summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /xfce-base/xfce4-appfinder
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'xfce-base/xfce4-appfinder')
-rw-r--r--xfce-base/xfce4-appfinder/Manifest2
-rw-r--r--xfce-base/xfce4-appfinder/metadata.xml8
-rw-r--r--xfce-base/xfce4-appfinder/xfce4-appfinder-4.10.1.ebuild36
-rw-r--r--xfce-base/xfce4-appfinder/xfce4-appfinder-4.12.0-r1.ebuild36
4 files changed, 82 insertions, 0 deletions
diff --git a/xfce-base/xfce4-appfinder/Manifest b/xfce-base/xfce4-appfinder/Manifest
new file mode 100644
index 000000000000..608a4b93ecf0
--- /dev/null
+++ b/xfce-base/xfce4-appfinder/Manifest
@@ -0,0 +1,2 @@
+DIST xfce4-appfinder-4.10.1.tar.bz2 446043 SHA256 65ee74ffa76334d273e4c9ae501ec7f81f7de028813849f7d1441cbf7788eb77 SHA512 5a9e1ac2d140549fa332bb8578cd12291a331ed017b72b0684aba9d36b16bf3231552a2d5f6aa5b0ccaf9fe2b899d42872f6726a80e4f68a80474092dd245a28 WHIRLPOOL 08284445624ab935ab38a12eb4d0faaf61fc717a3343b91ee3bf91002c282c1afd3f6ae5dcbba0ab04dba15b7ffa921ddcefe6f05cbdaeb724cca9e68a35c7a3
+DIST xfce4-appfinder-4.12.0.tar.bz2 459338 SHA256 2ad4a58019a76a6b64a816050db25f96854917c2f2e89d6a9df6c18e6c84c567 SHA512 025d38f9f2d57d1bcc37d38f4956742593cbee820ccf7d375138ca3eb0a9614090e3b969aba9d80b546eac43d2a9fd6c530ff829f0e4f59621ca068159e9adaf WHIRLPOOL e7d4ac9d25861a45d9b6ac94d66bf6631b7e7c2354d87a4bb7ce96e094f0dda61dbd88eb4edc9900733cb5488906a932e7ff521a2be48c76dc716579033692d4
diff --git a/xfce-base/xfce4-appfinder/metadata.xml b/xfce-base/xfce4-appfinder/metadata.xml
new file mode 100644
index 000000000000..008cf479f615
--- /dev/null
+++ b/xfce-base/xfce4-appfinder/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>xfce@gentoo.org</email>
+ <name>XFCE Team</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/xfce-base/xfce4-appfinder/xfce4-appfinder-4.10.1.ebuild b/xfce-base/xfce4-appfinder/xfce4-appfinder-4.10.1.ebuild
new file mode 100644
index 000000000000..0c8b66646222
--- /dev/null
+++ b/xfce-base/xfce4-appfinder/xfce4-appfinder-4.10.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="A tool to find and launch installed applications for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/dbus-glib-0.100
+ >=dev-libs/glib-2.24
+ >=x11-libs/gtk+-2.20:2
+ >=xfce-base/garcon-0.2
+ >=xfce-base/libxfce4util-4.10
+ >=xfce-base/libxfce4ui-4.10
+ >=xfce-base/xfconf-4.10
+ !xfce-base/xfce-utils"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS )
+}
diff --git a/xfce-base/xfce4-appfinder/xfce4-appfinder-4.12.0-r1.ebuild b/xfce-base/xfce4-appfinder/xfce4-appfinder-4.12.0-r1.ebuild
new file mode 100644
index 000000000000..b7244141195d
--- /dev/null
+++ b/xfce-base/xfce4-appfinder/xfce4-appfinder-4.12.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="A tool to find and launch installed applications for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/glib-2.30:=
+ >=x11-libs/gtk+-3.2:3=
+ >=xfce-base/garcon-0.3:=
+ >=xfce-base/libxfce4util-4.11:=
+ >=xfce-base/libxfce4ui-4.11:=[gtk3(+)]
+ >=xfce-base/xfconf-4.10:=
+ !xfce-base/xfce-utils"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ --enable-gtk3
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS )
+}