summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-15 15:39:05 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-15 16:03:57 +0100
commit030ceb70667f8bb07d325e54e8bd676f8f73b9ce (patch)
treebb094f1741602d47e60ee5be19d52131a287e357 /xfce-base/xfconf/xfconf-4.17.1.ebuild
parentxfce-base/xfce4-panel: Bump to 4.18.0 (diff)
downloadgentoo-030ceb70667f8bb07d325e54e8bd676f8f73b9ce.tar.gz
gentoo-030ceb70667f8bb07d325e54e8bd676f8f73b9ce.tar.bz2
gentoo-030ceb70667f8bb07d325e54e8bd676f8f73b9ce.zip
xfce-base/xfconf: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base/xfconf/xfconf-4.17.1.ebuild')
-rw-r--r--xfce-base/xfconf/xfconf-4.17.1.ebuild78
1 files changed, 0 insertions, 78 deletions
diff --git a/xfce-base/xfconf/xfconf-4.17.1.ebuild b/xfce-base/xfconf/xfconf-4.17.1.ebuild
deleted file mode 100644
index 68bc11da4d43..000000000000
--- a/xfce-base/xfconf/xfconf-4.17.1.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit bash-completion-r1 vala
-
-DESCRIPTION="A configuration management system for Xfce"
-SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
-HOMEPAGE="
- https://docs.xfce.org/xfce/xfconf/start
- https://gitlab.xfce.org/xfce/xfconf/
-"
-
-LICENSE="GPL-2+"
-SLOT="0/3"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
-IUSE="debug +introspection vala"
-REQUIRED_USE="vala? ( introspection )"
-
-DEPEND="
- >=dev-libs/glib-2.50
- sys-apps/dbus
- >=xfce-base/libxfce4util-4.17.2:=
- introspection? ( >=dev-libs/gobject-introspection-1.66:= )
-"
-RDEPEND="
- ${DEPEND}
-"
-BDEPEND="
- dev-util/gdbus-codegen
- dev-util/glib-utils
- dev-util/intltool
- sys-devel/gettext
- virtual/pkgconfig
- vala? ( $(vala_depend) )
-"
-
-src_configure() {
- local myconf=(
- $(use_enable introspection)
- $(use_enable vala)
- $(use_enable debug checks)
- --with-bash-completion-dir="$(get_bashcompdir)"
- )
-
- use vala && vala_setup
- econf "${myconf[@]}"
-}
-
-src_test() {
- local service_dir=${HOME}/.local/share/dbus-1/services
- mkdir -p "${service_dir}" || die
- cat > "${service_dir}/org.xfce.Xfconf.service" <<-EOF || die
- [D-BUS Service]
- Name=org.xfce.Xfconf
- Exec=${S}/xfconfd/xfconfd
- EOF
-
- (
- # start isolated dbus session bus
- dbus_data=$(dbus-launch --sh-syntax) || exit
- eval "${dbus_data}"
-
- # -j>1 often hangs
- # https://gitlab.xfce.org/xfce/xfconf/-/issues/13
- nonfatal emake -j1 check
- ret=${?}
-
- kill "${DBUS_SESSION_BUS_PID}"
- exit "${ret}"
- ) || die
-}
-
-src_install() {
- default
- find "${D}" -type f -name '*.la' -delete || die
-}