summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-23 00:26:17 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-23 00:35:43 +0100
commit13d5905060132c798116e192b956135af498c968 (patch)
tree31cea22b96311174b143371c0ade38ef4386083e /xfce-base
parentxfce-base/libxfce4ui: Bump to 4.16.0 (diff)
downloadgentoo-13d5905060132c798116e192b956135af498c968.tar.gz
gentoo-13d5905060132c798116e192b956135af498c968.tar.bz2
gentoo-13d5905060132c798116e192b956135af498c968.zip
xfce-base/xfwm4: Bump to 4.16.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/xfwm4/Manifest1
-rw-r--r--xfce-base/xfwm4/xfwm4-4.16.0.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/xfce-base/xfwm4/Manifest b/xfce-base/xfwm4/Manifest
index ba0c673daac5..0b0738841f74 100644
--- a/xfce-base/xfwm4/Manifest
+++ b/xfce-base/xfwm4/Manifest
@@ -1,2 +1,3 @@
DIST xfwm4-4.14.6.tar.bz2 1167818 BLAKE2B 2315843da3684ea069d8361d1d787634052da5449d7aeb4ba6b219cd46ae4b7b6007becca316a5ab552fe4432baab3efa6a23793b68a00d06c9fbe3d1164080a SHA512 1e3cc3e976250e311607d12e1a51047132584d6e8cd8979e3d5a85a3cc49e420453e3812b2d8a8f6268f3d6f1b44f4df2b57b7e1395d02ec63ae82a55bb9d4ee
DIST xfwm4-4.15.3.tar.bz2 1180308 BLAKE2B e76651e58bdb6b4c4b15c6dd49d5df16b40729fc41302d0eff336194d84a8b467c9b6b2f37094657b0555c25d87d92744991dfc00127638468b23eae31088475 SHA512 6ca7faba7fdd225d1c91e7c217200eebf271abc6058f3b9a46ce7bce8f31028c99e454412afa4ca441a5b30decb0d33a03ca5caeed7e4b20a29efa855af8328d
+DIST xfwm4-4.16.0.tar.bz2 1200929 BLAKE2B 2df17028287ff3e4fea7ea082ea39545a05fba5089fbaea1764bbb59ff550d9dbf14322246d9dcd455bc589055c75b7941f08f6ab4a59fe2089001236ab8677b SHA512 f21e773b34092cadd86713373e59880cf68020cbfa3d16ab651f48a8a051a38925428358e0bca5ffc346eb62dc6cc53c87a9e6895d7e613dadf3cdac499dae02
diff --git a/xfce-base/xfwm4/xfwm4-4.16.0.ebuild b/xfce-base/xfwm4/xfwm4-4.16.0.ebuild
new file mode 100644
index 000000000000..26cb91f81588
--- /dev/null
+++ b/xfce-base/xfwm4/xfwm4-4.16.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="Window manager for the Xfce desktop environment"
+HOMEPAGE="https://www.xfce.org/projects/"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="opengl startup-notification +xcomposite +xpresent"
+
+RDEPEND=">=dev-libs/glib-2.20
+ >=x11-libs/gtk+-3.22:3
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXres
+ x11-libs/pango
+ >=x11-libs/libwnck-3.14:3
+ >=xfce-base/libxfce4util-4.10:=
+ >=xfce-base/libxfce4ui-4.12:=
+ >=xfce-base/xfconf-4.13:=
+ opengl? ( media-libs/libepoxy:=[X(+)] )
+ startup-notification? ( x11-libs/startup-notification )
+ xpresent? ( x11-libs/libXpresent )
+ xcomposite? (
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXfixes
+ )"
+# libICE/libSM: not really used anywhere but checked by configure
+# https://bugzilla.xfce.org/show_bug.cgi?id=11914
+DEPEND="${RDEPEND}
+ x11-libs/libICE
+ x11-libs/libSM"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ xfce-base/exo
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ $(use_enable opengl epoxy)
+ $(use_enable startup-notification)
+ --enable-xsync
+ --enable-render
+ --enable-randr
+ $(use_enable xpresent)
+ $(use_enable xcomposite compositor)
+ )
+
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}