summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-01 16:56:48 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-01 16:57:30 +0200
commit28ec04997ac82cefe68d345f476b7ba4a20d47ec (patch)
tree8b1fe8ea9c75447fc5b83f45888af6be0237b01a /xfce-base
parentsys-kernel/gentoo-kernel-bin: Bump to 5.7.12 (diff)
downloadgentoo-28ec04997ac82cefe68d345f476b7ba4a20d47ec.tar.gz
gentoo-28ec04997ac82cefe68d345f476b7ba4a20d47ec.tar.bz2
gentoo-28ec04997ac82cefe68d345f476b7ba4a20d47ec.zip
xfce-base/xfwm4: Bump to 4.15.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/xfwm4/Manifest1
-rw-r--r--xfce-base/xfwm4/xfwm4-4.15.0.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/xfce-base/xfwm4/Manifest b/xfce-base/xfwm4/Manifest
index 4a526bb86926..e92693d811aa 100644
--- a/xfce-base/xfwm4/Manifest
+++ b/xfce-base/xfwm4/Manifest
@@ -2,3 +2,4 @@ DIST xfwm4-4.14.0.tar.bz2 1122735 BLAKE2B 1865c0714ddd4107e806de5607ef0e260c3fd1
DIST xfwm4-4.14.2.tar.bz2 1158799 BLAKE2B 87270997688a44e1476935f2158842999befebf18628f6cd92131d81beac2f0a91db0a6522f86340688285fd67cf48e94259bdb2e4ce8df567eba83319bb31e3 SHA512 9e28f7782ce6c1734f9a50efec75d4c03a193bf078fd29f42c11770cef134c4516c256cb9c4b92a71bbbbfca81f37ba0ce19477831bb1da858c839135005b8f2
DIST xfwm4-4.14.3.tar.bz2 1164653 BLAKE2B 24db309df708164bd0554fb96499205b4f1437023c014d571ba86f7419e09e23ffdacbf31d3afd05b7bd4f4e8e88394cfe34ec233518078b88eb8c0c640b8af7 SHA512 eb27c9d540a4b1d773f31c16dd8e7e4cd8fb833514ecc62251c68b53e88440beccb4923c49c66a29b387c77e2e69cb36e83d0a3d457ef8e7fdd5d2b925fdfda6
DIST xfwm4-4.14.4.tar.bz2 1164972 BLAKE2B 5bdf4837bd19708c975d6400750059c5182b9d1b1a0b7b30e8721e1c443d9f78c1ea1c868ad7ceb384e442b94139b89d50327dc6413e938348816a311cada2b2 SHA512 ca3c94d1835076b904aca9f531dccebd9d78a1c85e0f7af7ac7aaba1a067e0f11f5224bdc20dc233038dc752ae1ac85602608c168a4d91643ac7538b448c04bf
+DIST xfwm4-4.15.0.tar.bz2 1179779 BLAKE2B c12ec365218b8afda7b01706d4f2822b4663d327aad482e89f8c8b2811b687594c6f58ea0b5be79eabe3771c125edb111c3b03a708dcfbf720eef993181b0e14 SHA512 8359c8e9414bc7a66a95c4b9eb98da7a3ba08c0e15752c2ebb4a569f9afcd50697d37685c786d6a4c23f1bfa12f8782293923fde309c7d027cf66dd4db44340e
diff --git a/xfce-base/xfwm4/xfwm4-4.15.0.ebuild b/xfce-base/xfwm4/xfwm4-4.15.0.ebuild
new file mode 100644
index 000000000000..77ed670eb91b
--- /dev/null
+++ b/xfce-base/xfwm4/xfwm4-4.15.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="Window manager for the Xfce desktop environment"
+HOMEPAGE="https://www.xfce.org/projects/"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="opengl startup-notification +xcomposite +xpresent"
+
+RDEPEND=">=dev-libs/glib-2.20
+ >=x11-libs/gtk+-3.20:3
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXres
+ x11-libs/pango
+ >=x11-libs/libwnck-3.14:3
+ >=xfce-base/libxfce4util-4.10:=
+ >=xfce-base/libxfce4ui-4.12:=
+ >=xfce-base/xfconf-4.13:=
+ opengl? ( media-libs/libepoxy:=[X(+)] )
+ startup-notification? ( x11-libs/startup-notification )
+ xpresent? ( x11-libs/libXpresent )
+ xcomposite? (
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXfixes
+ )"
+# libICE/libSM: not really used anywhere but checked by configure
+# https://bugzilla.xfce.org/show_bug.cgi?id=11914
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ x11-libs/libICE
+ x11-libs/libSM
+ xfce-base/exo
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog COMPOSITOR NEWS README TODO )
+
+src_configure() {
+ local myconf=(
+ $(use_enable opengl epoxy)
+ $(use_enable startup-notification)
+ --enable-xsync
+ --enable-render
+ --enable-randr
+ $(use_enable xpresent)
+ $(use_enable xcomposite compositor)
+ )
+
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}