summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-28 23:01:27 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-28 23:08:31 +0200
commit0173ba73228031023d39a2082e0aa79601a6fbf1 (patch)
tree62650e29c9fa60c672dae573d96520406889381a /xfce-extra/xfce4-power-manager
parentxfce-extra/xfce4-power-manager: Drop old (diff)
downloadgentoo-0173ba73228031023d39a2082e0aa79601a6fbf1.tar.gz
gentoo-0173ba73228031023d39a2082e0aa79601a6fbf1.tar.bz2
gentoo-0173ba73228031023d39a2082e0aa79601a6fbf1.zip
xfce-extra/xfce4-power-manager: Bump to 1.6.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra/xfce4-power-manager')
-rw-r--r--xfce-extra/xfce4-power-manager/Manifest1
-rw-r--r--xfce-extra/xfce4-power-manager/xfce4-power-manager-1.6.4.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-power-manager/Manifest b/xfce-extra/xfce4-power-manager/Manifest
index 721b46ea20e6..3472604aff43 100644
--- a/xfce-extra/xfce4-power-manager/Manifest
+++ b/xfce-extra/xfce4-power-manager/Manifest
@@ -1,2 +1,3 @@
DIST xfce4-power-manager-1.6.1.tar.bz2 1180710 BLAKE2B bffb5f00a42a3242a0b9d35b48fe6d9813d3292757844e911a8e71d05cb59f2f91d93ab5a77ac15ae35c90ccfa60ce39db23bc94a0350232538c8621fec4473f SHA512 b81ce1b35892a6cd0b1d4fb590ccc25b906cde6f782de2fffbe78ea89e00df15e51ea1f47576c173b7512cd617f5142868fca8cf81519b6fe165a5ecc67a5478
DIST xfce4-power-manager-1.6.3.tar.bz2 1216971 BLAKE2B 872011a6d18841aa7b9cfee3b9aa91e75b7db95a77dd8ac3484ebdc5d289c375a7c805d8638650e72870b8eaddd71bfac74a5e3f568b8ca1366160c972c61cc4 SHA512 4a3c629bf14b3214d57df9b9a5fc77ec675e02c300c508525634bcaf38d94ab0f6e125ea5ec7bd41c1d0c3d065dfb3ab1937ee7f1006adc0093142f466950c6b
+DIST xfce4-power-manager-1.6.4.tar.bz2 1216948 BLAKE2B bc89c30f1668e4cef662336c3294bc0ac495e3a8350d4bcd1c4f514a52840482b9129a822e4e3edee5379f32cf9df897564493e444b2c4607ec5cd8c6a562d43 SHA512 0d1aee648d4fbd1543dc65abf97eb9c7da7d5eb39d034ea9c99a6e9c2144854f6fcd12d5581d1bf1a31afb308f0ff34d4f6888a766c1eb7d0f1d63765a73e02d
diff --git a/xfce-extra/xfce4-power-manager/xfce4-power-manager-1.6.4.ebuild b/xfce-extra/xfce4-power-manager/xfce4-power-manager-1.6.4.ebuild
new file mode 100644
index 000000000000..f7dd4f54e23d
--- /dev/null
+++ b/xfce-extra/xfce4-power-manager/xfce4-power-manager-1.6.4.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit xdg-utils
+
+DESCRIPTION="Power manager for the Xfce desktop environment"
+HOMEPAGE="https://goodies.xfce.org/projects/applications/xfce4-power-manager"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="kernel_linux networkmanager +panel-plugin policykit"
+
+COMMON_DEPEND=">=dev-libs/glib-2.42:=
+ >=sys-power/upower-0.99.0
+ sys-power/pm-utils
+ >=x11-libs/gtk+-3.14:3=
+ >=x11-libs/libnotify-0.7:=
+ x11-libs/libX11:=
+ >=x11-libs/libXrandr-1.2:=
+ x11-libs/libXext:=
+ x11-libs/libXtst:=
+ >=xfce-base/xfconf-4.12:=
+ >=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.12:=
+ panel-plugin? ( >=xfce-base/xfce4-panel-4.12:= )
+ policykit? ( >=sys-auth/polkit-0.112 )"
+RDEPEND="${COMMON_DEPEND}
+ networkmanager? ( net-misc/networkmanager )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ x11-base/xorg-proto"
+
+src_configure() {
+ local myconf=(
+ $(use_enable policykit polkit)
+ $(use_enable networkmanager network-manager)
+ $(use_enable panel-plugin xfce4panel)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}