summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-12-26 12:56:42 +0100
committerMichał Górny <mgorny@gentoo.org>2018-12-26 14:34:23 +0100
commitfee47870046209fc5868f646e0dbfd89a9fc9b6b (patch)
treed104cea6405e591ddc963ec7cbaae4af83a6a00e /xfce-extra/xfce4-taskmanager
parentdev-util/meson: stable 0.48.2 for ia64, bug #672472 (diff)
downloadgentoo-fee47870046209fc5868f646e0dbfd89a9fc9b6b.tar.gz
gentoo-fee47870046209fc5868f646e0dbfd89a9fc9b6b.tar.bz2
gentoo-fee47870046209fc5868f646e0dbfd89a9fc9b6b.zip
xfce-extra/xfce4-taskmanager: Bump to 1.2.2, now GTK+3 by default
Bump to the new version which -- besides some bugfixes -- switches the default from GTK+2 to GTK+3. While GTK+2 is still technically supported, the configure bug requiring the default toolkit unconditionally has not been fixed, and upstream plans to remove GTK+2 support altogether in the next release. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra/xfce4-taskmanager')
-rw-r--r--xfce-extra/xfce4-taskmanager/Manifest1
-rw-r--r--xfce-extra/xfce4-taskmanager/xfce4-taskmanager-1.2.2.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-taskmanager/Manifest b/xfce-extra/xfce4-taskmanager/Manifest
index 5332ca5a8de3..c3cc8ba6d59b 100644
--- a/xfce-extra/xfce4-taskmanager/Manifest
+++ b/xfce-extra/xfce4-taskmanager/Manifest
@@ -1,2 +1,3 @@
DIST xfce4-taskmanager-1.2.0.tar.bz2 435276 BLAKE2B 857494cedf5f6a43280379f1468ce55acaddac51e8e73a02a59bf96148fffa18a20da8a55099b404eb073fb971d7bb72bb597fc7089d0927d9219a76cadfd460 SHA512 45a496dc406eb825b9829a9cd0b76250566df0bf57dd39413112512209936b52cd3271fd1933dd972582178d897ef40ab8e106b2980db6963d29373940fdcc2d
DIST xfce4-taskmanager-1.2.1.tar.bz2 394704 BLAKE2B 0fc1d43aafec3301687faca4ba6f6a3bef4d3cdf682c9220522557bf9c999b0979b658b0153108308fa38abcf933b9d3e6a82a55aec19bb1e3b81c60def1c116 SHA512 72a1ea75403ef5b96d461f0e4846374f7aa3eebbdd09a1a25c49278e4909904ed6305fe6a06f3a2fc370e191421726b96924e35427253428e968665155808d4e
+DIST xfce4-taskmanager-1.2.2.tar.bz2 395320 BLAKE2B d844e4db79ca110c4f83a7fd6c9b813cd6cb4bfb8639d3bcc0b2ec19f9e81c1df1bf6f1dac6f4df3d5f004e85d48a5f504bdd7781bb720b13fbdf508895c820f SHA512 670e8fd09bdaa85dc822dd5a7b055f898941e8079315843344e4dae12e2c0a14049b58241fb58f170461e7b8829bc479bea1a488b756210ef91ef8a4d7ff3348
diff --git a/xfce-extra/xfce4-taskmanager/xfce4-taskmanager-1.2.2.ebuild b/xfce-extra/xfce4-taskmanager/xfce4-taskmanager-1.2.2.ebuild
new file mode 100644
index 000000000000..12aa5a2754c0
--- /dev/null
+++ b/xfce-extra/xfce4-taskmanager/xfce4-taskmanager-1.2.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils
+
+DESCRIPTION="Easy to use task manager"
+HOMEPAGE="https://goodies.xfce.org/projects/applications/xfce4-taskmanager"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ x11-libs/cairo:=
+ x11-libs/libX11:=
+ x11-libs/libXmu:=
+ x11-libs/gtk+:3=
+ x11-libs/libwnck:3="
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ --enable-wnck
+ # GTK+3 is required unconditionally anyway
+ --disable-gtk2
+ --disable-gksu
+ )
+
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}