summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-02-16 21:08:46 +0100
committerMichał Górny <mgorny@gentoo.org>2017-02-16 22:06:11 +0100
commitc995d11f6d99483f2217b76fd2d77bbe6ca2d3bc (patch)
treef137e99c2b9794e96c73de8e4968455106171468 /xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.8.9.ebuild
parentdev-python/jedi: version bump to 0.10.0 (diff)
downloadgentoo-c995d11f6d99483f2217b76fd2d77bbe6ca2d3bc.tar.gz
gentoo-c995d11f6d99483f2217b76fd2d77bbe6ca2d3bc.tar.bz2
gentoo-c995d11f6d99483f2217b76fd2d77bbe6ca2d3bc.zip
xfce-extra/xfce4-weather-plugin: Bump to 0.8.9, EAPI=6
Diffstat (limited to 'xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.8.9.ebuild')
-rw-r--r--xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.8.9.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.8.9.ebuild b/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.8.9.ebuild
new file mode 100644
index 000000000000..af86d24247e5
--- /dev/null
+++ b/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.8.9.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="A weather plug-in for the Xfce desktop environment"
+HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-weather-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="upower"
+
+RDEPEND=">=dev-libs/glib-2.20:=
+ dev-libs/libxml2:=
+ >=net-libs/libsoup-2.32:=
+ >=x11-libs/gtk+-2.14:2=
+ >=xfce-base/libxfce4ui-4.10:=
+ >=xfce-base/libxfce4util-4.10:=
+ >=xfce-base/xfce4-panel-4.10:=
+ upower? ( || ( >=sys-power/upower-0.9.23 sys-power/upower-pm-utils ) )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+src_configure() {
+ # For GEONAMES_USERNAME, read README file and ask ssuominen@!
+ local myconf=(
+ $(use_enable upower)
+ GEONAMES_USERNAME=Gentoo
+ )
+ econf "${myconf[@]}"
+}