summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2019-10-30 08:41:01 -0400
committerMichael Orlitzky <mjo@gentoo.org>2019-10-30 08:43:20 -0400
commit67bcbb21f42e1184de333d54b67037d34225ef85 (patch)
tree41d2136d608ae7f2c63aa34959cbec800206f0fc /xfce-extra
parentdev-java/maven-bin: amd64 stable wrt bug #698908 (diff)
downloadgentoo-67bcbb21f42e1184de333d54b67037d34225ef85.tar.gz
gentoo-67bcbb21f42e1184de333d54b67037d34225ef85.tar.bz2
gentoo-67bcbb21f42e1184de333d54b67037d34225ef85.zip
xfce-extra/xfce4-hdaps: new gtk+-3.x version.
New upstream version, new license, new dependencies, new EAPI, new eclasses, etc. I'm no longer bothering to check for a "recent" 2.6 kernel. But overall, everything should work pretty much the same. Closes: https://bugs.gentoo.org/698104 Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-hdaps/Manifest1
-rw-r--r--xfce-extra/xfce4-hdaps/xfce4-hdaps-1.0.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-hdaps/Manifest b/xfce-extra/xfce4-hdaps/Manifest
index 2796270a3354..fc4f01072aa3 100644
--- a/xfce-extra/xfce4-hdaps/Manifest
+++ b/xfce-extra/xfce4-hdaps/Manifest
@@ -1 +1,2 @@
DIST xfce4-hdaps-0.0.9.tar.bz2 304851 BLAKE2B 1f1318bb27628eb1ff72a1642737271ab37e722a18a6c3c6d40c7a05f56e36813bc7a570d5bc51d169dfcc89467cb6173d61c2f0cc2c90a90a795ba63ef1e07d SHA512 7ee963dacd3e1096fb205fa78c05202925977a4fc88aaa96ba779dc08e32937602fdc83a27457386b2b89847487c5dcc75385f2763201b1613f30eee8124e740
+DIST xfce4-hdaps-1.0.0.tar.xz 350888 BLAKE2B bc34321f42b0f51a10ef65429cdcf5e3d63f20914aa0c593c004c830932c8a63f194a25b602784527f5da0f74302142ccbcb3ecfc2a677b004b71e5bad4e5ee5 SHA512 0efdedbccfe578304e61cccb86936b4d62e9e3de6cb9c3cf7b288983b93bd8388e1b227565ebe354aadbd58fc493b67e5c3fea02bf9dbc1b37b5d2ec419a5d7b
diff --git a/xfce-extra/xfce4-hdaps/xfce4-hdaps-1.0.0.ebuild b/xfce-extra/xfce4-hdaps/xfce4-hdaps-1.0.0.ebuild
new file mode 100644
index 000000000000..a680a7fb6696
--- /dev/null
+++ b/xfce-extra/xfce4-hdaps/xfce4-hdaps-1.0.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit xdg-utils
+
+DESCRIPTION="Show the status of the IBM Hard Drive Active Protection System"
+HOMEPAGE="http://michael.orlitzky.com/code/xfce4-hdaps.xhtml"
+SRC_URI="http://michael.orlitzky.com/code/releases/${P}.tar.xz"
+
+LICENSE="AGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND="dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+DEPEND=">=x11-libs/gtk+-3.20:3
+ x11-libs/libX11
+ >=xfce-base/libxfce4ui-4.14
+ >=xfce-base/libxfce4util-4.14
+ >=xfce-base/xfce4-panel-4.14:="
+RDEPEND="${DEPEND}
+ app-laptop/hdapsd
+ app-laptop/tp_smapi"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}