summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pyformance/Manifest1
-rw-r--r--dev-python/pyformance/pyformance-0.3.4.ebuild32
-rw-r--r--dev-python/pyformance/pyformance-0.4.ebuild32
3 files changed, 0 insertions, 65 deletions
diff --git a/dev-python/pyformance/Manifest b/dev-python/pyformance/Manifest
index eb27933535b8..675193548324 100644
--- a/dev-python/pyformance/Manifest
+++ b/dev-python/pyformance/Manifest
@@ -1,3 +1,2 @@
-DIST pyformance-0.3.4.tar.gz 19394 BLAKE2B 4bd141df5b3264ae8abb5b5314fcba93aeeab960e4d1d70631a3d5ac072f94a2da48b480f74c446124fb9fbd54a8ffad9c75b2352509aaf991025a02bf736648 SHA512 5dbc83da62bf66767eaaf316824cf5683488d8ee594b72baee327c4ef594f84b5aed07654da483aff29bee98605e5265425be88c165a4bb06e7bdddbbf28e440
DIST pyformance-0.4-patches.tar.xz 3500 BLAKE2B 511001e9011db5ef25b802739dca51337d039193a9d3322bbf94bcb120bbbeff2e1a818217970a1a97d77cd8d7da462792248910acbb3ef586704596276b7056 SHA512 858cefd6c8b151db10c63e0d8117cd6c226bd153103993040909e8fd2ab7a41a7770a2ae6de0f395a4f9f6cce3213d7ecabc0bf647657ee04fc10d76f51e07e3
DIST pyformance-0.4.tar.gz 20683 BLAKE2B d818832b7ff43a7e1db888bdb7dc333a532c7d3365dd472f9dbb3300f676cd3cc8f82f8d1c444aa277404ff8e72843eca35e3905542700ea37b1dad3e05c8b4c SHA512 a03324977b40f5097ae4608dd7c36bdbd2a20b261c9d3e32d1be19e5fca50e17fcc24df781b6c3ab60314534368c5e9cf08bc3863d4d2d7ecc59f9af26f8d20e
diff --git a/dev-python/pyformance/pyformance-0.3.4.ebuild b/dev-python/pyformance/pyformance-0.3.4.ebuild
deleted file mode 100644
index 65e0604698fb..000000000000
--- a/dev-python/pyformance/pyformance-0.3.4.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Performance metrics, based on Coda Hale's Yammer metrics"
-HOMEPAGE="https://pyformance.readthedocs.org/ https://github.com/omergertel/pyformance/ https://pypi.org/project/pyformance/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}] )"
-
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
-
-python_prepare() {
- sed -i -e "s/find_packages()/find_packages(exclude=['tests'])/" setup.py || die
- sed -i -e "s/URLError, err/URLError as err/" ${PN}/reporters/influx.py || die
-}
-
-python_test() {
- py.test || die
-}
diff --git a/dev-python/pyformance/pyformance-0.4.ebuild b/dev-python/pyformance/pyformance-0.4.ebuild
deleted file mode 100644
index 0092fe0ab5a3..000000000000
--- a/dev-python/pyformance/pyformance-0.4.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Performance metrics, based on Coda Hale's Yammer metrics"
-HOMEPAGE="https://pyformance.readthedocs.org/ https://github.com/omergertel/pyformance/ https://pypi.org/project/pyformance/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}] )"
-
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
-
-python_prepare() {
- sed -i -e "s/find_packages()/find_packages(exclude=['tests'])/" setup.py || die
-}
-
-python_test() {
- py.test || die
-}