summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/pcsc-lite/Manifest2
-rw-r--r--sys-apps/pcsc-lite/pcsc-lite-1.8.20.ebuild108
-rw-r--r--sys-apps/pcsc-lite/pcsc-lite-1.8.21.ebuild108
3 files changed, 0 insertions, 218 deletions
diff --git a/sys-apps/pcsc-lite/Manifest b/sys-apps/pcsc-lite/Manifest
index 72971604076d..fc57135823cb 100644
--- a/sys-apps/pcsc-lite/Manifest
+++ b/sys-apps/pcsc-lite/Manifest
@@ -1,3 +1 @@
-DIST pcsc-lite-1.8.20.tar.bz2 745049 BLAKE2B 211b463c63b25f1dab629e8c32ccc6f19f28baf7b62029610dc9c2163ba2392f9ffa3d17671ae93c35e0ae3768a82ed5a5f245b8d3ea5f4c46013a07896a00b5 SHA512 63fea660d71605ebced5600a59ab5b6a735c4ba3697faf7658d91b8e281a7fb2a2bca6831c8f8c8c87b87a54f7fd03ae818a4c496dcbac0afce523e3b6c606b8
-DIST pcsc-lite-1.8.21.tar.bz2 750879 BLAKE2B dc12fbef1e91a649c1df77603788f3b8eb9f4d3a38f40d54c8d5ea16135312f48d92c4d5706b667ac0db5491467881a8b557a9c56bb14b168c28d06e6e731642 SHA512 bd3740f4444d2201efaa34a312d2a5f6b5808b0b7ff1d5696dce26df67ef198a63a96670d0acac97a6e693b33079afeeeaa6692746875b0ff72d69a2b0835990
DIST pcsc-lite-1.8.22.tar.bz2 751724 BLAKE2B d11ca9588449ea8508550b60aad2d2bb6a140c02a86287f6d972ced97fdc8a5db80d542624cbaebdda564192217186c79c30b046cb7d6f6c7a450d91c0f1c9fb SHA512 762eccf6a25040653f563b93bf11262ddc015323d06d759a3472ba80af0489804410ba17c7e5330ccd4b5accc8b7314c80b5e99da278561d3818d8c381e6a025
diff --git a/sys-apps/pcsc-lite/pcsc-lite-1.8.20.ebuild b/sys-apps/pcsc-lite/pcsc-lite-1.8.20.ebuild
deleted file mode 100644
index 435f3790d8a0..000000000000
--- a/sys-apps/pcsc-lite/pcsc-lite-1.8.20.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-PYTHON_COMPAT=( python2_7 )
-
-inherit python-single-r1 systemd udev user multilib-minimal
-
-DESCRIPTION="PC/SC Architecture smartcard middleware library"
-HOMEPAGE="https://pcsclite.alioth.debian.org/"
-
-STUPID_NUM="4203"
-MY_P="${PN}-${PV/_/-}"
-SRC_URI="https://alioth.debian.org/download.php/file/${STUPID_NUM}/${MY_P}.tar.bz2"
-S="${WORKDIR}/${MY_P}"
-
-# GPL-2 is there for the init script; everything else comes from
-# upstream.
-LICENSE="BSD ISC MIT GPL-3+ GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~m68k ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-
-# This is called libusb so that it doesn't fool people in thinking that
-# it is _required_ for USB support. Otherwise they'll disable udev and
-# that's going to be worse.
-IUSE="python libusb policykit selinux +udev"
-
-REQUIRED_USE="^^ ( udev libusb ) \
- python? ( ${PYTHON_REQUIRED_USE} )"
-
-# No dependencies need the MULTILIB_DEPS because the libraries are actually
-# standalone, the deps are only needed for the daemon itself.
-CDEPEND="libusb? ( virtual/libusb:1 )
- udev? ( virtual/udev )
- policykit? ( >=sys-auth/polkit-0.111 )
- python? ( ${PYTHON_DEPS} )"
-DEPEND="${CDEPEND}
- virtual/pkgconfig"
-RDEPEND="${CDEPEND}
- !<app-crypt/ccid-1.4.1-r1
- !<sys-apps/baselayout-2
- !<sys-apps/openrc-0.11.8
- selinux? ( sec-policy/selinux-pcscd )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.8.11-polkit-pcscd.patch
-)
-
-DOCS=( AUTHORS DRIVERS HELP README SECURITY ChangeLog )
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
- enewgroup openct # make sure it exists
- enewgroup pcscd
- enewuser pcscd -1 -1 /run/pcscd pcscd,openct
-}
-
-multilib_src_configure() {
- ECONF_SOURCE="${S}" econf \
- --disable-maintainer-mode \
- --enable-usbdropdir="${EPREFIX}/usr/$(get_libdir)/readers/usb" \
- --enable-ipcdir=/run/pcscd \
- --with-systemdsystemunitdir="$(systemd_get_systemunitdir)" \
- $(multilib_native_use_enable udev libudev) \
- $(multilib_native_use_enable libusb) \
- $(multilib_native_use_enable policykit polkit)
-}
-
-multilib_src_install_all() {
- einstalldocs
-
- newinitd "${FILESDIR}"/pcscd-init.7 pcscd
-
- if use udev; then
- insinto "$(get_udevdir)"/rules.d
- doins "${FILESDIR}"/99-pcscd-hotplug.rules
- fi
-
- for f in "${ED}/usr/bin/pcsc-spy"; do
- if use python; then
- python_fix_shebang "${f}"
- else
- rm "${f}"
- fi
- done
-}
-
-pkg_postinst() {
- elog "Starting from version 1.6.5, pcsc-lite will start as user nobody in"
- elog "the pcscd group, to avoid running as root."
- elog ""
- elog "This also means you need the newest drivers available so that the"
- elog "devices get the proper owner."
- elog ""
- elog "Furthermore, a conf.d file is no longer installed by default, as"
- elog "the default configuration does not require one. If you need to"
- elog "pass further options to pcscd, create a file and set the"
- elog "EXTRA_OPTS variable."
- elog ""
- if use udev; then
- elog "Hotplug support is provided by udev rules; you only need to tell"
- elog "the init system to hotplug it, by setting this variable in"
- elog "/etc/rc.conf:"
- elog ""
- elog " rc_hotplug=\"pcscd\""
- fi
-}
diff --git a/sys-apps/pcsc-lite/pcsc-lite-1.8.21.ebuild b/sys-apps/pcsc-lite/pcsc-lite-1.8.21.ebuild
deleted file mode 100644
index 582b0f6a87fd..000000000000
--- a/sys-apps/pcsc-lite/pcsc-lite-1.8.21.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit python-single-r1 systemd udev user multilib-minimal
-
-DESCRIPTION="PC/SC Architecture smartcard middleware library"
-HOMEPAGE="https://pcsclite.alioth.debian.org/"
-
-STUPID_NUM="4216"
-MY_P="${PN}-${PV/_/-}"
-SRC_URI="https://alioth.debian.org/download.php/file/${STUPID_NUM}/${MY_P}.tar.bz2"
-S="${WORKDIR}/${MY_P}"
-
-# GPL-2 is there for the init script; everything else comes from
-# upstream.
-LICENSE="BSD ISC MIT GPL-3+ GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-
-# This is called libusb so that it doesn't fool people in thinking that
-# it is _required_ for USB support. Otherwise they'll disable udev and
-# that's going to be worse.
-IUSE="python libusb policykit selinux +udev"
-
-REQUIRED_USE="^^ ( udev libusb ) \
- python? ( ${PYTHON_REQUIRED_USE} )"
-
-# No dependencies need the MULTILIB_DEPS because the libraries are actually
-# standalone, the deps are only needed for the daemon itself.
-CDEPEND="libusb? ( virtual/libusb:1 )
- udev? ( virtual/udev )
- policykit? ( >=sys-auth/polkit-0.111 )
- python? ( ${PYTHON_DEPS} )"
-DEPEND="${CDEPEND}
- virtual/pkgconfig"
-RDEPEND="${CDEPEND}
- !<app-crypt/ccid-1.4.1-r1
- !<sys-apps/baselayout-2
- !<sys-apps/openrc-0.11.8
- selinux? ( sec-policy/selinux-pcscd )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.8.11-polkit-pcscd.patch
-)
-
-DOCS=( AUTHORS DRIVERS HELP README SECURITY ChangeLog )
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
- enewgroup openct # make sure it exists
- enewgroup pcscd
- enewuser pcscd -1 -1 /run/pcscd pcscd,openct
-}
-
-multilib_src_configure() {
- ECONF_SOURCE="${S}" econf \
- --disable-maintainer-mode \
- --enable-usbdropdir="${EPREFIX}/usr/$(get_libdir)/readers/usb" \
- --enable-ipcdir=/run/pcscd \
- --with-systemdsystemunitdir="$(systemd_get_systemunitdir)" \
- $(multilib_native_use_enable udev libudev) \
- $(multilib_native_use_enable libusb) \
- $(multilib_native_use_enable policykit polkit)
-}
-
-multilib_src_install_all() {
- einstalldocs
-
- newinitd "${FILESDIR}"/pcscd-init.7 pcscd
-
- if use udev; then
- insinto "$(get_udevdir)"/rules.d
- doins "${FILESDIR}"/99-pcscd-hotplug.rules
- fi
-
- for f in "${ED}/usr/bin/pcsc-spy"; do
- if use python; then
- python_fix_shebang "${f}"
- else
- rm "${f}"
- fi
- done
-}
-
-pkg_postinst() {
- elog "Starting from version 1.6.5, pcsc-lite will start as user nobody in"
- elog "the pcscd group, to avoid running as root."
- elog ""
- elog "This also means you need the newest drivers available so that the"
- elog "devices get the proper owner."
- elog ""
- elog "Furthermore, a conf.d file is no longer installed by default, as"
- elog "the default configuration does not require one. If you need to"
- elog "pass further options to pcscd, create a file and set the"
- elog "EXTRA_OPTS variable."
- elog ""
- if use udev; then
- elog "Hotplug support is provided by udev rules; you only need to tell"
- elog "the init system to hotplug it, by setting this variable in"
- elog "/etc/rc.conf:"
- elog ""
- elog " rc_hotplug=\"pcscd\""
- fi
-}