summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/ascii85/Manifest1
-rw-r--r--dev-ruby/ascii85/ascii85-1.1.1-r1.ebuild28
-rw-r--r--dev-ruby/ascii85/ascii85-2.0.1.ebuild29
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-ruby/ascii85/Manifest b/dev-ruby/ascii85/Manifest
index d05519f6cb71..1005060c5aab 100644
--- a/dev-ruby/ascii85/Manifest
+++ b/dev-ruby/ascii85/Manifest
@@ -1 +1,2 @@
DIST Ascii85-1.1.1.gem 12288 BLAKE2B 7886cc4e7745ace8bc615305f13e4cd081805b3d3eabc6d05fb84fb2bc1c3c26916ba1e4b8e891246fcd3b7c10320f90e994022f99723bb7692c13cda67af72a SHA512 6d2f9941ed88d4e7c3867a8c9da1bf56696195447be5f9edd5fc0f62231e60c2786363823703c26da9d614d776866a93a983d7e64a631532315c51b6eb258045
+DIST Ascii85-2.0.1.gem 15360 BLAKE2B 84eea4a0b8d6412a10b21f2eb6773a950fc062bea39bc1c56f18566f56cd661c5542ed5d30d0bd934a38cc2baec8d6cf973fd1c21dc9fb0cd9b0bf3270f14fce SHA512 91396977e688f6e3607cff2da741f002c3e1702e5def27eaa3be55589bc7f1eb8c67895911be718269b9dd8229dd0b7fa35b9a30ea52c30d23e28ad23672c65e
diff --git a/dev-ruby/ascii85/ascii85-1.1.1-r1.ebuild b/dev-ruby/ascii85/ascii85-1.1.1-r1.ebuild
new file mode 100644
index 000000000000..d5edfaf0b6f4
--- /dev/null
+++ b/dev-ruby/ascii85/ascii85-1.1.1-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md History.txt"
+
+RUBY_FAKEGEM_NAME="Ascii85"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Methods for encoding/decoding Adobe's binary-to-text encoding of the same name"
+HOMEPAGE="https://github.com/datawraith/ascii85gem"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+ruby_add_bdepend "test? ( dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+}
diff --git a/dev-ruby/ascii85/ascii85-2.0.1.ebuild b/dev-ruby/ascii85/ascii85-2.0.1.ebuild
new file mode 100644
index 000000000000..649186f30073
--- /dev/null
+++ b/dev-ruby/ascii85/ascii85-2.0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
+
+RUBY_FAKEGEM_NAME="Ascii85"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Methods for encoding/decoding Adobe's binary-to-text encoding of the same name"
+HOMEPAGE="https://github.com/datawraith/ascii85gem"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+ruby_add_rdepend "!<dev-ruby/ascii85-1.1.1-r1"
+
+ruby_add_bdepend "test? ( dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+}