summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-text/mandoc/files/mandoc-1.14.5-gcc10.patch54
-rw-r--r--app-text/mandoc/mandoc-1.14.5-r1.ebuild5
2 files changed, 58 insertions, 1 deletions
diff --git a/app-text/mandoc/files/mandoc-1.14.5-gcc10.patch b/app-text/mandoc/files/mandoc-1.14.5-gcc10.patch
new file mode 100644
index 000000000000..6d976683772c
--- /dev/null
+++ b/app-text/mandoc/files/mandoc-1.14.5-gcc10.patch
@@ -0,0 +1,54 @@
+https://cvsweb.bsd.lv/mandoc/compat_reallocarray.c.diff?r1=1.4&r2=1.5
+https://cvsweb.bsd.lv/mandoc/compat_getline.c.diff?r1=text&tr1=1.1&r2=text&tr2=1.2
+
+https://bugs.gentoo.org/707254
+--- mandoc/compat_reallocarray.c 2014/12/11 09:05:01 1.4
++++ mandoc/compat_reallocarray.c 2020/06/15 01:37:15 1.5
+@@ -1,8 +1,0 @@
+-#include "config.h"
+-
+-#if HAVE_REALLOCARRAY
+-
+-int dummy;
+-
+-#else
+-
+@@ -23,6 +15,7 @@ int dummy;
+ * ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
+ * OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+ */
++#include "config.h"
+
+ #include <sys/types.h>
+ #include <errno.h>
+@@ -45,5 +38,3 @@ reallocarray(void *optr, size_t nmemb, size_t size)
+ }
+ return realloc(optr, size * nmemb);
+ }
+-
+-#endif /*!HAVE_REALLOCARRAY*/
+--- mandoc/compat_getline.c 2015/11/07 20:52:52 1.1
++++ mandoc/compat_getline.c 2020/06/15 01:37:14 1.2
+@@ -1,8 +1,0 @@
+-#include "config.h"
+-
+-#if HAVE_GETLINE
+-
+-int dummy;
+-
+-#else
+-
+@@ -22,6 +14,7 @@ int dummy;
+ * ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
+ * OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+ */
++#include "config.h"
+
+ #include <sys/types.h>
+ #include <errno.h>
+@@ -64,5 +57,3 @@ getline(char **buf, size_t *bufsz, FILE *fp)
+ return pos;
+ }
+ }
+-
+-#endif
diff --git a/app-text/mandoc/mandoc-1.14.5-r1.ebuild b/app-text/mandoc/mandoc-1.14.5-r1.ebuild
index 21e0f9624754..cdc81d936543 100644
--- a/app-text/mandoc/mandoc-1.14.5-r1.ebuild
+++ b/app-text/mandoc/mandoc-1.14.5-r1.ebuild
@@ -24,7 +24,10 @@ BDEPEND="
cgi? ( app-text/highlight )
"
-PATCHES=( "${FILESDIR}"/${PN}-1.14.5-r1-www-install.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.14.5-r1-www-install.patch
+ "${FILESDIR}"/${PN}-1.14.5-gcc10.patch
+)
pkg_pretend() {
if use system-man ; then