summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-crypt/princeprocessor/Manifest1
-rw-r--r--app-crypt/princeprocessor/metadata.xml11
-rw-r--r--app-crypt/princeprocessor/princeprocessor-0.22.ebuild31
3 files changed, 43 insertions, 0 deletions
diff --git a/app-crypt/princeprocessor/Manifest b/app-crypt/princeprocessor/Manifest
new file mode 100644
index 000000000000..981018a96a13
--- /dev/null
+++ b/app-crypt/princeprocessor/Manifest
@@ -0,0 +1 @@
+DIST v0.22.tar.gz 38829 BLAKE2B 396a3b12bd390dca80f8d054e8e0c04c70d0bc1cb4f957d53f9f7f4a8aaa87edc1499cde20e01dfa288ba8212403e87e2c6180f1cee3da4825938d08cb2da1df SHA512 8b73867b3f8a83601cde9d6d17e917d0ba468873eda8c47e3c4de7a0511fe35bedb44c68897df9fcc48b1737c1f2c026117e9398f5ff4202611a001fe33990df
diff --git a/app-crypt/princeprocessor/metadata.xml b/app-crypt/princeprocessor/metadata.xml
new file mode 100644
index 000000000000..83b9308ac052
--- /dev/null
+++ b/app-crypt/princeprocessor/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">hashcat/princeprocessor</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-crypt/princeprocessor/princeprocessor-0.22.ebuild b/app-crypt/princeprocessor/princeprocessor-0.22.ebuild
new file mode 100644
index 000000000000..8f540412c78c
--- /dev/null
+++ b/app-crypt/princeprocessor/princeprocessor-0.22.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Standalone password candidate generator using the PRINCE algorithm"
+HOMEPAGE="https://github.com/hashcat/princeprocessor"
+SRC_URI="https://github.com/hashcat/princeprocessor/archive/v${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+S="${WORKDIR}/${P}/src"
+
+src_prepare() {
+ sed -i "s#-O2 -s#${CFLAGS} ${LDFLAGS}#" Makefile
+ default
+}
+
+src_install() {
+ newbin pp64.bin princeprocessor
+ #install rules after hashcat is fixed
+ #insinto /usr/share/hashcat
+ #doins ../rules/*.rules
+}