summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/tcping/metadata.xml4
-rw-r--r--net-analyzer/tcping/tcping-1.3.5-r1.ebuild28
2 files changed, 31 insertions, 1 deletions
diff --git a/net-analyzer/tcping/metadata.xml b/net-analyzer/tcping/metadata.xml
index 6f49eba8f496..12edb2ee98a0 100644
--- a/net-analyzer/tcping/metadata.xml
+++ b/net-analyzer/tcping/metadata.xml
@@ -1,5 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<!-- maintainer-needed -->
+<maintainer type='project'>
+<email>netmon@gentoo.org</email>
+</maintainer>
</pkgmetadata>
diff --git a/net-analyzer/tcping/tcping-1.3.5-r1.ebuild b/net-analyzer/tcping/tcping-1.3.5-r1.ebuild
new file mode 100644
index 000000000000..956a3556561e
--- /dev/null
+++ b/net-analyzer/tcping/tcping-1.3.5-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="Ping implementation that uses the TCP protocol"
+HOMEPAGE="https://github.com/mkirchner/tcping"
+SRC_URI="https://web.archive.org/web/20160316191549/http://linuxco.de/tcping/tcping-1.3.5.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ default
+ sed -e '/^CC=/s:=:?=:' \
+ -e '/^CCFLAGS/s:=:+=:' \
+ -e 's/$(CCFLAGS)/$(CCFLAGS) $(LDFLAGS)/' \
+ -i Makefile || die
+ tc-export CC
+ export CCFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin tcping
+ dodoc README
+}