summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pymongo/Manifest1
-rw-r--r--dev-python/pymongo/pymongo-4.0.ebuild112
2 files changed, 113 insertions, 0 deletions
diff --git a/dev-python/pymongo/Manifest b/dev-python/pymongo/Manifest
index bfa7dbbf251f..b657b3eeaba7 100644
--- a/dev-python/pymongo/Manifest
+++ b/dev-python/pymongo/Manifest
@@ -1,3 +1,4 @@
DIST mongo-python-driver-3.11.4.tar.gz 983009 BLAKE2B b2ca8d90a34b41c0991b545626853137b6a7f5f006dbb5d7a93fd8312759b53b99415583ca5ba982abb420db8502cb9de745f1ac0962efa05eb05ecb4289c323 SHA512 ecd2ff41ab902423dc58901cd9a8355e200f5b00a4eea4a8e950de75674fd59f7367df1ab7ee6c09bf515b8fa110cac0f7de084fbe14527486a9c38a0c8c9c27
DIST mongo-python-driver-3.12.0.tar.gz 1062091 BLAKE2B 636a34a42d43a6ecd549c51e9e5b3a617291b64a1ba91d7473c365f8df88d59efd7b2906dd80147ffab4309d38cce30a3475bbe142e347312823236f8657c801 SHA512 fc2734b8821b42cca1b67930d5c7612526e51292144a376425627ea6254b09128ccd894af3be293184f940c7f8faa1c0cd3a0d069f9b4143a15cb32279c3bdb1
DIST mongo-python-driver-3.12.1.tar.gz 1067667 BLAKE2B 3f18c5aa92ce180067f9c86e1fcbd80543274a2ee33ce1fad5741f0e7f5a9cb0520c33b8fe885ea69c2c8ce168747a44129fe79a5df389b83bd5e77a6ec4a687 SHA512 1fc98c33d8140ab045804130fc27b655a8622318f7030967d841e7a296dcdfb89a125cb2574a9b08eef15d3fdc089f268631501743b46d04a7b465cc45c0c04e
+DIST mongo-python-driver-4.0.tar.gz 1029687 BLAKE2B d8ae35b68bff288388a797c51b40d453c3e2197a0b639689bbb43f7e4470f3c4d5bf861d6ae77805b950e8c8daadcef5043b93c6d6a4b094fcb95521caf4c751 SHA512 b29acfcbd92b8f46780039cd0688cb03c083dfaf1ec6793906029f1e03635edc9a9ef6eb7104fa3dc16eca6df4ccfedd7bd4a8da495f754157edec371211fe15
diff --git a/dev-python/pymongo/pymongo-4.0.ebuild b/dev-python/pymongo/pymongo-4.0.ebuild
new file mode 100644
index 000000000000..c45af7c0a672
--- /dev/null
+++ b/dev-python/pymongo/pymongo-4.0.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit check-reqs distutils-r1
+
+MY_P=mongo-python-driver-${PV}
+DESCRIPTION="Python driver for MongoDB"
+HOMEPAGE="https://github.com/mongodb/mongo-python-driver https://pypi.org/project/pymongo/"
+SRC_URI="
+ https://github.com/mongodb/mongo-python-driver/archive/${PV}.tar.gz
+ -> ${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~riscv ~x86"
+IUSE="doc kerberos"
+
+RDEPEND="
+ kerberos? ( dev-python/pykerberos[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ test? (
+ >=dev-db/mongodb-2.6.0
+ )
+"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+distutils_enable_sphinx doc
+distutils_enable_tests unittest
+
+reqcheck() {
+ if use test; then
+ # During the tests, database size reaches 1.5G.
+ local CHECKREQS_DISK_BUILD=1536M
+
+ check-reqs_${1}
+ fi
+}
+
+pkg_pretend() {
+ reqcheck pkg_pretend
+}
+
+pkg_setup() {
+ reqcheck pkg_setup
+}
+
+src_prepare() {
+ # network-sandbox probably
+ rm test/test_srv_polling.py || die
+ sed -e 's:test_connection_timeout_ms_propagates_to_DNS_resolver:_&:' \
+ -i test/test_client.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # Yes, we need TCP/IP for that...
+ local DB_IP=127.0.0.1
+ local DB_PORT=27000
+
+ export DB_IP DB_PORT
+
+ local dbpath=${TMPDIR}/mongo.db
+ local logpath=${TMPDIR}/mongod.log
+
+ # Now, the hard part: we need to find a free port for mongod.
+ # We're just trying to run it random port numbers and check the log
+ # for bind errors. It shall be noted that 'mongod --fork' does not
+ # return failure when it fails to bind.
+
+ mkdir -p "${dbpath}" || die
+ while true; do
+ ebegin "Trying to start mongod on port ${DB_PORT}"
+
+ LC_ALL=C \
+ mongod --dbpath "${dbpath}" --nojournal \
+ --bind_ip ${DB_IP} --port ${DB_PORT} \
+ --unixSocketPrefix "${TMPDIR}" \
+ --logpath "${logpath}" --fork \
+ && sleep 2
+
+ # Now we need to check if the server actually started...
+ if [[ ${?} -eq 0 && -S "${TMPDIR}"/mongodb-${DB_PORT}.sock ]]; then
+ # yay!
+ eend 0
+ break
+ elif grep -q 'Address already in use' "${logpath}"; then
+ # ay, someone took our port!
+ eend 1
+ : $(( DB_PORT += 1 ))
+ continue
+ else
+ eend 1
+ eerror "Unable to start mongod for tests. See the server log:"
+ eerror " ${logpath}"
+ die "Unable to start mongod for tests."
+ fi
+ done
+
+ local failed
+ DB_PORT2=$(( DB_PORT + 1 )) DB_PORT3=$(( DB_PORT + 2 )) esetup.py test || failed=1
+
+ mongod --dbpath "${dbpath}" --shutdown || die
+
+ [[ ${failed} ]] && die "Tests fail with ${EPYTHON}"
+
+ rm -rf "${dbpath}" || die
+}