summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/click-help-colors/Manifest1
-rw-r--r--dev-python/click-help-colors/click-help-colors-0.9.ebuild26
-rw-r--r--dev-python/click-help-colors/metadata.xml13
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/click-help-colors/Manifest b/dev-python/click-help-colors/Manifest
new file mode 100644
index 000000000000..93313e11804a
--- /dev/null
+++ b/dev-python/click-help-colors/Manifest
@@ -0,0 +1 @@
+DIST click-help-colors-0.9.tar.gz 100701 BLAKE2B 838507658aec9cea962d1f373bd771871837d1fe274c70fe4555efbd4e1825203d8728457c5836a482add26e86d4eed83b962811602864d43bf8174f49bd89cd SHA512 02cca02a5cec6b3b23fdeee4aef921cac1cf83d85bea8eb04dd100955dc27b2e4d098bad2f49694c0aa6548135fb979a1fd054525dcec27077f461a034d62a87
diff --git a/dev-python/click-help-colors/click-help-colors-0.9.ebuild b/dev-python/click-help-colors/click-help-colors-0.9.ebuild
new file mode 100644
index 000000000000..0f16c35209b3
--- /dev/null
+++ b/dev-python/click-help-colors/click-help-colors-0.9.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Colorization of help messages in Click"
+HOMEPAGE="https://github.com/click-contrib/click-help-colors"
+SRC_URI="https://github.com/click-contrib/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+RDEPEND="<dev-python/click-9[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/click-help-colors/metadata.xml b/dev-python/click-help-colors/metadata.xml
new file mode 100644
index 000000000000..4f878dd813d2
--- /dev/null
+++ b/dev-python/click-help-colors/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">click-contrib/click-help-colors</remote-id>
+ <remote-id type="pypi">click-help-colors</remote-id>
+ </upstream>
+</pkgmetadata>