summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/ecasound/Manifest1
-rw-r--r--media-sound/ecasound/ecasound-2.6.0-r1.ebuild69
2 files changed, 0 insertions, 70 deletions
diff --git a/media-sound/ecasound/Manifest b/media-sound/ecasound/Manifest
index 743c6c7aaec6..0ef66f13970b 100644
--- a/media-sound/ecasound/Manifest
+++ b/media-sound/ecasound/Manifest
@@ -1,2 +1 @@
-DIST ecasound-2.6.0.tar.gz 966629 BLAKE2B 35539d80ea306f2ba38980838895c66a2f5db918854f0bd0d0cd1513d0cdaa00a9359337b469a41b8fa42cd88e7642e8393d91fdb1add277edfe77bde633e1cc SHA512 48b3c65e301a775499765c55b09bddacfde24bfd7a5be6c03389c7bda882abe98b061aaa39ec12a797e3a5a2808f446751155b36c263f0f12da2db1495515c5e
DIST ecasound-2.9.3.tar.gz 1101628 BLAKE2B 52aaa96abee9a911c613ac772fd3df3ff7bb4a8309283089d19e2f7265be26eb6e77304896cda2ed1c71742f36dfe1e38209afd42b921d56f12d43f08b4fe2d2 SHA512 4f70e6f54cd05194a4ffe80905e7488d16d32d684c87736dfdac7b3aebf3d20cbf417964d75e00e781f6f0614b8b699061c69fcbf7e1761d66ce1abfcd5f1140
diff --git a/media-sound/ecasound/ecasound-2.6.0-r1.ebuild b/media-sound/ecasound/ecasound-2.6.0-r1.ebuild
deleted file mode 100644
index bab257a0d55b..000000000000
--- a/media-sound/ecasound/ecasound-2.6.0-r1.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 )
-
-inherit eutils python-single-r1
-
-DESCRIPTION="a package for multitrack audio processing"
-HOMEPAGE="https://ecasound.seul.org/ecasound/"
-SRC_URI="https://${PN}.seul.org/download/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="1"
-KEYWORDS="amd64 ~ppc x86"
-IUSE="alsa audiofile debug doc jack libsamplerate mikmod ncurses vorbis oss python ruby sndfile"
-
-RDEPEND="python? ( ${PYTHON_DEPS} )
- jack? ( media-sound/jack-audio-connection-kit )
- media-libs/ladspa-sdk
- audiofile? ( media-libs/audiofile )
- alsa? ( media-libs/alsa-lib )
- vorbis? ( media-libs/libvorbis )
- libsamplerate? ( media-libs/libsamplerate )
- mikmod? ( media-libs/libmikmod:0 )
- ruby? ( dev-lang/ruby )
- python? ( dev-lang/python )
- ncurses? ( sys-libs/ncurses )
- sndfile? ( media-libs/libsndfile )
- sys-libs/readline"
-DEPEND="${RDEPEND}"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_configure() {
- local pyconf=()
-
- if use python ; then
- pyconf=( "--with-python-modules=${EPREFIX}/usr/$(get_libdir)/${EPYTHON}" )
- fi
-
- econf \
- $(use_enable alsa) \
- --disable-arts \
- $(use_enable audiofile) \
- $(use_enable debug) \
- $(use_enable jack) \
- $(use_enable libsamplerate) \
- $(use_enable ncurses) \
- $(use_enable oss) \
- $(use_enable python pyecasound c) \
- $(use_enable ruby rubyecasound) \
- $(use_enable sndfile) \
- --enable-shared \
- --with-largefile \
- --enable-sys-readline \
- "${pyconf[@]}"
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- use python && python_optimize
- dodoc BUGS NEWS README TODO
- use doc && dodoc Documentation/*.html
-}