summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/actionpack/Manifest1
-rw-r--r--dev-ruby/actionpack/actionpack-5.2.2.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-ruby/actionpack/Manifest b/dev-ruby/actionpack/Manifest
index 9e6c256bb7e1..5c8aa430e4cd 100644
--- a/dev-ruby/actionpack/Manifest
+++ b/dev-ruby/actionpack/Manifest
@@ -6,3 +6,4 @@ DIST rails-5.1.6.tgz 6142931 BLAKE2B 0c24677946c3421e73903214822a13cb26609a3c7e7
DIST rails-5.2.0.tgz 9233349 BLAKE2B 8b237f7b039baed6d2a3f19d138f5985443d8543247b01ba316668052fede66820894e3f5ef76a953a4bdb54febecb6299692899556ea029ebfcbcebbaba9409 SHA512 0d7fdbc05a69f7a7b5ce612c0ec8e5dcd51ffb63891d97ca08036d07b3fb3267699dd4a209fd698e5eb2ca8f6c7f4539e86044c3bd15d0c614feda16892d3d85
DIST rails-5.2.1.1.tgz 8795521 BLAKE2B 93b30ba7b9127d2fc4dae6c7e7884f0a4ab36805b440c37ca8e2b81a5ba2b9ccaa4d30e65599cfb036befc4ec58942d3eba71ba9683becb535e8a822d3a8422e SHA512 bd2c13f06d524a03547341acee3422a58a306a1c33a896073648e4ddcac296a8e397bd73fd5928dae1e66ba3b4a42ac4ea5f0a7cca1f73b2e773b8ece24a76d0
DIST rails-5.2.1.tgz 8795554 BLAKE2B 712fba696aeb8600dcd3b031b84a7ec164aa4d8ec386576ff367d5d45b3effd48515c9b8ef36ea93642776220685a1d8eec6909f705e62a80a06cf151fc42b43 SHA512 4484981845f9bba8882db6b4d1e0c4600b54baeda5cf1825fda7cbbb04cfdcf35e4caa19355cb843d1b96fc67801f28902d79d763dae71446db515691a32742e
+DIST rails-5.2.2.tgz 8794009 BLAKE2B ee6af6990d6b3dc12171fa2a1baf0f975481dc31711ae2caed27b79d1c5b514d1959492c5cced5b0202b46fc18e4a8178703a91b5f1f65df4ea46f193e9d48d5 SHA512 ecca752baa52ee7f11ef21a919bbba370d9ca76a0b428305143e86ebabbd7218978cdeefc919bfb1c0e0e71fc555869dcf917bda219f89e7e41e17dfe983b792
diff --git a/dev-ruby/actionpack/actionpack-5.2.2.ebuild b/dev-ruby/actionpack/actionpack-5.2.2.ebuild
new file mode 100644
index 000000000000..f18a94520ee3
--- /dev/null
+++ b/dev-ruby/actionpack/actionpack-5.2.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionpack.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem eapi7-ver
+
+DESCRIPTION="Eases web-request routing, handling, and response"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ ~dev-ruby/actionview-${PV}
+ dev-ruby/rack:2.0
+ >=dev-ruby/rack-test-0.6.3:*
+ >=dev-ruby/rails-html-sanitizer-1.0.2:1
+ dev-ruby/rails-dom-testing:2
+"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/mocha:0.14
+ dev-ruby/bundler
+ >=dev-ruby/capybara-2.13:2
+ ~dev-ruby/activemodel-${PV}
+ >=dev-ruby/rack-cache-1.2:1.2
+ www-servers/puma
+ )"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|'mysql'\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|sprockets\|stackprof\)/ s:^:#:" \
+ -e '/:job/,/end/ s:^:#:' \
+ -e '/group :doc/,/^end/ s:^:#:' ../Gemfile || die
+ rm ../Gemfile.lock || die
+}