summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-action/rafkill/Manifest1
-rw-r--r--games-action/rafkill/files/rafkill-1.2.3-build.patch27
-rw-r--r--games-action/rafkill/files/rafkill-1.2.3-gcc43.patch106
-rw-r--r--games-action/rafkill/files/rafkill-1.2.3-gcc47.patch11
-rw-r--r--games-action/rafkill/files/rafkill-1.2.3-ldflags.patch17
-rw-r--r--games-action/rafkill/metadata.xml11
-rw-r--r--games-action/rafkill/rafkill-1.2.3-r1.ebuild48
-rw-r--r--profiles/package.mask4
8 files changed, 0 insertions, 225 deletions
diff --git a/games-action/rafkill/Manifest b/games-action/rafkill/Manifest
deleted file mode 100644
index e8c490bc5d06..000000000000
--- a/games-action/rafkill/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST rafkill-1.2.3.tar.gz 6221729 BLAKE2B e3ea686f95299f3e6726e75ccf25231dcd57e5c1e03e3212b55b8179b3961a59935c3c5be9d4557bc38f8a29c90dbd758ff8d4de01e1abdcf4f7a7f10e664b7c SHA512 1ab8ce90f9b823092432519dbafed43db3eb6f9189dda4ced1bbce78b826b37759d0768fffdd2df1c77cbbbf1c3c88db1cc9fe1b59c815d832ebc9aed279d03c
diff --git a/games-action/rafkill/files/rafkill-1.2.3-build.patch b/games-action/rafkill/files/rafkill-1.2.3-build.patch
deleted file mode 100644
index 26e5aa64c101..000000000000
--- a/games-action/rafkill/files/rafkill-1.2.3-build.patch
+++ /dev/null
@@ -1,27 +0,0 @@
---- a/SConstruct
-+++ b/SConstruct
-@@ -8,8 +8,8 @@
-
- print "Use 'scons -h' for help"
-
--prefix = '/usr/local/games'
--bin = '/usr/local/bin'
-+prefix = 'data'
-+bin = 'src'
- if sys.platform == 'win32':
- try:
- Execute(Mkdir('gen'))
-@@ -46,7 +46,12 @@
- # print "Install directory = $prefix"
- # print "Directory where symlinked binary will go = $bin"
-
--flags = [ '-g3', '-Wall', '-fno-rtti', '-Woverloaded-virtual', '-O2', '-DINSTALL_DIR=\\\"$prefix\\\"' ];
-+SConsignFile()
-+env.Replace(CXX = os.environ['CXX'])
-+if os.environ.get('CXXFLAGS'):
-+ env.Replace(CPPFLAGS = os.environ['CXXFLAGS'])
-+
-+flags = [ '-Wall', '-fno-rtti', '-Woverloaded-virtual' ];
- env.Append( CCFLAGS = flags, CPPPATH = [ "build" ] )
-
- # SConscript( 'src/SConscript', build_dir='build', exports = 'env' );
diff --git a/games-action/rafkill/files/rafkill-1.2.3-gcc43.patch b/games-action/rafkill/files/rafkill-1.2.3-gcc43.patch
deleted file mode 100644
index 7284a74a1ac5..000000000000
--- a/games-action/rafkill/files/rafkill-1.2.3-gcc43.patch
+++ /dev/null
@@ -1,106 +0,0 @@
-Index: rafkill-1.2.2/src/guns/gun_findgun.cpp
-===================================================================
---- rafkill-1.2.2.orig/src/guns/gun_findgun.cpp 2006-05-07 15:50:04.000000000 +0100
-+++ rafkill-1.2.2/src/guns/gun_findgun.cpp 2008-04-09 22:54:54.000000000 +0100
-@@ -5,6 +5,7 @@
- #include "weaponobj.h"
- #include "hulls/hull_weapon_machine.h"
- #include "spaceobj.h"
-+#include <cstdlib>
- #include <vector>
- #include <math.h>
-
-Index: rafkill-1.2.2/src/guns/gun_machine_circle.cpp
-===================================================================
---- rafkill-1.2.2.orig/src/guns/gun_machine_circle.cpp 2006-05-02 02:50:40.000000000 +0100
-+++ rafkill-1.2.2/src/guns/gun_machine_circle.cpp 2008-04-09 22:54:54.000000000 +0100
-@@ -3,6 +3,7 @@
- #include "weaponobj.h"
- #include "hulls/hull_weapon_machine.h"
- #include "trigtable.h"
-+#include <cstdlib>
-
- // #define d_circle_move (2.9*8)
-
-Index: rafkill-1.2.2/src/guns/gun_saber.cpp
-===================================================================
---- rafkill-1.2.2.orig/src/guns/gun_saber.cpp 2006-05-02 02:52:23.000000000 +0100
-+++ rafkill-1.2.2/src/guns/gun_saber.cpp 2008-04-09 22:54:54.000000000 +0100
-@@ -5,6 +5,7 @@
- #include "weapons/weapon_beam.h"
- #include "spaceobj.h"
- #include "ebox.h"
-+#include <cstdlib>
- #include <vector>
-
- using namespace std;
-Index: rafkill-1.2.2/src/menu.cpp
-===================================================================
---- rafkill-1.2.2.orig/src/menu.cpp 2008-04-09 22:53:35.000000000 +0100
-+++ rafkill-1.2.2/src/menu.cpp 2008-04-09 22:54:54.000000000 +0100
-@@ -1,4 +1,5 @@
- #include <stdio.h>
-+#include <cstdlib>
- #include "defs.h"
- #include "menu.h"
- #include "loadsave.h"
-Index: rafkill-1.2.2/src/weapons/weapon_follow.cpp
-===================================================================
---- rafkill-1.2.2.orig/src/weapons/weapon_follow.cpp 2006-03-25 23:29:05.000000000 +0000
-+++ rafkill-1.2.2/src/weapons/weapon_follow.cpp 2008-04-09 22:54:54.000000000 +0100
-@@ -3,6 +3,7 @@
- #include "weapon_follow.h"
- #include "hulls/hull_weapon_follow.h"
- #include "spaceobj.h"
-+#include <cstdlib>
- #include <vector>
-
- using namespace std;
-Index: rafkill-1.2.2/src/hulls/hull_weapon_beam.cpp
-===================================================================
---- rafkill-1.2.2.orig/src/hulls/hull_weapon_beam.cpp 2006-05-02 03:12:50.000000000 +0100
-+++ rafkill-1.2.2/src/hulls/hull_weapon_beam.cpp 2008-04-09 22:54:54.000000000 +0100
-@@ -4,6 +4,7 @@
- #include "hull_weapon_beam.h"
- #include "trigtable.h"
- #include "ebox.h"
-+#include <cstdlib>
-
- #ifndef debug
- #include <iostream>
-Index: rafkill-1.2.2/src/drawer.cpp
-===================================================================
---- rafkill-1.2.2.orig/src/drawer.cpp 2008-04-09 22:55:06.000000000 +0100
-+++ rafkill-1.2.2/src/drawer.cpp 2008-04-09 22:55:55.000000000 +0100
-@@ -11,6 +11,7 @@
- #include "trigtable.h"
- #include "pck.h"
- #include <iostream>
-+#include <cstring>
-
- /* TODO:
- * Add weapon icons to HUD
-Index: rafkill-1.2.2/src/loadsave.cpp
-===================================================================
---- rafkill-1.2.2.orig/src/loadsave.cpp 2008-04-09 22:55:19.000000000 +0100
-+++ rafkill-1.2.2/src/loadsave.cpp 2008-04-09 22:55:55.000000000 +0100
-@@ -7,6 +7,7 @@
- #include "spaceobj.h"
- #include "strings.h"
- #include <string>
-+#include <cstring>
- #include <vector>
- #include "gunobj.h"
- #include "hull.h"
-Index: rafkill-1.2.2/src/system.cpp
-===================================================================
---- rafkill-1.2.2.orig/src/system.cpp 2008-04-09 22:55:29.000000000 +0100
-+++ rafkill-1.2.2/src/system.cpp 2008-04-09 22:55:55.000000000 +0100
-@@ -1,6 +1,7 @@
- #include "system.h"
- #include <strings.h>
- #include <string>
-+#include <cstring>
-
- #ifdef WINDOWS
- static const char * type(){
diff --git a/games-action/rafkill/files/rafkill-1.2.3-gcc47.patch b/games-action/rafkill/files/rafkill-1.2.3-gcc47.patch
deleted file mode 100644
index 3c95e02869d1..000000000000
--- a/games-action/rafkill/files/rafkill-1.2.3-gcc47.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src/system.cpp 2012-07-19 13:37:12.324303303 +0200
-+++ b/src/system.cpp 2012-07-19 13:38:05.451584273 +0200
-@@ -2,6 +2,8 @@
- #include <strings.h>
- #include <string>
- #include <cstring>
-+#include <unistd.h>
-+#include <sys/types.h>
-
- #ifdef WINDOWS
- static const char * type(){
diff --git a/games-action/rafkill/files/rafkill-1.2.3-ldflags.patch b/games-action/rafkill/files/rafkill-1.2.3-ldflags.patch
deleted file mode 100644
index 4adf853e912a..000000000000
--- a/games-action/rafkill/files/rafkill-1.2.3-ldflags.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- a/SConstruct 2010-10-07 10:37:26.000000000 +0200
-+++ b/SConstruct 2010-10-07 10:39:33.000000000 +0200
-@@ -1,5 +1,6 @@
- import os
- import sys
-+import SCons.Util
-
- env = Environment( ENV = os.environ );
- config = env.Configure();
-@@ -36,6 +37,7 @@
-
- env.BuildDir( 'build/', 'src/' )
- env.Append( LIBS = [ 'aldmb', 'dumb' ] );
-+env['LINKFLAGS'] += SCons.Util.CLVar(os.environ['LDFLAGS'])
- if sys.platform == 'win32':
- env.Append( CCFLAGS = [ '-DWINDOWS' ] )
- env.Append( LIBS = [ 'alleg', 'pthreadGC2' ] )
diff --git a/games-action/rafkill/metadata.xml b/games-action/rafkill/metadata.xml
deleted file mode 100644
index cf6a276e7664..000000000000
--- a/games-action/rafkill/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>games@gentoo.org</email>
- <name>Gentoo Games Project</name>
- </maintainer>
- <upstream>
- <remote-id type="sourceforge">raptorv2</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/games-action/rafkill/rafkill-1.2.3-r1.ebuild b/games-action/rafkill/rafkill-1.2.3-r1.ebuild
deleted file mode 100644
index d277190f452c..000000000000
--- a/games-action/rafkill/rafkill-1.2.3-r1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit desktop scons-utils toolchain-funcs
-
-DESCRIPTION="Space shoot-em-up game"
-HOMEPAGE="http://raptorv2.sourceforge.net/"
-SRC_URI="mirror://sourceforge/raptorv2/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="<media-libs/allegro-5
- media-libs/aldumb"
-RDEPEND=${DEPEND}
-
-PATCHES=(
- "${FILESDIR}"/${P}-build.patch
- "${FILESDIR}"/${P}-gcc43.patch
- "${FILESDIR}"/${P}-gcc47.patch
- "${FILESDIR}"/${P}-ldflags.patch
-)
-
-src_prepare() {
- default
-
- rm -f {data,music}/.sconsign || die
-
- sed -i \
- -e "/^#define INSTALL_DIR/s:\.:/usr/share:" \
- src/defs.cpp || die
-}
-
-src_compile() {
- tc-export CXX
- escons
-}
-
-src_install() {
- dobin ${PN}
- insinto /usr/share/${PN}
- doins -r data music
- dodoc README
-}
diff --git a/profiles/package.mask b/profiles/package.mask
index 5587f502f52a..cc6895467077 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -193,10 +193,6 @@ app-forensics/libbfio
sys-apps/likwid
# Pacho Ramos <pacho@gentoo.org> (11 Nov 2018)
-# Doesn't build for a long time (#638096). Removal in a month.
-games-action/rafkill
-
-# Pacho Ramos <pacho@gentoo.org> (11 Nov 2018)
# Fails to build (#662000), not compatible with kernel-4, use kernel driver rtsx_pci
# instead. Removal in a month.
sys-block/rts_pstor