summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-mathematics/wxmaxima/wxmaxima-19.12.2.ebuild8
-rw-r--r--sci-mathematics/yacas/yacas-1.7.0-r1.ebuild6
2 files changed, 7 insertions, 7 deletions
diff --git a/sci-mathematics/wxmaxima/wxmaxima-19.12.2.ebuild b/sci-mathematics/wxmaxima/wxmaxima-19.12.2.ebuild
index d1fd945c6f9e..809444233eef 100644
--- a/sci-mathematics/wxmaxima/wxmaxima-19.12.2.ebuild
+++ b/sci-mathematics/wxmaxima/wxmaxima-19.12.2.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
WX_GTK_VER="3.0"
PLOCALES="ca cs da de el en es fi fr gl hu it ja kab nb pl pt_BR ru tr uk zh_CN zh_TW"
-inherit cmake-utils wxwidgets l10n xdg
+inherit cmake wxwidgets l10n xdg
DESCRIPTION="Graphical frontend to Maxima, using the wxWidgets toolkit"
HOMEPAGE="https://wxmaxima-developers.github.io/wxmaxima/"
@@ -28,7 +28,7 @@ PATCHES=( "${FILESDIR}"/${P}.patch )
src_prepare() {
setup-wxwidgets
- cmake-utils_src_prepare
+ cmake_src_prepare
sed -e "s|share/doc/${PN}|share/doc/${PF}|g" -i "${S}"/info/CMakeLists.txt \
|| die "sed info/CMakeLists.txt failed"
@@ -47,5 +47,5 @@ src_prepare() {
src_install() {
docompress -x /usr/share/doc/${PF}
- cmake-utils_src_install
+ cmake_src_install
}
diff --git a/sci-mathematics/yacas/yacas-1.7.0-r1.ebuild b/sci-mathematics/yacas/yacas-1.7.0-r1.ebuild
index 0d808f23ce18..5848e44b18fd 100644
--- a/sci-mathematics/yacas/yacas-1.7.0-r1.ebuild
+++ b/sci-mathematics/yacas/yacas-1.7.0-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils desktop
+inherit cmake desktop
DESCRIPTION="General purpose computer algebra system"
HOMEPAGE="http://www.yacas.org/"
@@ -55,5 +55,5 @@ src_configure() {
-DENABLE_CYACAS_KERNEL=$(usex jupyter)
-DENABLE_CYACAS_UNIT_TESTS=$(usex test)
)
- cmake-utils_src_configure
+ cmake_src_configure
}