summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/chart-studio/chart-studio-1.1.0-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/chart-studio/chart-studio-1.1.0-r1.ebuild b/dev-python/chart-studio/chart-studio-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..d2b1c6934990
--- /dev/null
+++ b/dev-python/chart-studio/chart-studio-1.1.0-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_10 )
+
+inherit distutils-r1
+
+DESCRIPTION="Browser-based graphing library for Python"
+HOMEPAGE="https://plot.ly/python/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/plotly[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/retrying[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"