summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/isapnptools/files/isapnptools-1.27-fno-common.patch22
-rw-r--r--sys-apps/isapnptools/isapnptools-1.27.ebuild10
2 files changed, 28 insertions, 4 deletions
diff --git a/sys-apps/isapnptools/files/isapnptools-1.27-fno-common.patch b/sys-apps/isapnptools/files/isapnptools-1.27-fno-common.patch
new file mode 100644
index 000000000000..54da41cdd602
--- /dev/null
+++ b/sys-apps/isapnptools/files/isapnptools-1.27-fno-common.patch
@@ -0,0 +1,22 @@
+--- a/src/isapnp_main.c
++++ b/src/isapnp_main.c
+@@ -1153,7 +1153,7 @@
+ return 0;
+ }
+
+-unsigned char serial_identifier[NUM_CARDS+1][IDENT_LEN];
++extern unsigned char serial_identifier[NUM_CARDS+1][IDENT_LEN];
+ static char *boardid[NUM_CARDS+1];
+ static unsigned long serno[NUM_CARDS+1];
+
+--- a/src/isapnp_main.l
++++ b/src/isapnp_main.l
+@@ -363,7 +363,7 @@
+ return 0;
+ }
+
+-unsigned char serial_identifier[NUM_CARDS+1][IDENT_LEN];
++extern unsigned char serial_identifier[NUM_CARDS+1][IDENT_LEN];
+ static char *boardid[NUM_CARDS+1];
+ static unsigned long serno[NUM_CARDS+1];
+
diff --git a/sys-apps/isapnptools/isapnptools-1.27.ebuild b/sys-apps/isapnptools/isapnptools-1.27.ebuild
index c95092405332..294f895aff77 100644
--- a/sys-apps/isapnptools/isapnptools-1.27.ebuild
+++ b/sys-apps/isapnptools/isapnptools-1.27.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
DESCRIPTION="Tools for configuring ISA PnP devices"
HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
@@ -10,9 +10,11 @@ SRC_URI="ftp://metalab.unc.edu/pub/Linux/system/hardware/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="-* amd64 x86"
-IUSE=""
-PATCHES=( "${FILESDIR}"/${P}-include.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-include.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+)
src_install() {
default