summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-java/slf4j-simple/Manifest1
-rw-r--r--dev-java/slf4j-simple/files/1.7.7-build.xml208
-rw-r--r--dev-java/slf4j-simple/slf4j-simple-1.7.7.ebuild52
3 files changed, 0 insertions, 261 deletions
diff --git a/dev-java/slf4j-simple/Manifest b/dev-java/slf4j-simple/Manifest
index 828bfe619962..483c3d5a5aac 100644
--- a/dev-java/slf4j-simple/Manifest
+++ b/dev-java/slf4j-simple/Manifest
@@ -1,2 +1 @@
DIST slf4j-1.7.30-sources.tar.gz 2272772 BLAKE2B c6692a20406983fa333bdb27bf8da599140d7d37fe55da6dfa2c2aff1825ee57c9d6b7bf0015e4b41b3c15ac0971559b3dd4bb5244e5393cd209ee26fac5e93d SHA512 4f05c996532560b16f22d78fcd47f8c4ba14691ce218a51ee6d50b283a51f8e40475a3a47f1117c1898a7be922e3f85806c4a7eb526759f0e7ea8426b5c6035f
-DIST slf4j-1.7.7.tar.gz 3031017 BLAKE2B 55020b493f9f0df534d199d86e8d312dcd64831155f6d18d5f2de6f5157ecb20853cc96689e25ded8c7f4f858481567eb67a21a1cf96a7c3a33ed1ddf9aa47eb SHA512 aefefe049ed36e8ec938469067be8d73d2c7a28189f54cf434606fecab1d380f00fdf8349a23ed99d574067d9a613b0aec48b913705cd27524af5a4a5d887418
diff --git a/dev-java/slf4j-simple/files/1.7.7-build.xml b/dev-java/slf4j-simple/files/1.7.7-build.xml
deleted file mode 100644
index f91d565e170a..000000000000
--- a/dev-java/slf4j-simple/files/1.7.7-build.xml
+++ /dev/null
@@ -1,208 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-
-<project name="slf4j-simple-from-maven" default="package" basedir=".">
- <property file="${user.home}/.m2/maven.properties"/>
- <property file="maven-build.properties"/>
-
- <property name="maven.build.finalName" value="slf4j-simple-1.7.6"/>
- <property name="maven.build.dir" value="target"/>
- <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
- <property name="maven.build.srcDir.0" value="src/main/java"/>
- <property name="maven.build.resourceDir.0" value="src/main/resources"/>
- <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
- <property name="maven.build.testDir.0" value="src/test/java"/>
- <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
- <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
- <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
-
- <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
- <property name="maven.settings.offline" value="false"/>
- <property name="maven.settings.interactiveMode" value="true"/>
-
- <!-- ====================================================================== -->
- <!-- Defining classpaths -->
- <!-- ====================================================================== -->
-
- <path id="build.classpath">
- <pathelement location="${maven.repo.local}/org/slf4j/slf4j-api/1.7.6/slf4j-api-1.7.6.jar"/>
- </path>
- <path id="build.test.classpath">
- <pathelement location="${maven.repo.local}/org/slf4j/slf4j-api/1.7.6/slf4j-api-1.7.6.jar"/>
- <pathelement location="${maven.repo.local}/junit/junit/4.10/junit-4.10.jar"/>
- </path>
-
- <!-- ====================================================================== -->
- <!-- Cleaning up target -->
- <!-- ====================================================================== -->
-
- <target name="clean" description="Clean the output directory">
- <delete dir="${maven.build.dir}"/>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Compilation target -->
- <!-- ====================================================================== -->
-
- <target name="compile" description="Compile the code">
- <mkdir dir="${maven.build.outputDir}"/>
- <javac destdir="${maven.build.outputDir}"
- nowarn="false"
- debug="true"
- optimize="false"
- deprecation="true"
- target="1.5"
- verbose="false"
- fork="false"
- source="1.5">
- <src>
- <pathelement location="${maven.build.srcDir.0}"/>
- </src>
- <classpath refid="build.classpath"/>
- </javac>
- <copy todir="${maven.build.outputDir}">
- <fileset dir="${maven.build.resourceDir.0}"/>
- </copy>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Test-compilation target -->
- <!-- ====================================================================== -->
-
- <target name="compile-tests"
- depends="compile"
- description="Compile the test code"
- unless="maven.test.skip">
- <mkdir dir="${maven.build.testOutputDir}"/>
- <javac destdir="${maven.build.testOutputDir}"
- nowarn="false"
- debug="true"
- optimize="false"
- deprecation="true"
- target="1.5"
- verbose="false"
- fork="false"
- source="1.5">
- <src>
- <pathelement location="${maven.build.testDir.0}"/>
- </src>
- <classpath>
- <path refid="build.test.classpath"/>
- <pathelement location="${maven.build.outputDir}"/>
- </classpath>
- </javac>
- <copy todir="${maven.build.testOutputDir}">
- <fileset dir="${maven.build.testResourceDir.0}"/>
- </copy>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Run all tests -->
- <!-- ====================================================================== -->
-
- <target name="test"
- depends="compile-tests, junit-missing"
- unless="junit.skipped"
- description="Run the test cases">
- <mkdir dir="${maven.test.reports}"/>
- <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
- <sysproperty key="basedir" value="."/>
- <formatter type="xml"/>
- <formatter type="plain" usefile="false"/>
- <classpath>
- <path refid="build.test.classpath"/>
- <pathelement location="${maven.build.outputDir}"/>
- <pathelement location="${maven.build.testOutputDir}"/>
- </classpath>
- <batchtest todir="${maven.test.reports}" unless="test">
- <fileset dir="${maven.build.testDir.0}">
- <include name="**/Test*.java"/>
- <include name="**/*Test.java"/>
- <include name="**/*TestCase.java"/>
- <exclude name="**/AllTest.java"/>
- <exclude name="**/PackageTest.java"/>
- </fileset>
- </batchtest>
- <batchtest todir="${maven.test.reports}" if="test">
- <fileset dir="${maven.build.testDir.0}">
- <include name="**/${test}.java"/>
- <exclude name="**/AllTest.java"/>
- <exclude name="**/PackageTest.java"/>
- </fileset>
- </batchtest>
- </junit>
- </target>
-
- <target name="test-junit-present">
- <available classname="junit.framework.Test" property="junit.present"/>
- </target>
-
- <target name="test-junit-status"
- depends="test-junit-present">
- <condition property="junit.missing">
- <and>
- <isfalse value="${junit.present}"/>
- <isfalse value="${maven.test.skip}"/>
- </and>
- </condition>
- <condition property="junit.skipped">
- <or>
- <isfalse value="${junit.present}"/>
- <istrue value="${maven.test.skip}"/>
- </or>
- </condition>
- </target>
-
- <target name="junit-missing"
- depends="test-junit-status"
- if="junit.missing">
- <echo>=================================== WARNING ===================================</echo>
- <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
- <echo>===============================================================================</echo>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Javadoc target -->
- <!-- ====================================================================== -->
-
- <target name="javadoc" description="Generates the Javadoc of the application">
- <javadoc sourcepath="${maven.build.srcDir.0}"
- packagenames="*"
- destdir="${maven.reporting.outputDirectory}/apidocs"
- access="protected"
- old="false"
- verbose="false"
- version="true"
- use="true"
- author="true"
- splitindex="false"
- nodeprecated="false"
- nodeprecatedlist="false"
- notree="false"
- noindex="false"
- nohelp="false"
- nonavbar="false"
- serialwarn="false"
- charset="ISO-8859-1"
- linksource="false"
- breakiterator="false"/>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Package target -->
- <!-- ====================================================================== -->
-
- <target name="package" depends="compile,test" description="Package the application">
- <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
- compress="true"
- index="false"
- manifest="${maven.build.resourceDir.0}/META-INF/MANIFEST.MF"
- basedir="${maven.build.outputDir}"
- excludes="**/package.html"/>
- </target>
-
- <!-- ====================================================================== -->
- <!-- A dummy target for the package named after the type it creates -->
- <!-- ====================================================================== -->
-
- <target name="jar" depends="package" description="Builds the jar for the application"/>
-</project>
diff --git a/dev-java/slf4j-simple/slf4j-simple-1.7.7.ebuild b/dev-java/slf4j-simple/slf4j-simple-1.7.7.ebuild
deleted file mode 100644
index 792d3f30f513..000000000000
--- a/dev-java/slf4j-simple/slf4j-simple-1.7.7.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-JAVA_PKG_IUSE="doc source"
-
-inherit java-pkg-2 java-ant-2
-
-DESCRIPTION="Simple Logging Facade for Java"
-HOMEPAGE="http://www.slf4j.org/"
-SRC_URI="http://www.slf4j.org/dist/${P/-simple/}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ppc64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-CDEPEND="
- dev-java/slf4j-api:0"
-RDEPEND=">=virtual/jre-1.6
- ${CDEPEND}"
-DEPEND=">=virtual/jdk-1.6
- ${CDEPEND}
- test? (
- dev-java/junit:4
- dev-java/ant-junit:0
- )"
-
-S="${WORKDIR}/${P/-simple/}/${PN}"
-
-JAVA_ANT_REWRITE_CLASSPATH="yes"
-EANT_GENTOO_CLASSPATH="slf4j-api"
-EANT_TEST_GENTOO_CLASSPATH="${EANT_GENTOO_CLASSPATH},junit-4"
-EANT_TEST_ANT_TASKS="ant-junit"
-EANT_EXTRA_ARGS="-Dmaven.build.finalName=${PN}"
-
-java_prepare() {
- cp "${FILESDIR}"/"${PV}"-build.xml build.xml || die
- find "${S}" -name "*.jar" -delete || die
-}
-
-src_test() {
- java-pkg-2_src_test
-}
-
-src_install() {
- java-pkg_dojar target/${PN}.jar
- use doc && java-pkg_dojavadoc target/site/apidocs
- use source && java-pkg_dosrc src/main/java/org
-}