summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/thor/Manifest1
-rw-r--r--dev-ruby/thor/thor-0.19.1.ebuild64
2 files changed, 0 insertions, 65 deletions
diff --git a/dev-ruby/thor/Manifest b/dev-ruby/thor/Manifest
index 9428c375e546..0b9619b1d27c 100644
--- a/dev-ruby/thor/Manifest
+++ b/dev-ruby/thor/Manifest
@@ -1,3 +1,2 @@
-DIST thor-git-0.19.1.tgz 86389 BLAKE2B e5fdadf13639c93cf36d8ce3c0124eed5bdfc738534652df75863728fd91241362dd5bba57d7bbef087b6f28be6e14bcb361b7ecaeea180012140f433ac33e3d SHA512 67aeaa2822b462c59ea9fd1a197222ce997b0edd30eb714b0a303c816acff82f4fb10a650b8a3c508c796426517ba25a462551fbc73ed7b33d4e16207cad8991
DIST thor-git-0.19.4.tgz 88733 BLAKE2B 8be54310cc4bf4a0308e6b103832831b89285003bb22a679986cd02636aaee57a25aa606f3e99bf532961a4e1d3625c46bfdb874a09f66cab85a21e5f7ed22d6 SHA512 a5cc52b23806e6104b12f924324960f2567bcd6c73b72ad47c33da222201b0377e7677b996698774de8adf3eff551926393785323ecf46cb59d72eb0e5b05aa0
DIST thor-git-0.20.0.tgz 91758 BLAKE2B 86e4079a86a9c65852e710e40e49e915afe5522512f061ecc62aed48acc08a5397cc82d45cff7c4b1dd549ec57d8699b9afe7c391ac9ab838d1ba9100f1f058a SHA512 aa5344c94cad7c33dd0582409dbcf9bd109bf97b37131357a4cc8a66317acf8781460e8fe5532b301a74521010be59bb34ac1c68bc01ad3140bfe73fedc2a451
diff --git a/dev-ruby/thor/thor-0.19.1.ebuild b/dev-ruby/thor/thor-0.19.1.ebuild
deleted file mode 100644
index 5c4bcef80a7f..000000000000
--- a/dev-ruby/thor/thor-0.19.1.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-USE_RUBY="ruby20 ruby21 ruby22 ruby23"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_RECIPE_TEST="rspec"
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-RUBY_FAKEGEM_BINWRAP="thor"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A scripting framework that replaces rake and sake"
-HOMEPAGE="http://whatisthor.com/"
-
-SRC_URI="https://github.com/erikhuda/${PN}/archive/v${PV}.tar.gz -> ${PN}-git-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux"
-IUSE="doc"
-
-# fakeweb is not compatible with ruby22. Upstream has switched to
-# webmock but leads to circular dependencies via childlabor's
-# dependencies, so skip tests for ruby22 for now.
-USE_RUBY="ruby20 ruby21" ruby_add_bdepend "
- test? (
- >=dev-ruby/fakeweb-1.3
- dev-ruby/childlabor
- )"
-
-all_ruby_prepare() {
- # Remove rspec default options (as we might not have the last
- # rspec).
- rm .rspec || die
-
- # Remove Bundler
- #rm Gemfile || die
- sed -i -e '/[Bb]undler/d' Thorfile || die
-
- # Remove mandatory coverage collection using simplecov which is not
- # packaged.
- sed -i -e '/require .simplecov/,/^end/ s:^:#:' spec/helper.rb || die
-
- # Avoid a spec that requires UTF-8 support, so LANG=C still works,
- # bug 430402
- sed -i -e '/uses maximum terminal width/,/end/ s:^:#:' spec/shell/basic_spec.rb || die
-}
-
-each_ruby_test() {
- case ${RUBY} in
- *ruby23)
- einfo "Skipping tests due to circular dependencies"
- ;;
- *ruby22)
- einfo "Skipping tests due to circular dependencies"
- ;;
- *)
- ruby-ng_rspec spec || die
- ;;
- esac
-}