summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-text/vilistextum/Manifest1
-rw-r--r--app-text/vilistextum/files/vilistextum-2.6.9-blockquote.patch113
-rw-r--r--app-text/vilistextum/files/vilistextum-2.6.9-darwin11.patch23
-rw-r--r--app-text/vilistextum/files/vilistextum-2.6.9-gentoo.diff22
-rw-r--r--app-text/vilistextum/files/vilistextum-2.6.9-prefix.patch27
-rw-r--r--app-text/vilistextum/vilistextum-2.6.9-r1.ebuild76
6 files changed, 0 insertions, 262 deletions
diff --git a/app-text/vilistextum/Manifest b/app-text/vilistextum/Manifest
index fe3cc0534af1..ff042089a352 100644
--- a/app-text/vilistextum/Manifest
+++ b/app-text/vilistextum/Manifest
@@ -1,2 +1 @@
-DIST vilistextum-2.6.9.tar.bz2 147743 BLAKE2B 1cf6f187cb277271ddd9946984afb4d59336ea0cd446e62df3593070ccc63b3510a107e2b7e7b8dc757c63e4f5caf3790c7d998b6be325f4d22d2a6b9fea3432 SHA512 ce76a4061b766e4544d1a86986333314a3b6959439ba6995a2977c10b01b0142c524d4b215c3272a1dcfcc4f5b6fda03210de95d65cedecfc6a1c940cedf487d
DIST vilistextum-2.8.0.20200411.tar.gz 219791 BLAKE2B 95b86d17e8dbf29b520aa48c88eb8c9e8abb01a234848ed55bdad0a63a7c0ec8ca9ae7c437fe7f84bbf7f4dad74fc8437a9e3b53493552e9e01b8029b10ef18a SHA512 40a219ebe7bebd61548a3bad794690cf091b67b70e8e6c44548a0c1b9f61077b141a035335e7128b191a8501103707f5324b00326a407e29ec0fee383c4d0917
diff --git a/app-text/vilistextum/files/vilistextum-2.6.9-blockquote.patch b/app-text/vilistextum/files/vilistextum-2.6.9-blockquote.patch
deleted file mode 100644
index 395d03a7456f..000000000000
--- a/app-text/vilistextum/files/vilistextum-2.6.9-blockquote.patch
+++ /dev/null
@@ -1,113 +0,0 @@
-Many clients seem to use blockquote tags to flag quotes these days, so
-write them out as quotes, so they remain readable.
-
---- vilistextum-2.6.9/src/html_tag.c
-+++ vilistextum-2.6.9/src/html_tag.c
-@@ -87,8 +87,8 @@
-
- else if CMP("P", str) { start_p(); }
- else if CMP("/P", str) { paragraphen_ende(); }
-- else if CMP("BLOCKQUOTE", str) { start_p(); }
-- else if CMP("/BLOCKQUOTE", str) { paragraphen_ende(); }
-+ else if CMP("BLOCKQUOTE", str) { start_p(); quote++; }
-+ else if CMP("/BLOCKQUOTE", str) { paragraphen_ende(); if (quote>0) quote--;}
- else if CMP("Q", str) { wort_plus_ch('"'); }
- else if CMP("/Q", str) { wort_plus_ch('"'); }
-
---- vilistextum-2.6.9/src/multibyte.h
-+++ vilistextum-2.6.9/src/multibyte.h
-@@ -16,6 +16,7 @@
- #define ATOI(n) wcstoi(n)
-
- #define ONESPACE L" "
-+ #define QUOTE L">"
- #define WORT_PLUS_STRING(str) wort_plus_string(L##str)
-
- #define STRSTR(haystack, needle) wcsstr(haystack, L##needle)
-@@ -40,6 +41,7 @@
- #define ATOI(n) atoi(n)
-
- #define ONESPACE " "
-+ #define QUOTE ">"
- #define WORT_PLUS_STRING(str) wort_plus_string(str)
-
- #define STRSTR(haystack, needle) strstr(haystack, needle)
---- vilistextum-2.6.9/src/text.h
-+++ vilistextum-2.6.9/src/text.h
-@@ -26,6 +26,7 @@
-
- int tab;
- int spaces;
-+int quote;
-
- void print_zeile();
- int is_zeile_empty();
---- vilistextum-2.6.9/src/text.c
-+++ vilistextum-2.6.9/src/text.c
-@@ -28,6 +28,7 @@
- int breite=76,
- hr_breite=76,
- paragraph=0,
-+ quote=0,
-
- tab=4, /* tabulator */
- spaces=0, /* spaces at beginning of line */
-@@ -325,6 +326,12 @@
- printf(" z0: zeilen_pos: %d\n",zeilen_pos);
- #endif
- print_zeile();
-+ if (quote > 0)
-+ {
-+ i=0;
-+ while (i<quote) { zeile_plus_wort(QUOTE,1,1); i++; }
-+ zeile_plus_wort(ONESPACE,1,1);
-+ }
- i=0;
- while (i<spaces) { zeile_plus_wort(ONESPACE,1,1); i++; }
- if (orderedlist>0) { zeile_plus_wort(ONESPACE,1,1); }
-@@ -345,6 +352,12 @@
- printf(" z2: zeilen_len: %d\n",zeilen_len);
- printf(" z2: zeilen_pos: %d\n",zeilen_pos);
- #endif
-+ if (quote > 0)
-+ {
-+ i=0;
-+ while (i<quote) { zeile_plus_wort(QUOTE,1,1); i++; }
-+ zeile_plus_wort(ONESPACE,1,1);
-+ }
- i=0;
- while (i<spaces) { zeile_plus_wort(ONESPACE,1,1); i++; }
- if (orderedlist>0) { zeile_plus_wort(ONESPACE,1,1); }
---- vilistextum-2.6.9/tests/check_utf8
-+++ vilistextum-2.6.9/tests/check_utf8
-@@ -9,5 +9,6 @@
- rm -f utf-8-sampler.output.test
- ../src/vilistextum utf-8-sampler.html utf-8-sampler.output.test
-
--diff >/dev/null utf-8-sampler.output utf-8-sampler.output.test
-+sed 's/^> //' utf-8-sampler.output.test | \
-+diff >/dev/null utf-8-sampler.output -
-
---- vilistextum-2.6.9/tests/utf-8-sampler.output
-+++ vilistextum-2.6.9/tests/utf-8-sampler.output
-@@ -100,8 +100,8 @@
- ვეპხის ტყაოსანი შოთა რუსთაველი
-
- ღმერთსი შემვედრე, ნუთუ კვლა დამხსნას სოფლისა შრომასა, ცეცხლს, წყალსა და
--მიწასა, ჰაერთა თანა მრომასა; მომცნეს ფრთენი და აღვფრინდე, მივჰხვდე მას ჩემსა
--ნდომასა, დღისით და ღამით ვჰხედვიდე მზისა ელვათა კრთომაასა.
-+მიწასა, ჰაერთა თანა მრომასა; მომცნეს ფრთენი და აღვფრინდე, მივჰხვდე მას
-+ჩემსა ნდომასა, დღისით და ღამით ვჰხედვიდე მზისა ელვათა კრთომაასა.
-
- Tamil poetry of Cupiramaniya Paarathiyar: சுப்ரமணிய பாரதியார் (1882-1921)
-
-@@ -446,7 +446,8 @@
- д, п, and/or т:
-
- Bulgarian:   [ бгдпт ]   [ бгдпт ]   Мога да ям стъкло и не ме боли.
-- Russian: [ бгдпт ]   [ бгдпт ]   Я могу есть стекло, это мне не вредит.
-+ Russian: [ бгдпт ]   [ бгдпт ]   Я могу есть стекло, это мне не
-+вредит.
- Serbian: [ бгдпт ]   [ бгдпт ]   Могу јести стакло а да ми не шкоди.
-
- ------------------------------------------------------------------------
diff --git a/app-text/vilistextum/files/vilistextum-2.6.9-darwin11.patch b/app-text/vilistextum/files/vilistextum-2.6.9-darwin11.patch
deleted file mode 100644
index bda9f5d39c3e..000000000000
--- a/app-text/vilistextum/files/vilistextum-2.6.9-darwin11.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-OSX Lion has wcscasecmp, but is not GNU
-
---- configure.in
-+++ configure.in
-@@ -67,6 +67,7 @@
- dnl Checks for library functions.
- AC_CHECK_FUNCS(strstr)
- AC_CHECK_FUNCS(strcasecmp)
-+AC_CHECK_FUNCS(wcscasecmp)
-
- dnl create testsuite
- dnl AC_CONFIG_TESTDIR([tests])
---- src/html.c
-+++ src/html.c
-@@ -40,7 +40,7 @@
- link_inline[DEF_STR_LEN]; /* Link of a HTML-Tag */
-
- /* ------------------------------------------------ */
--#if defined(MULTIBYTE) && ! defined(__GNU_LIBRARY__)
-+#if defined(MULTIBYTE) && ! defined(HAVE_WCSCASECMP)
- #include <wchar.h>
- static int wcscasecmp(const wchar_t *s1, const wchar_t *s2)
- {
diff --git a/app-text/vilistextum/files/vilistextum-2.6.9-gentoo.diff b/app-text/vilistextum/files/vilistextum-2.6.9-gentoo.diff
deleted file mode 100644
index 42db519b080a..000000000000
--- a/app-text/vilistextum/files/vilistextum-2.6.9-gentoo.diff
+++ /dev/null
@@ -1,22 +0,0 @@
-diff -ur vilistextum-2.6.9/src/Makefile.am vilistextum-2.6.9.new/src/Makefile.am
---- vilistextum-2.6.9/src/Makefile.am 2006-10-24 01:48:54.000000000 +0700
-+++ vilistextum-2.6.9.new/src/Makefile.am 2006-11-20 09:51:24.000000000 +0700
-@@ -6,7 +6,7 @@
- main.c main.h util.c util.h \
- multibyte.h unicode_entities.c unicode_entities.h
-
--AM_CFLAGS = -Wall -O2 -ansi
-+AM_CFLAGS = -Wall -ansi
- AM_LDFLAGS = $(STATIC)
-
- EXTRA_DIST = kilistextum.kaptn
-diff -ur vilistextum-2.6.9/tests/Makefile.am vilistextum-2.6.9.new/tests/Makefile.am
---- vilistextum-2.6.9/tests/Makefile.am 2004-07-06 19:06:20.000000000 +0700
-+++ vilistextum-2.6.9.new/tests/Makefile.am 2006-11-20 09:51:05.000000000 +0700
-@@ -16,5 +16,5 @@
-
- test: check
-
--all: check
-+all:
-
diff --git a/app-text/vilistextum/files/vilistextum-2.6.9-prefix.patch b/app-text/vilistextum/files/vilistextum-2.6.9-prefix.patch
deleted file mode 100644
index 1ff76250db13..000000000000
--- a/app-text/vilistextum/files/vilistextum-2.6.9-prefix.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-* don't look in /usr/local
-* try to hack around not being able to use AM_ICONV
-
---- configure.in.orig 2006-10-23 22:20:19 +0200
-+++ configure.in 2010-03-18 19:32:13 +0100
-@@ -21,10 +21,6 @@
- AC_HEADER_STDC
- AC_CHECK_HEADERS(getopt.h)
-
--dnl add /usr/local
--CFLAGS="$CFLAGS -I/usr/local/include"
--LDFLAGS="$LDFLAGS -L/usr/local/lib"
--
- dnl checking for options
- AC_MSG_CHECKING(if --enable-multibyte specified)
- AC_ARG_ENABLE(multibyte,
-@@ -41,7 +37,9 @@
- AC_CHECK_HEADERS(iconv.h,,
- AC_MSG_ERROR(Need libiconv or iconv.h for multibyte support))
-
--AC_CHECK_LIB(iconv, iconv,,
-+dnl iconv_open_into is implemented only in GNU libiconv and not in other
-+dnl iconv implementations
-+AC_CHECK_LIB(iconv, libiconv_open_into,,
- AC_MSG_WARN([Generic iconv found but not libiconv. See INSTALL for details]))
-
- dnl setting INTERNAL_LOCALE
diff --git a/app-text/vilistextum/vilistextum-2.6.9-r1.ebuild b/app-text/vilistextum/vilistextum-2.6.9-r1.ebuild
deleted file mode 100644
index 378b7e597fb2..000000000000
--- a/app-text/vilistextum/vilistextum-2.6.9-r1.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit epatch autotools
-
-DESCRIPTION="HTML to ASCII converter programmed to handle incorrect html"
-HOMEPAGE="https://bhaak.net/vilistextum/"
-SRC_URI="https://bhaak.net/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
-#IUSE="unicode kde"
-IUSE="unicode"
-
-DEPEND="virtual/libiconv"
-RDEPEND=""
-# KDE support will be available once a version of kaptain in stable
-# kde? ( kde-misc/kaptain )"
-
-src_prepare() {
- epatch \
- "${FILESDIR}/${P}-gentoo.diff" \
- "${FILESDIR}/${P}-prefix.patch" \
- "${FILESDIR}/${P}-darwin11.patch" \
- "${FILESDIR}/${P}-blockquote.patch"
- eautoreconf
-}
-
-get_locale() {
- locale -a | grep -i "$1\.utf.*8\$"
-}
-
-find_locale() {
- local l t
-
- # we basically prefer to find en_US.UTF-8, but it may not always be
- # available, in which case it is better not to hardcode to use it
- l=$(get_locale en_US)
- if [[ -z ${l} ]] ; then
- for t in "en_GB" "en_.*" ".*" ; do
- l=$(get_locale ${t})
- if [[ -n ${l} ]] ; then
- l=${l%%$'\n'*}
- break;
- fi
- done
- fi
- [[ -z ${l} ]] && die "Failed to find a unicode locale"
- echo "${l}"
-}
-
-src_configure() {
- # need hardwired locale simply because locale -a | grep -i utf-8 | head -n1
- # isn't always returning the most sensical (and working) locale
- econf \
- $(use_enable unicode multibyte) \
- $(use_with unicode unicode-locale $(find_locale))
-}
-
-src_test() {
- if $(locale -a | grep -iq "en_US\.utf.*8"); then
- emake -j1 check
- else
- ewarn "If you like to run the test,"
- ewarn "please make sure en_US.UTF-8 is installed."
- die "en_US.UTF-8 locale is missing"
- fi
-}
-
-src_install() {
- default
- dohtml doc/*.html
-}