summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/nghttp2/Manifest1
-rw-r--r--net-libs/nghttp2/nghttp2-1.39.1.ebuild75
2 files changed, 0 insertions, 76 deletions
diff --git a/net-libs/nghttp2/Manifest b/net-libs/nghttp2/Manifest
index 8c85d782df5f..0fb0e2447e47 100644
--- a/net-libs/nghttp2/Manifest
+++ b/net-libs/nghttp2/Manifest
@@ -1,2 +1 @@
-DIST nghttp2-1.39.1.tar.xz 1634512 BLAKE2B 66444de067200a7dd66f162c22fd258471d336b1ba02f579a675b5d9dfcbf1600fcfb92a37797842a0482bd0f5c850008508d3d41f7afddc47f7c9330fb34b43 SHA512 36558ed03c59086086abbf144ec7c54c60de3fea00a9ea594feea7186a779781cbb66a08c9b34265892dea382b42b875f551e85331cfa0086e357f9b27b919fa
DIST nghttp2-1.39.2.tar.xz 1635428 BLAKE2B 4569774c33f17d51ac889c385697fcead82106db421399ceb22ad2aafabe64a576445d9272adcf37e2fec47cdd6ac1dc6423efd49012ca7be0aa2087609a0397 SHA512 d8c971543e3e87736dfafebca55e9ecd0644e304c9731edaccba34170205824476595861a439077289b438ad489dd6008dedf2c6b2c111920300329be1b1bf34
diff --git a/net-libs/nghttp2/nghttp2-1.39.1.ebuild b/net-libs/nghttp2/nghttp2-1.39.1.ebuild
deleted file mode 100644
index 2142ab3bd2e9..000000000000
--- a/net-libs/nghttp2/nghttp2-1.39.1.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# TODO: Add python support.
-
-EAPI=7
-
-inherit multilib-minimal
-
-if [[ ${PV} == 9999 ]] ; then
- EGIT_REPO_URI="https://github.com/nghttp2/nghttp2.git"
- inherit autotools git-r3
-else
- SRC_URI="https://github.com/nghttp2/nghttp2/releases/download/v${PV}/${P}.tar.xz"
- KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-fbsd"
-fi
-
-DESCRIPTION="HTTP/2 C Library"
-HOMEPAGE="https://nghttp2.org/"
-
-LICENSE="MIT"
-SLOT="0/1.14" # <C++>.<C> SONAMEs
-IUSE="cxx debug hpack-tools jemalloc libressl static-libs test +threads utils xml"
-
-SSL_DEPEND="
- !libressl? ( >=dev-libs/openssl-1.0.2:0=[-bindist,${MULTILIB_USEDEP}] )
- libressl? ( dev-libs/libressl:=[${MULTILIB_USEDEP}] )
-"
-RDEPEND="
- cxx? (
- ${SSL_DEPEND}
- dev-libs/boost:=[${MULTILIB_USEDEP},threads]
- )
- hpack-tools? ( >=dev-libs/jansson-2.5 )
- jemalloc? ( dev-libs/jemalloc[${MULTILIB_USEDEP}] )
- utils? (
- ${SSL_DEPEND}
- >=dev-libs/libev-4.15[${MULTILIB_USEDEP}]
- >=sys-libs/zlib-1.2.3[${MULTILIB_USEDEP}]
- net-dns/c-ares:=[${MULTILIB_USEDEP}]
- )
- xml? ( >=dev-libs/libxml2-2.7.7:2[${MULTILIB_USEDEP}] )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
-
-src_prepare() {
- default
- [[ ${PV} == 9999 ]] && eautoreconf
-}
-
-multilib_src_configure() {
- local myeconfargs=(
- --disable-examples
- --disable-failmalloc
- --disable-python-bindings
- --disable-werror
- --without-cython
- $(use_enable cxx asio-lib)
- $(use_enable debug)
- $(multilib_native_use_enable hpack-tools)
- $(use_enable static-libs static)
- $(use_enable threads)
- $(multilib_native_use_enable utils app)
- $(multilib_native_use_with jemalloc)
- $(multilib_native_use_with xml libxml2)
- )
- ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
-}
-
-multilib_src_install_all() {
- if ! use static-libs ; then
- find "${ED}"/usr -name '*.la' -delete || die
- fi
-}