summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-sports/torcs/files/torcs-1.3.6-gcc7.patch11
-rw-r--r--games-sports/torcs/torcs-1.3.6-r1.ebuild3
2 files changed, 13 insertions, 1 deletions
diff --git a/games-sports/torcs/files/torcs-1.3.6-gcc7.patch b/games-sports/torcs/files/torcs-1.3.6-gcc7.patch
new file mode 100644
index 000000000000..af139ad509de
--- /dev/null
+++ b/games-sports/torcs/files/torcs-1.3.6-gcc7.patch
@@ -0,0 +1,11 @@
+--- a/src/libs/musicplayer/OpenALMusicPlayer.cpp
++++ b/src/libs/musicplayer/OpenALMusicPlayer.cpp
+@@ -161,7 +161,7 @@
+ {
+ char pcm[BUFFERSIZE];
+ int size = 0;
+- const char* error = '\0';
++ const char* error = "";
+
+ if (!stream->read(pcm, BUFFERSIZE, &size, &error)) {
+ GfError("OpenALMusicPlayer: Stream read error: %s\n", error);
diff --git a/games-sports/torcs/torcs-1.3.6-r1.ebuild b/games-sports/torcs/torcs-1.3.6-r1.ebuild
index c92083f6cbc0..6b7ba9ad5785 100644
--- a/games-sports/torcs/torcs-1.3.6-r1.ebuild
+++ b/games-sports/torcs/torcs-1.3.6-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -34,6 +34,7 @@ PATCHES=(
"${FILESDIR}"/${P}-format.patch
"${FILESDIR}"/${P}-noXmuXt.patch
"${FILESDIR}"/${P}-gcc6.patch
+ "${FILESDIR}"/${P}-gcc7.patch
)
src_prepare() {