summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emulation/containerd/Manifest2
-rw-r--r--app-emulation/containerd/containerd-0.2.0.ebuild43
-rw-r--r--app-emulation/containerd/containerd-0.2.4.ebuild40
3 files changed, 0 insertions, 85 deletions
diff --git a/app-emulation/containerd/Manifest b/app-emulation/containerd/Manifest
index eed951ec3c94..12adee68ecaa 100644
--- a/app-emulation/containerd/Manifest
+++ b/app-emulation/containerd/Manifest
@@ -1,3 +1 @@
-DIST containerd-0.2.0.tar.gz 635248 SHA256 1462e0c233763800b91ac2a670d82994ba1988560928e153f751fb1c0a6608c0 SHA512 381c0a21733fb79e90364649b46cbdadbc32d07245bd7a320465f6619ee5895e9552b7cc4393cb8d409295a7b867b7e461c079715cf1938e6313d4b888d81518 WHIRLPOOL d4e70a8be832227be671c13b77242a790cdf8645ff294c31d72e8cf01de2b30b9d78c691a156624adb004de42af6f133cb88b46aff37a33bc94d72bf87a0ee8a
-DIST containerd-0.2.4.tar.gz 1002344 SHA256 34805aef6300fbf37adcf4362a2315fac1ea57a9ceb8b0c7b1a0859cba975428 SHA512 f35d8d31cc76c1bf3dcbe25178868ce64624e6032756813e13222816155c10941abdaf7ba0558297f87557336a6e3d07eda06dbfd1099ee8de328f1ecc93c413 WHIRLPOOL 1f3c4b2f5a9e0d2265ec2d4162ff1a4b609ba28d3a94794e1a73129c070a240fd6ee9a3c2cfdcd76ff2fe378a7549b390cacb34e2ed7915fa5a304bb84b397c7
DIST containerd-0.2.5.tar.gz 1003500 SHA256 88e099af66b50abe7f2159f13bdab793fa5199d8d5b9a9ef7a68171abb4359be SHA512 ba1e074bb7556a7c4be4d68dc62aa2fa4b823682c209d1609c1f11518a7b7167139ea159d31e0b21ba190d83115a67e5e45b54b6a4770742d49e9e561309551f WHIRLPOOL eb3622ba99c4d4806bda9a45853422a5b0b884869ed3be4c3caec4c20f49027e8db78b9885eca7bc83a0f3b08e9a66eca950390f0eda1ef2535fd3ab41623bf4
diff --git a/app-emulation/containerd/containerd-0.2.0.ebuild b/app-emulation/containerd/containerd-0.2.0.ebuild
deleted file mode 100644
index 6bead415e485..000000000000
--- a/app-emulation/containerd/containerd-0.2.0.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-EGO_PN="github.com/docker/${PN}"
-
-if [[ ${PV} == *9999 ]]; then
- inherit golang-vcs
-else
- MY_PV="${PV/_/-}"
- EGIT_COMMIT="v${MY_PV}"
- SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64"
- inherit golang-vcs-snapshot
-fi
-
-DESCRIPTION="A daemon to control runC"
-HOMEPAGE="https://containerd.tools"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="+seccomp"
-
-DEPEND=""
-RDEPEND="=app-emulation/runc-0.1.0
- seccomp? ( sys-libs/libseccomp )"
-
-S=${WORKDIR}/${P}/src/${EGO_PN}
-
-src_prepare() {
- eapply_user
-}
-
-src_compile() {
- local options=( $(usex seccomp "seccomp") )
- export GOPATH="${WORKDIR}/${P}" # ${PWD}/vendor
- LDFLAGS= emake GIT_COMMIT="$EGIT_COMMIT" BUILDTAGS="${options[@]}"
-}
-
-src_install() {
- dobin bin/containerd* bin/ctr
-}
diff --git a/app-emulation/containerd/containerd-0.2.4.ebuild b/app-emulation/containerd/containerd-0.2.4.ebuild
deleted file mode 100644
index 2fce33a3eb66..000000000000
--- a/app-emulation/containerd/containerd-0.2.4.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-EGO_PN="github.com/docker/${PN}"
-
-if [[ ${PV} == *9999 ]]; then
- inherit golang-vcs
-else
- MY_PV="${PV/_/-}"
- EGIT_COMMIT="v${MY_PV}"
- SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~ppc64"
- inherit golang-vcs-snapshot
-fi
-
-DESCRIPTION="A daemon to control runC"
-HOMEPAGE="https://containerd.tools"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="hardened +seccomp"
-
-DEPEND=""
-RDEPEND=">=app-emulation/runc-1.0.0_rc2
- seccomp? ( sys-libs/libseccomp )"
-
-S=${WORKDIR}/${P}/src/${EGO_PN}
-
-src_compile() {
- local options=( $(usex seccomp "seccomp") )
- export GOPATH="${WORKDIR}/${P}" # ${PWD}/vendor
- LDFLAGS=$(usex hardened '-extldflags -fno-PIC' '') \
- emake GIT_COMMIT="$EGIT_COMMIT" BUILDTAGS="${options[@]}"
-}
-
-src_install() {
- dobin bin/containerd* bin/ctr
-}