summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-misc/fdupes/Manifest1
-rw-r--r--app-misc/fdupes/fdupes-1.5.1.ebuild (renamed from app-misc/fdupes/fdupes-1.51.ebuild)12
-rw-r--r--app-misc/fdupes/fdupes-1.6.1.ebuild30
3 files changed, 36 insertions, 7 deletions
diff --git a/app-misc/fdupes/Manifest b/app-misc/fdupes/Manifest
index db0a598fd79c..c364ab0dd86c 100644
--- a/app-misc/fdupes/Manifest
+++ b/app-misc/fdupes/Manifest
@@ -1 +1,2 @@
DIST fdupes-1.51.tar.gz 48942 SHA256 87dbc85b7b9cdb9626e713dd8078bd7487bceb58d47ceaff5404a9e6fd062881 SHA512 7cbc414f25427793317667b8d5494f7247a08ba402855929de77d1db01eb3dce41ea608f8dcca047c4a7856e02b10261982cf2acd7f6a79ab726b3009c710a8d WHIRLPOOL 49c4ac195270972246e54f1249749afde889926067e6a3c88f14dbe738b1ba40c085c4b6c9fc0bcbb3fa83de0bf21c54a24eea91307143083648b333c50d7305
+DIST fdupes-1.6.1.tar.gz 20869 SHA256 9d6b6fdb0b8419815b4df3bdfd0aebc135b8276c90bbbe78ebe6af0b88ba49ea SHA512 6c6662b70068c2f48f4be64a6830c81a66852d650391d0756f20b9ac0df7d70c1a32918bd7cbd50e19de524d9ebc09ea338c19636e1807b071eb96b325e641db WHIRLPOOL 811daccb06f2061b9ad2b6c86a2126c0ea1a496f1fd712dbebb1be0427c8cf35d03f001f810af92ecc57f4c5af98a32df8ce26231fbd0b7b8cb203e5f5662e4f
diff --git a/app-misc/fdupes/fdupes-1.51.ebuild b/app-misc/fdupes/fdupes-1.5.1.ebuild
index 3a43ae96e39f..4225cb93163d 100644
--- a/app-misc/fdupes/fdupes-1.51.ebuild
+++ b/app-misc/fdupes/fdupes-1.5.1.ebuild
@@ -7,13 +7,11 @@ EAPI=5
inherit eutils flag-o-matic toolchain-funcs
MY_P="${PN}-${PV/_pre/-PR}"
+MY_P="${MY_P/5\.1/51}"
DESCRIPTION="Identify/delete duplicate files residing within specified directories"
-HOMEPAGE="https://github.com/adrianlopezroche/fdupes https://code.google.com/p/fdupes/"
-SRC_URI="
- https://fdupes.googlecode.com/files/${P}.tar.gz
- https://github.com/adrianlopezroche/${PN}/archive/${P}.tar.gz
- "
+HOMEPAGE="https://github.com/adrianlopezroche/fdupes"
+SRC_URI="https://github.com/adrianlopezroche/${PN}/archive/${P/5\.1/51}.tar.gz"
LICENSE="MIT"
SLOT="0"
@@ -24,10 +22,10 @@ S="${WORKDIR}/${MY_P}"
src_prepare() {
epatch \
- "${FILESDIR}"/${P}-makefile.patch \
+ "${FILESDIR}"/${PN}-1.51-makefile.patch \
"${FILESDIR}"/${PN}-1.50_pre2-compare-file.patch \
"${FILESDIR}"/${PN}-1.50_pre2-typo.patch \
- "${FILESDIR}"/${P}-fix-stdin-lvalue.patch
+ "${FILESDIR}"/${PN}-1.51-fix-stdin-lvalue.patch
append-lfs-flags
}
diff --git a/app-misc/fdupes/fdupes-1.6.1.ebuild b/app-misc/fdupes/fdupes-1.6.1.ebuild
new file mode 100644
index 000000000000..7d51f8455ae6
--- /dev/null
+++ b/app-misc/fdupes/fdupes-1.6.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Identify/delete duplicate files residing within specified directories"
+HOMEPAGE="https://github.com/adrianlopezroche/fdupes"
+SRC_URI="https://github.com/adrianlopezroche/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE=""
+
+src_prepare() {
+ append-lfs-flags
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ dobin fdupes
+ doman fdupes.1
+ dodoc CHANGES CONTRIBUTORS README TODO
+}