summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/ofono/Manifest1
-rw-r--r--net-misc/ofono/ofono-1.28.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/net-misc/ofono/Manifest b/net-misc/ofono/Manifest
index 0107e32033e9..a3274d103b79 100644
--- a/net-misc/ofono/Manifest
+++ b/net-misc/ofono/Manifest
@@ -2,3 +2,4 @@ DIST ofono-1.16.tar.xz 854296 BLAKE2B 4ee8f895e21903b8181fe14f5a91fea466eb3a2f66
DIST ofono-1.20.tar.xz 935448 BLAKE2B 751f6c340cf95dd4ab6f3d17f81a967406b3f6cc4d6024435aba1e663a220a47d14f04d62b765205bf04f11a9b5b0075501dbbaaa22f9380ffb0ef3a78fce5ec SHA512 8dc86654ae8a1dc1761c95df5f0de55566db20012e523f11bcd5ab5e1540f4cd9fc7bd6bf1665dcbeb31f2925f9322c21fd05fb00034e408b5d85b265e2fe840
DIST ofono-1.23.tar.xz 978472 BLAKE2B 0bd0b7921df075f0ea35d61d4ea852dad0bc752802263f8525e697f3b23e555488116918fed8f143c95ae6fc919515cbb06d0644f7119225076d1fe7c5be1f52 SHA512 103dc28f9a6c583804884bdb891424eb53323b5edf764edd6c64e0b6c76ee6ea063c6a1d1d36a35d4ae6740e00479e2fc0abc6fca1dc92b916e166d48a1642fd
DIST ofono-1.24.tar.xz 980644 BLAKE2B 74974ab104cc31a67ec04c62149e282de5295573e1b236b39da8005721c8277a0636fd290aaa3c6380eb117364d2098af856f22ce9f6d41af599c5bf78bf98b1 SHA512 d3148df4bcac60c0f12bc4665e170e92d35473a7ff9fc516bd6a3c35c3e9b6f9beadc624ac9bbdfb9de2876e4ab417d857bd52b27a634f433f3607a7e11381c3
+DIST ofono-1.28.tar.xz 1016308 BLAKE2B 0aec5bc6c845c0906548f62bda95bfee5ca5ef17bc2defd60fe4b0967b9f58fcbbbfeb9593aa33f6852360266ea4ea025a87a07ac95ef50829b592accfb5bc72 SHA512 963471fac89db746d0e99fee805413342203be0d200bc14f0e56c5ec3053e25ea8112943657c88c57c539ae485ac11eb5f80052aad12443c248888f6e6a4114e
diff --git a/net-misc/ofono/ofono-1.28.ebuild b/net-misc/ofono/ofono-1.28.ebuild
new file mode 100644
index 000000000000..ca819ad691d5
--- /dev/null
+++ b/net-misc/ofono/ofono-1.28.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils multilib systemd
+
+DESCRIPTION="Open Source mobile telephony (GSM/UMTS) daemon"
+HOMEPAGE="https://01.org/ofono"
+SRC_URI="mirror://kernel/linux/network/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+atmodem bluetooth +cdmamodem +datafiles doc dundee examples +isimodem +phonesim +provision +qmimodem tools +udev upower"
+
+REQUIRED_USE="dundee? ( bluetooth )"
+
+RDEPEND=">=sys-apps/dbus-1.4
+ >=dev-libs/glib-2.32
+ net-misc/mobile-broadband-provider-info
+ bluetooth? ( >=net-wireless/bluez-4.99 )
+ udev? ( virtual/udev )
+ examples? ( dev-python/dbus-python )
+ tools? ( virtual/libusb:1 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( ChangeLog AUTHORS )
+
+src_configure() {
+ econf \
+ $(use_enable udev) \
+ $(use_enable isimodem) \
+ $(use_enable atmodem) \
+ $(use_enable cdmamodem) \
+ $(use_enable datafiles) \
+ $(use_enable dundee) \
+ $(use_enable bluetooth) \
+ $(use_enable phonesim) \
+ $(use_enable provision) \
+ $(use_enable qmimodem) \
+ $(use_enable tools) \
+ $(use_enable examples test) \
+ $(use_enable upower) \
+ --disable-maintainer-mode \
+ --disable-rilmodem
+ --localstatedir=/var \
+ --with-systemdunitdir="$(systemd_get_systemunitdir)"
+}
+
+src_install() {
+ default
+
+ if use tools ; then
+ dobin tools/auto-enable \
+ tools/huawei-audio \
+ tools/lookup-provider-name \
+ tools/lookup-apn \
+ tools/get-location \
+ tools/tty-redirector
+ fi
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ use doc && dodoc doc/*.txt
+}