summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-p2p/deluge/files/deluge-1.3.15-r1-fix-preferences-ui.patch32
-rw-r--r--net-p2p/deluge/files/deluge-1.3.5-disable_libtorrent_internal_copy.patch42
2 files changed, 0 insertions, 74 deletions
diff --git a/net-p2p/deluge/files/deluge-1.3.15-r1-fix-preferences-ui.patch b/net-p2p/deluge/files/deluge-1.3.15-r1-fix-preferences-ui.patch
deleted file mode 100644
index a63e5de10de1..000000000000
--- a/net-p2p/deluge/files/deluge-1.3.15-r1-fix-preferences-ui.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 38d7b7cdfde3c50d6263602ffb03af92fcbfa52e Mon Sep 17 00:00:00 2001
-From: Calum Lind <calumlind+deluge@gmail.com>
-Date: Sat, 13 May 2017 00:05:48 +0100
-Subject: [GTKUI] Fix keyerror showing prefs
-
- * Fix the single_proxy ui to True as unlikely any users using <=0.15
- and need to have different proxy type settings.
----
- deluge/ui/gtkui/preferences.py | 7 ++-----
- 1 file changed, 2 insertions(+), 5 deletions(-)
-
-diff --git a/deluge/ui/gtkui/preferences.py b/deluge/ui/gtkui/preferences.py
-index 645ad26..efcd93d 100644
---- a/deluge/ui/gtkui/preferences.py
-+++ b/deluge/ui/gtkui/preferences.py
-@@ -318,11 +318,8 @@ class Preferences(component.Component):
- }
- # Add proxy stuff
-
-- # Display workaround for single proxy in libtorrent >v0.16
-- try:
-- lt_single_proxy = component.get("PreferencesManager").LT_SINGLE_PROXY
-- except AttributeError:
-- lt_single_proxy = False
-+ # Display workaround for single proxy in libtorrent >= v0.16
-+ lt_single_proxy = True
-
- for t in ("peer", "web_seed", "tracker", "dht"):
- if lt_single_proxy and not t == "peer":
---
-cgit v1.1
-
diff --git a/net-p2p/deluge/files/deluge-1.3.5-disable_libtorrent_internal_copy.patch b/net-p2p/deluge/files/deluge-1.3.5-disable_libtorrent_internal_copy.patch
deleted file mode 100644
index 349261426de8..000000000000
--- a/net-p2p/deluge/files/deluge-1.3.5-disable_libtorrent_internal_copy.patch
+++ /dev/null
@@ -1,42 +0,0 @@
---- a/setup.py
-+++ b/setup.py
-@@ -205,38 +205,7 @@
-
- _ext_modules = []
-
--# Check for a system libtorrent and if found, then do not build the libtorrent extension
--build_libtorrent = True
--try:
-- from deluge._libtorrent import lt
--except ImportError:
-- build_libtorrent = True
--else:
-- build_libtorrent = False
--
--if build_libtorrent:
-- got_libtorrent = False
-- if not os.path.exists("libtorrent"):
-- import subprocess
-- if subprocess.call(['./get_libtorrent.sh']) > 0:
-- got_libtorrent = False
-- else:
-- got_libtorrent = True
-- else:
-- got_libtorrent = True
--
-- if got_libtorrent:
-- # There isn't a system libtorrent library, so let's build the one included with deluge
-- libtorrent = Extension(
-- 'libtorrent',
-- extra_compile_args = _extra_compile_args,
-- include_dirs = _include_dirs,
-- libraries = _libraries,
-- library_dirs = _library_dirs,
-- sources = _sources
-- )
--
-- _ext_modules = [libtorrent]
-+import deluge._libtorrent
-
- desktop_data = 'deluge/data/share/applications/deluge.desktop'
-