summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/rpy/Manifest1
-rw-r--r--dev-python/rpy/rpy-3.4.2.ebuild44
2 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/rpy/Manifest b/dev-python/rpy/Manifest
index b7a72bff3330..2353a14c03d4 100644
--- a/dev-python/rpy/Manifest
+++ b/dev-python/rpy/Manifest
@@ -1,2 +1 @@
-DIST rpy2-3.4.2.tar.gz 186064 BLAKE2B 5c800f546240cc33e6341973adae813edcdaa88e90ea0274e97075bc4516ced20828ccc6010ae23aead0b227639158240dae9b678790e0d28f974f10e9ac0e5f SHA512 e754d082bf392de582829bc078b512a071d0c0aa79ce3ed3692ad88b3816863b520a4ef9bbeaccbb2a7284685e470f345ba103e3db78a1c95187c0b554565314
DIST rpy2-3.4.5.tar.gz 194433 BLAKE2B 588c1c270d69b0214e77e586c4c66e78ae8912b6c10a2fe082be64dc75dff574fa0ab6d5bc500b8ff6a199de8540f508467bf0210f1c66b779857dee767262ab SHA512 296056e1c64a4555a1ccef74cfb580674034155a42b8e7c83feb8bb7d7a6d80b8e2f2966df53a6ed8612718ad169755a7994c5635dda1d1c8af1b549a5863935
diff --git a/dev-python/rpy/rpy-3.4.2.ebuild b/dev-python/rpy/rpy-3.4.2.ebuild
deleted file mode 100644
index 996c66c3e50a..000000000000
--- a/dev-python/rpy/rpy-3.4.2.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-PYTHON_REQ_USE="sqlite"
-inherit distutils-r1 flag-o-matic virtualx
-
-MYSLOT=2
-MY_PN=${PN}${MYSLOT}
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Python interface to the R Programming Language"
-HOMEPAGE="https://rpy.sourceforge.net/
- https://pypi.org/project/rpy2/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="AGPL-3 GPL-2 LGPL-2.1 MPL-1.1"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-
-# ggplot2 is a test dep but not in portage
-RESTRICT="test"
-
-RDEPEND="
- >=dev-lang/R-3.2
- dev-python/cffi[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- >=dev-python/pandas-0.13.1[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/tzlocal[${PYTHON_USEDEP}]"
-PDEPEND="dev-python/ipython[${PYTHON_USEDEP}]"
-
-python_compile() {
- distutils-r1_python_compile
-}
-
-python_test() {
- cd "${BUILD_DIR}"/lib || die
- virtx "${EPYTHON}" -m 'rpy2.tests'
-}