summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/jsonschema/jsonschema-4.0.1.ebuild7
-rw-r--r--dev-python/jsonschema/jsonschema-4.1.0.ebuild7
-rw-r--r--dev-python/jsonschema/jsonschema-4.1.1.ebuild7
-rw-r--r--dev-python/jsonschema/jsonschema-4.1.2.ebuild7
4 files changed, 24 insertions, 4 deletions
diff --git a/dev-python/jsonschema/jsonschema-4.0.1.ebuild b/dev-python/jsonschema/jsonschema-4.0.1.ebuild
index fad4177993e3..903e733761da 100644
--- a/dev-python/jsonschema/jsonschema-4.0.1.ebuild
+++ b/dev-python/jsonschema/jsonschema-4.0.1.ebuild
@@ -42,4 +42,9 @@ BDEPEND="
)
"
-distutils_enable_tests unittest
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # requires pip, does not make much sense for the users
+ jsonschema/tests/test_cli.py::TestCLIIntegration::test_license
+)
diff --git a/dev-python/jsonschema/jsonschema-4.1.0.ebuild b/dev-python/jsonschema/jsonschema-4.1.0.ebuild
index 904fc6ee1ce0..3eee583f9602 100644
--- a/dev-python/jsonschema/jsonschema-4.1.0.ebuild
+++ b/dev-python/jsonschema/jsonschema-4.1.0.ebuild
@@ -42,4 +42,9 @@ BDEPEND="
)
"
-distutils_enable_tests unittest
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # requires pip, does not make much sense for the users
+ jsonschema/tests/test_cli.py::TestCLIIntegration::test_license
+)
diff --git a/dev-python/jsonschema/jsonschema-4.1.1.ebuild b/dev-python/jsonschema/jsonschema-4.1.1.ebuild
index 904fc6ee1ce0..3eee583f9602 100644
--- a/dev-python/jsonschema/jsonschema-4.1.1.ebuild
+++ b/dev-python/jsonschema/jsonschema-4.1.1.ebuild
@@ -42,4 +42,9 @@ BDEPEND="
)
"
-distutils_enable_tests unittest
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # requires pip, does not make much sense for the users
+ jsonschema/tests/test_cli.py::TestCLIIntegration::test_license
+)
diff --git a/dev-python/jsonschema/jsonschema-4.1.2.ebuild b/dev-python/jsonschema/jsonschema-4.1.2.ebuild
index 85ab95abeec6..52313e225d8b 100644
--- a/dev-python/jsonschema/jsonschema-4.1.2.ebuild
+++ b/dev-python/jsonschema/jsonschema-4.1.2.ebuild
@@ -42,4 +42,9 @@ BDEPEND="
)
"
-distutils_enable_tests unittest
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # requires pip, does not make much sense for the users
+ jsonschema/tests/test_cli.py::TestCLIIntegration::test_license
+)