summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-p2p/go-ethereum/Manifest1
-rw-r--r--net-p2p/go-ethereum/go-ethereum-1.7.3.ebuild42
2 files changed, 0 insertions, 43 deletions
diff --git a/net-p2p/go-ethereum/Manifest b/net-p2p/go-ethereum/Manifest
index 7f4ccf68e116..1577deb49260 100644
--- a/net-p2p/go-ethereum/Manifest
+++ b/net-p2p/go-ethereum/Manifest
@@ -1,2 +1 @@
-DIST go-ethereum-1.7.3.tar.gz 8188445 BLAKE2B abfa7fff970ea740376e05a56c51a83ba62853b68fd1de1a7161192da294558ea2939427119d00aadcb9e00b8b487e1acfae058e0c5ab6dbe3531e4db0b446cb SHA512 c50391f84b64c924c56d8d052a5c910f94869d86b080cd9b3355a48e094e7f5d4a05a631a57a74619b677067be5da21d6018d18a81bd014bceed43d3626cb017
DIST go-ethereum-1.8.2.tar.gz 9129180 BLAKE2B 8a1e841c8c9f0c0f0adcb08610996c0a06b0133aae89fc0b67543a4aa6d0209b9dbb5b5cff5fc83eb62f7b00ff650cedb7823d640fe4d222698063c8d818f1d5 SHA512 d09bb18098e866ecbabf8e5b796e1a93c125556525b55eaddc2ec870ea84ca861feab3f56b83f31adf9e5d4001df6f2045b82b9224a6017cc6791be04d202271
diff --git a/net-p2p/go-ethereum/go-ethereum-1.7.3.ebuild b/net-p2p/go-ethereum/go-ethereum-1.7.3.ebuild
deleted file mode 100644
index a7fce9166ec3..000000000000
--- a/net-p2p/go-ethereum/go-ethereum-1.7.3.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit golang-base
-
-DESCRIPTION="Official golang implementation of the Ethereum protocol"
-HOMEPAGE="https://github.com/ethereum/go-ethereum"
-SRC_URI="https://github.com/ethereum/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3+ LGPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="devtools opencl"
-
-DEPEND="dev-lang/go:=
- opencl? ( virtual/opencl )
-"
-RDEPEND="${DEPEND}"
-
-src_compile() {
- use opencl && export GO_OPENCL=true
-
- emake $(usex devtools all geth)
-}
-
-src_install() {
- einstalldocs
-
- dobin build/bin/geth
- if use devtools; then
- dobin build/bin/abigen
- dobin build/bin/bootnode
- dobin build/bin/evm
- dobin build/bin/p2psim
- dobin build/bin/puppeth
- dobin build/bin/rlpdump
- dobin build/bin/swarm
- dobin build/bin/wnode
- fi
-}