summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-cpp/glibmm/Manifest1
-rw-r--r--dev-cpp/glibmm/glibmm-2.52.0.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-cpp/glibmm/Manifest b/dev-cpp/glibmm/Manifest
index 5a7c39fc92ab..5dc5a7d70136 100644
--- a/dev-cpp/glibmm/Manifest
+++ b/dev-cpp/glibmm/Manifest
@@ -1 +1,2 @@
DIST glibmm-2.50.1.tar.xz 6444576 SHA256 1fd85051da9cb402cc8348cec72dfe4d79f9345df4a1dbf68703a4ded45846a4 SHA512 4f25c75c1628ca2f4db1c29cebc63187d372603066b06aa6a66c6da792f9e02cb4a413e41f058a81e2d5a2b38d625de13df76115b278f010ce2fc493fe6e6bbb WHIRLPOOL 54b656e04550a050994061db1498a3ac066b1e37643faa218ec1ef04604c0d37c799572b546e79c29f1b35586b1a5b0c354eca72151756eb99f4434a27fa7ae2
+DIST glibmm-2.52.0.tar.xz 6450592 SHA256 81b8abf21c645868c06779abc5f34efc1a51d5e61589dab2a2ed67faa8d4811e SHA512 45cbbe4ce4ba04dcadbcc3b46159dda194235c10a7287075724b0e1c19db2e4db061dc2a66823205f6884b30e2ef87ceafdf9cc2970212a2424535dbe3b9a262 WHIRLPOOL 11cd96f6cb28af494dd8fb63703069df12b8adeb2cba26f7b6d3bc92fd9206385001938db0584c2ee1167b4ca51746ca3a0496bb5fc3abcbdc94f6b3b5944d83
diff --git a/dev-cpp/glibmm/glibmm-2.52.0.ebuild b/dev-cpp/glibmm/glibmm-2.52.0.ebuild
new file mode 100644
index 000000000000..6b4fa6640641
--- /dev/null
+++ b/dev-cpp/glibmm/glibmm-2.52.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2 multilib-minimal
+
+DESCRIPTION="C++ interface for glib2"
+HOMEPAGE="https://www.gtkmm.org"
+
+LICENSE="LGPL-2.1+ GPL-2+" # GPL-2+ applies only to the build system
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="doc debug test"
+
+RDEPEND="
+ >=dev-libs/libsigc++-2.9.1:2[${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.50.0:2[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+# dev-cpp/mm-common needed for eautoreconf
+
+src_prepare() {
+ if ! use test; then
+ # don't waste time building tests
+ sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in || die "sed 1 failed"
+ fi
+
+ # don't build examples - we want to install example sources, not binaries
+ sed 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in || die "sed 2 failed"
+
+ gnome2_src_prepare
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" gnome2_src_configure \
+ $(use_enable debug debug-refcounting) \
+ $(multilib_native_use_enable doc documentation) \
+ --enable-deprecated-api
+}
+
+multilib_src_test() {
+ cd tests
+ default
+
+ for i in */test; do
+ ${i} || die "Running tests failed at ${i}"
+ done
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ find examples -type d -name '.deps' -exec rm -rf {} \; 2>/dev/null
+ find examples -type f -name 'Makefile*' -exec rm -f {} \; 2>/dev/null
+ dodoc -r examples
+}