summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/python-memcached/Manifest2
-rw-r--r--dev-python/python-memcached/python-memcached-1.54.ebuild42
-rw-r--r--dev-python/python-memcached/python-memcached-1.57.ebuild45
3 files changed, 0 insertions, 89 deletions
diff --git a/dev-python/python-memcached/Manifest b/dev-python/python-memcached/Manifest
index 89b0e7f7e984..5b3f085ce90e 100644
--- a/dev-python/python-memcached/Manifest
+++ b/dev-python/python-memcached/Manifest
@@ -1,4 +1,2 @@
DIST python-memcached-1.53.tar.gz 35025 SHA256 af04ea031b271a54f085166773e028fe053fc1d9a58cd8b3c3a57945990bfb48 SHA512 33ffd2778025a8e15beddf1660c4b5c9f1ba144adab5c36fd679e15508015c00e3e1185b5cc179cfcfc556b7c3ab44ed9914089e5ce9db66a04d0a658dd38bb3 WHIRLPOOL 81b80a05010eec576ce8eb00ac4c799213bfc82af4dd3d3da138d02337d28dcb5fbefcbdf11e8d9344b307ba8b1ab2a770b8130fce2f732e484f283e2fe85aae
-DIST python-memcached-1.54.tar.gz 36662 SHA256 df21d1431424c512901ecc3cd244039833aebc4bc7d345af403d4abdace20081 SHA512 e66684fba5ac638efef971df14f4049f1aeae1a84a9c530f26560c1150d7b136746daa164754a0e451ee1caf0b24fd856083aa23f42be1bd4e90a6943d9e45ad WHIRLPOOL a2d1c60fba41002c03718a75659ff1c3944e32b3c900643af2ed227e6280af2635f068f27923ed1722ae1407cd3a1e9696e6c628e4898aaf73451105846c31cb
-DIST python-memcached-1.57.tar.gz 22620 SHA256 3b689a135afb2fdb6da2298d5213780f43a3f210cf8c960d50b252acb3f62902 SHA512 1862d9a5c7c29c8956384e1b951b59dba1fb2bbaeb1c3a99b1b917a93e04e0d86f4b38022a4b0146889448a2d2152e7282cdf33d0240126350dc88d34f216ad4 WHIRLPOOL cda22d597848bf2ca138f0cc9cfedb9d1b58cf217568d6bf8ffe6b7ca2b9771f079db76e1b0fc577b079e717fd851007ec65859454ae6fc5eb369394bc205a6b
DIST python-memcached-1.58.tar.gz 30562 SHA256 2775829cb54b9e4c5b3bbd8028680f0c0ab695db154b9c46f0f074ff97540eb6 SHA512 48f933f095751b476c122473fa1d9767cfe5c6c339a9ba71825a50cec23cbfc7b6493716458bfb1f2451c634c517519152105a2000be66bd0d389f94ea312138 WHIRLPOOL 391d91a7d40f1d85febf7f90f0593d315854caa6dac0c4f70c2c3ee7af79b049099406683436df6af0e879626d6b42f95eed6a0153ae3874a9b746998cd02b88
diff --git a/dev-python/python-memcached/python-memcached-1.54.ebuild b/dev-python/python-memcached/python-memcached-1.54.ebuild
deleted file mode 100644
index 2bde1b94d99a..000000000000
--- a/dev-python/python-memcached/python-memcached-1.54.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="Pure python memcached client"
-HOMEPAGE="http://www.tummy.com/Community/software/python-memcached/ https://pypi.python.org/pypi/python-memcached"
-SRC_URI="ftp://ftp.tummy.com/pub/python-memcached/old-releases/${P}.tar.gz"
-
-LICENSE="OSL-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="test"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( net-misc/memcached )"
-RDEPEND=""
-
-# Tests try to connect to memcached via TCP/IP. Please do not re-enable
-# until you get them all to pass properly while using the UNIX socket
-# only and not even trying to connect to memcached over TCP/IP.
-RESTRICT=test
-
-python_test() {
- # Note: partial. Needs fixing. Stuff like that.
-
- cd "${TMPDIR}" || die
-
- local memcached_opts=( -d -P memcached.pid -s memcached.socket )
- [[ ${EUID} == 0 ]] && memcached_opts+=( -u portage )
-
- memcached "${memached_opts[@]}" || die
-
- "${PYTHON}" memcache.py --do-unix || die "Tests fail with ${EPYTHON}"
-
- kill "$(<memcached.pid)" || die
- rm memcached.pid || die
-}
diff --git a/dev-python/python-memcached/python-memcached-1.57.ebuild b/dev-python/python-memcached/python-memcached-1.57.ebuild
deleted file mode 100644
index db59b6d39887..000000000000
--- a/dev-python/python-memcached/python-memcached-1.57.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_4 python3_5 pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="Pure python memcached client"
-HOMEPAGE="http://www.tummy.com/Community/software/python-memcached/ https://pypi.python.org/pypi/python-memcached"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="OSL-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~ppc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="test"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- net-misc/memcached
- dev-python/nose[${PYTHON_USEDEP}]
- )"
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
-
-# Tests try to connect to memcached via TCP/IP. Please do not re-enable
-# until you get them all to pass properly while using the UNIX socket
-# only and not even trying to connect to memcached over TCP/IP.
-RESTRICT=test
-
-python_test() {
- # Note: partial. Needs fixing. Stuff like that.
-
- cd "${TMPDIR}" || die
-
- local memcached_opts=( -d -P memcached.pid -s memcached.socket )
- [[ ${EUID} == 0 ]] && memcached_opts+=( -u portage )
-
- memcached "${memached_opts[@]}" || die
-
- "${PYTHON}" memcache.py --do-unix || die "Tests fail with ${EPYTHON}"
-
- kill "$(<memcached.pid)" || die
- rm memcached.pid || die
-}