summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-ftp/filezilla/Manifest1
-rw-r--r--net-ftp/filezilla/filezilla-3.40.0.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/net-ftp/filezilla/Manifest b/net-ftp/filezilla/Manifest
index d031f9c5e355..0c51e7785627 100644
--- a/net-ftp/filezilla/Manifest
+++ b/net-ftp/filezilla/Manifest
@@ -2,3 +2,4 @@ DIST FileZilla_3.34.0_src.tar.bz2 4869893 BLAKE2B 43f017a833191126526195636607b7
DIST FileZilla_3.37.4_src.tar.bz2 4983335 BLAKE2B 16929caca3aabfdea406469a4128878f3cc48b347084d5d362ad206a7549be129195e8f111324b259e64d8e9324d9decd4bb51d088367fcaa560ec1feeb03570 SHA512 3f6697fd411b898f0db375bba7e6a34157c73274ee463832c38a4897240d990654c447baad8b0024492cb882106e7e63757d54401c487cfad96038d1f5eabfea
DIST FileZilla_3.38.1_src.tar.bz2 4983087 BLAKE2B a19b80b35535485fd1c03aa36a85aa1f894b106d09d1b78ab7e02fec6cec3e78e0612c343694e5fabaa2202802d2ba2cd2aa4e4d0840342f17c60c06c0c8bcf8 SHA512 a224c6f65253ceeef1f3049fd6304533a7efb427707c73481d3973d06e3b887f2511bc705e718a1018b287940c3d682794c6cf3d0e8d9e3c403a1e2f14ed01fc
DIST FileZilla_3.39.0_src.tar.bz2 4995713 BLAKE2B d89aaa1f57187cd926ae1c4dd34624b404baa291334c652293d2dcfaedc4a5dffb401f8727b5d5d1fb483bdd503f35124efb75bdd7dd750d68e517fcb57fb8c0 SHA512 a0360634517ffd07878082abae024dbb4896035edcbd9abe6d8adfc9d37b73d01d95f6c5ca031175d88b6e4badefafcc43b5ddce3d9dbddde4deab5f0cc97e83
+DIST FileZilla_3.40.0_src.tar.bz2 4997647 BLAKE2B 88ff2461d33369c435645f1dd5afa98c566141bf825e74898f870bd4c09cc7b47a70f605afbaf7be28855385812a28ea24303b6ec7f0ba605a793160c3b76027 SHA512 7aeb0c340111a47c435e8d8cbf379e83d2fc6c0a94038e085664df34c2fe1f8ef8496ea894f5e4cfd576d034e8935fe29661bb9eff9f22416032f45f5a66db2f
diff --git a/net-ftp/filezilla/filezilla-3.40.0.ebuild b/net-ftp/filezilla/filezilla-3.40.0.ebuild
new file mode 100644
index 000000000000..aa2e664800ab
--- /dev/null
+++ b/net-ftp/filezilla/filezilla-3.40.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+WX_GTK_VER="3.0-gtk3"
+
+inherit autotools flag-o-matic gnome2-utils wxwidgets
+
+MY_PV=${PV/_/-}
+MY_P="FileZilla_${MY_PV}"
+
+DESCRIPTION="FTP client with lots of useful features and an intuitive interface"
+HOMEPAGE="https://filezilla-project.org/"
+SRC_URI="https://download.filezilla-project.org/client/${MY_P}_src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~x86"
+IUSE="dbus nls test"
+
+# pugixml 1.7 minimal dependency is for c++11 proper configuration
+RDEPEND=">=app-eselect/eselect-wxwidgets-0.7-r1
+ >=dev-libs/nettle-3.1:=
+ >=dev-db/sqlite-3.7
+ >=dev-libs/libfilezilla-0.15.1
+ >=dev-libs/pugixml-1.7
+ >=net-libs/gnutls-3.4.15
+ >=x11-libs/wxGTK-3.0.4:${WX_GTK_VER}[X]
+ x11-misc/xdg-utils
+ dbus? ( sys-apps/dbus )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=sys-devel/libtool-1.4
+ nls? ( >=sys-devel/gettext-0.11 )
+ test? ( >=dev-util/cppunit-1.13.0 )"
+
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+DOCS=(AUTHORS ChangeLog NEWS )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.22.1-debug.patch
+)
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ if ! test-flag-CXX -std=c++14; then
+ eerror "${P} requires C++14-capable C++ compiler. Your current compiler"
+ eerror "does not seem to support -std=c++14 option. Please upgrade your compiler"
+ eerror "to gcc-4.9 or an equivalent version supporting C++14."
+ die "Currently active compiler does not support -std=c++14"
+ fi
+ fi
+}
+
+src_prepare() {
+ setup-wxwidgets
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with dbus) $(use_enable nls locales) \
+ --with-pugixml=system \
+ --disable-autoupdatecheck
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}