summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/autobahn/autobahn-0.16.0.ebuild7
-rw-r--r--dev-python/autobahn/autobahn-17.5.1.ebuild5
2 files changed, 11 insertions, 1 deletions
diff --git a/dev-python/autobahn/autobahn-0.16.0.ebuild b/dev-python/autobahn/autobahn-0.16.0.ebuild
index 6daae09d86a0..9cc6b9581cad 100644
--- a/dev-python/autobahn/autobahn-0.16.0.ebuild
+++ b/dev-python/autobahn/autobahn-0.16.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -55,3 +55,8 @@ S="${WORKDIR}"/${MY_P}
python_test() {
esetup.py test
}
+
+python_compile() {
+ addpredict "$(python_get_sitedir)"
+ distutils-r1_python_compile
+}
diff --git a/dev-python/autobahn/autobahn-17.5.1.ebuild b/dev-python/autobahn/autobahn-17.5.1.ebuild
index 9c6160c20975..bd3ca434ee92 100644
--- a/dev-python/autobahn/autobahn-17.5.1.ebuild
+++ b/dev-python/autobahn/autobahn-17.5.1.ebuild
@@ -55,3 +55,8 @@ python_test() {
cd "${BUILD_DIR}"/lib || die
py.test -v || die
}
+
+python_compile() {
+ addpredict "$(python_get_sitedir)"
+ distutils-r1_python_compile
+}