summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/src-cli/Manifest1
-rw-r--r--dev-util/src-cli/src-cli-3.27.0.ebuild140
2 files changed, 141 insertions, 0 deletions
diff --git a/dev-util/src-cli/Manifest b/dev-util/src-cli/Manifest
index 873dbe6c70cc..9c412a10317d 100644
--- a/dev-util/src-cli/Manifest
+++ b/dev-util/src-cli/Manifest
@@ -113,3 +113,4 @@ DIST jaytaylor.com%2Fhtml2text%2F@v%2Fv0.0.0-20200412013138-3577fbdbcff7.mod 31
DIST jaytaylor.com%2Fhtml2text%2F@v%2Fv0.0.0-20200412013138-3577fbdbcff7.zip 17752 BLAKE2B a752c67083d89d471656ec2f0fcd07b7c3c240acd781b01d050637f6dacbcce36b6ea2b194798fd0d7c0b5b983cc800fdaf3f0ba0d86daa931696df1a9df53bc SHA512 bf78ce9abfea5e74bcee2d6a2c54c894433f7e88ddde0ebb67647bcaad158d6981ff979cfe4eac530f81294cd07a72de93efc8776a5008b9e6aaf71f445fe744
DIST src-cli-3.26.2.tar.gz 193123 BLAKE2B d7973697e4a83248228f9db0cc04a168afbc18d0ad7a818df5c107dee219d3a5fdffbdda1c6cdffaa5ce3d54e193436bfd47f23a2453532224217a4c9b0ac6ba SHA512 784f9972b7661bec78ef06bbf529f79fdd340adacb7a957aaf756500e52525ca980b661aced6f755cdf1521135afcd94cb0e0e65187ae25d7c10278b43d5828e
DIST src-cli-3.26.3.tar.gz 193771 BLAKE2B 713ee83c856de22385b473cb063370639996cca25b296846debca24dbadaf072992170339f0a25f07d4f225c4cc457e3210fcc96f3b59f2686c4263aaec67097 SHA512 cdb7362dc6508ac50b00e0db26a5679787cfc8512c5d3f2251635c02b808aa40039b4544c4b8c7fd9d829957e09541ebbdae66ebca352dcdf6960359fcdf4e86
+DIST src-cli-3.27.0.tar.gz 194630 BLAKE2B 9d5d971d17a33bd8d41f7a121399f598f6718acda4d52626b856dbb53cb489846dcf8ae5f33d86db6e26c1d3d858dbc0a006efc79baba8fadc149275c087660c SHA512 09e236c5311c29b2ab29e1f0388cd62c9ee92419922ac80d4a417fa268c64fee7733abfee6f54d83e95bd3b3dc7b27d77c98dbfb19987f79dc4dd259d28086e3
diff --git a/dev-util/src-cli/src-cli-3.27.0.ebuild b/dev-util/src-cli/src-cli-3.27.0.ebuild
new file mode 100644
index 000000000000..7b73f558c14d
--- /dev/null
+++ b/dev-util/src-cli/src-cli-3.27.0.ebuild
@@ -0,0 +1,140 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit go-module
+
+DESCRIPTION="command line interface for the Sourcegraph code search tool"
+HOMEPAGE="https://www.sourcegraph.com https://docs.sourcegraph.com/cli"
+
+EGO_SUM=(
+ "github.com/Masterminds/semver v1.5.0"
+ "github.com/Masterminds/semver v1.5.0/go.mod"
+ "github.com/davecgh/go-spew v1.1.0/go.mod"
+ "github.com/davecgh/go-spew v1.1.1"
+ "github.com/davecgh/go-spew v1.1.1/go.mod"
+ "github.com/dustin/go-humanize v1.0.0"
+ "github.com/dustin/go-humanize v1.0.0/go.mod"
+ "github.com/efritz/pentimento v0.0.0-20190429011147-ade47d831101"
+ "github.com/efritz/pentimento v0.0.0-20190429011147-ade47d831101/go.mod"
+ "github.com/gobwas/glob v0.2.3"
+ "github.com/gobwas/glob v0.2.3/go.mod"
+ "github.com/google/go-cmp v0.5.2/go.mod"
+ "github.com/google/go-cmp v0.5.5"
+ "github.com/google/go-cmp v0.5.5/go.mod"
+ "github.com/google/gofuzz v1.0.0/go.mod"
+ "github.com/hashicorp/errwrap v1.0.0/go.mod"
+ "github.com/hashicorp/errwrap v1.1.0"
+ "github.com/hashicorp/errwrap v1.1.0/go.mod"
+ "github.com/hashicorp/go-multierror v1.1.0"
+ "github.com/hashicorp/go-multierror v1.1.0/go.mod"
+ "github.com/jig/teereadcloser v0.0.0-20181016160506-953720c48e05"
+ "github.com/jig/teereadcloser v0.0.0-20181016160506-953720c48e05/go.mod"
+ "github.com/json-iterator/go v1.1.10"
+ "github.com/json-iterator/go v1.1.10/go.mod"
+ "github.com/kballard/go-shellquote v0.0.0-20180428030007-95032a82bc51"
+ "github.com/kballard/go-shellquote v0.0.0-20180428030007-95032a82bc51/go.mod"
+ "github.com/mattn/go-isatty v0.0.12"
+ "github.com/mattn/go-isatty v0.0.12/go.mod"
+ "github.com/mattn/go-runewidth v0.0.7/go.mod"
+ "github.com/mattn/go-runewidth v0.0.9"
+ "github.com/mattn/go-runewidth v0.0.9/go.mod"
+ "github.com/modern-go/concurrent v0.0.0-20180228061459-e0a39a4cb421"
+ "github.com/modern-go/concurrent v0.0.0-20180228061459-e0a39a4cb421/go.mod"
+ "github.com/modern-go/reflect2 v0.0.0-20180701023420-4b7aa43c6742"
+ "github.com/modern-go/reflect2 v0.0.0-20180701023420-4b7aa43c6742/go.mod"
+ "github.com/neelance/parallel v0.0.0-20160708114440-4de9ce63d14c"
+ "github.com/neelance/parallel v0.0.0-20160708114440-4de9ce63d14c/go.mod"
+ "github.com/nsf/termbox-go v0.0.0-20200418040025-38ba6e5628f1"
+ "github.com/nsf/termbox-go v0.0.0-20200418040025-38ba6e5628f1/go.mod"
+ "github.com/olekukonko/tablewriter v0.0.4"
+ "github.com/olekukonko/tablewriter v0.0.4/go.mod"
+ "github.com/pkg/browser v0.0.0-20180916011732-0a3d74bf9ce4"
+ "github.com/pkg/browser v0.0.0-20180916011732-0a3d74bf9ce4/go.mod"
+ "github.com/pkg/errors v0.9.1"
+ "github.com/pkg/errors v0.9.1/go.mod"
+ "github.com/pmezard/go-difflib v1.0.0"
+ "github.com/pmezard/go-difflib v1.0.0/go.mod"
+ "github.com/shurcooL/go v0.0.0-20180423040247-9e1955d9fb6e/go.mod"
+ "github.com/shurcooL/go-goon v0.0.0-20170922171312-37c2f522c041/go.mod"
+ "github.com/sourcegraph/batch-change-utils v0.0.0-20210309183117-206c057cc03e"
+ "github.com/sourcegraph/batch-change-utils v0.0.0-20210309183117-206c057cc03e/go.mod"
+ "github.com/sourcegraph/go-diff v0.6.1"
+ "github.com/sourcegraph/go-diff v0.6.1/go.mod"
+ "github.com/sourcegraph/jsonx v0.0.0-20200629203448-1a936bd500cf"
+ "github.com/sourcegraph/jsonx v0.0.0-20200629203448-1a936bd500cf/go.mod"
+ "github.com/sourcegraph/sourcegraph/lib v0.0.0-20210312004335-4dae89dd19bc"
+ "github.com/sourcegraph/sourcegraph/lib v0.0.0-20210312004335-4dae89dd19bc/go.mod"
+ "github.com/sourcegraph/yaml v1.0.1-0.20200714132230-56936252f152"
+ "github.com/sourcegraph/yaml v1.0.1-0.20200714132230-56936252f152/go.mod"
+ "github.com/ssor/bom v0.0.0-20170718123548-6386211fdfcf"
+ "github.com/ssor/bom v0.0.0-20170718123548-6386211fdfcf/go.mod"
+ "github.com/stretchr/objx v0.1.0/go.mod"
+ "github.com/stretchr/testify v1.3.0"
+ "github.com/stretchr/testify v1.3.0/go.mod"
+ "github.com/xeipuuv/gojsonpointer v0.0.0-20180127040702-4e3ac2762d5f/go.mod"
+ "github.com/xeipuuv/gojsonpointer v0.0.0-20190905194746-02993c407bfb"
+ "github.com/xeipuuv/gojsonpointer v0.0.0-20190905194746-02993c407bfb/go.mod"
+ "github.com/xeipuuv/gojsonreference v0.0.0-20180127040603-bd5ef7bd5415"
+ "github.com/xeipuuv/gojsonreference v0.0.0-20180127040603-bd5ef7bd5415/go.mod"
+ "github.com/xeipuuv/gojsonschema v1.2.0"
+ "github.com/xeipuuv/gojsonschema v1.2.0/go.mod"
+ "github.com/yuin/goldmark v1.1.27/go.mod"
+ "golang.org/x/crypto v0.0.0-20190308221718-c2843e01d9a2/go.mod"
+ "golang.org/x/crypto v0.0.0-20190426145343-a29dc8fdc734/go.mod"
+ "golang.org/x/crypto v0.0.0-20191011191535-87dc89f01550/go.mod"
+ "golang.org/x/crypto v0.0.0-20200622213623-75b288015ac9/go.mod"
+ "golang.org/x/mod v0.2.0/go.mod"
+ "golang.org/x/net v0.0.0-20190311183353-d8887717615a/go.mod"
+ "golang.org/x/net v0.0.0-20190404232315-eb5bcb51f2a3/go.mod"
+ "golang.org/x/net v0.0.0-20190424112056-4829fb13d2c6/go.mod"
+ "golang.org/x/net v0.0.0-20190620200207-3b0461eec859/go.mod"
+ "golang.org/x/net v0.0.0-20200226121028-0de0cce0169b/go.mod"
+ "golang.org/x/net v0.0.0-20200625001655-4c5254603344"
+ "golang.org/x/net v0.0.0-20200625001655-4c5254603344/go.mod"
+ "golang.org/x/sync v0.0.0-20190423024810-112230192c58/go.mod"
+ "golang.org/x/sync v0.0.0-20190911185100-cd5d95a43a6e"
+ "golang.org/x/sync v0.0.0-20190911185100-cd5d95a43a6e/go.mod"
+ "golang.org/x/sys v0.0.0-20190215142949-d0b11bdaac8a/go.mod"
+ "golang.org/x/sys v0.0.0-20190412213103-97732733099d/go.mod"
+ "golang.org/x/sys v0.0.0-20190428183149-804c0c7841b5/go.mod"
+ "golang.org/x/sys v0.0.0-20200116001909-b77594299b42/go.mod"
+ "golang.org/x/sys v0.0.0-20200323222414-85ca7c5b95cd/go.mod"
+ "golang.org/x/sys v0.0.0-20200622214017-ed371f2e16b4"
+ "golang.org/x/sys v0.0.0-20200622214017-ed371f2e16b4/go.mod"
+ "golang.org/x/text v0.3.0/go.mod"
+ "golang.org/x/text v0.3.2/go.mod"
+ "golang.org/x/tools v0.0.0-20180917221912-90fa682c2a6e/go.mod"
+ "golang.org/x/tools v0.0.0-20190428024724-550556f78a90/go.mod"
+ "golang.org/x/tools v0.0.0-20191119224855-298f0cb1881e/go.mod"
+ "golang.org/x/tools v0.0.0-20200624163319-25775e59acb7/go.mod"
+ "golang.org/x/xerrors v0.0.0-20190717185122-a985d3407aa7/go.mod"
+ "golang.org/x/xerrors v0.0.0-20191011141410-1b5146add898/go.mod"
+ "golang.org/x/xerrors v0.0.0-20191204190536-9bdfabe68543"
+ "golang.org/x/xerrors v0.0.0-20191204190536-9bdfabe68543/go.mod"
+ "gopkg.in/check.v1 v0.0.0-20161208181325-20d25e280405"
+ "gopkg.in/check.v1 v0.0.0-20161208181325-20d25e280405/go.mod"
+ "gopkg.in/yaml.v2 v2.2.2/go.mod"
+ "gopkg.in/yaml.v2 v2.3.0"
+ "gopkg.in/yaml.v2 v2.3.0/go.mod"
+ "gopkg.in/yaml.v3 v3.0.0-20200615113413-eeeca48fe776"
+ "gopkg.in/yaml.v3 v3.0.0-20200615113413-eeeca48fe776/go.mod"
+ "jaytaylor.com/html2text v0.0.0-20200412013138-3577fbdbcff7"
+ "jaytaylor.com/html2text v0.0.0-20200412013138-3577fbdbcff7/go.mod"
+ )
+go-module_set_globals
+SRC_URI="https://github.com/sourcegraph/src-cli/archive/${PV}.tar.gz -> ${P}.tar.gz
+ ${EGO_SUM_SRC_URI}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ go build ./cmd/src || die
+}
+
+src_install() {
+ dobin src
+ dodoc AUTH_PROXY.md CHANGELOG.md
+}