summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-p2p/gtk-gnutella/Manifest1
-rw-r--r--net-p2p/gtk-gnutella/gtk-gnutella-1.1.1.ebuild86
2 files changed, 0 insertions, 87 deletions
diff --git a/net-p2p/gtk-gnutella/Manifest b/net-p2p/gtk-gnutella/Manifest
index 65dac58d163b..610d26d4ec07 100644
--- a/net-p2p/gtk-gnutella/Manifest
+++ b/net-p2p/gtk-gnutella/Manifest
@@ -1,3 +1,2 @@
-DIST gtk-gnutella-1.1.1.tar.bz2 35342037 SHA256 6e077204ddc23d0b8a044c3d7f12f40e8876b523f12a90c00b6725170611b501 SHA512 c8226f74bbbc901a608aa59544ba5d7f924f5bcef0e98ba16145c4ae07a93dc710376201cf46bedaddcefb4438e18c259ce06be076a5f365a80b445cf788ec02 WHIRLPOOL 19e41cea5dfbfc27d21c7a5ed7ea69a14ef4fb4c0285eedd218d2506a6a133bb9f81462e4396bc936528618216d419f1ac38e53ff887c9e640cd51264727d824
DIST gtk-gnutella-1.1.3.tar.bz2 19504243 SHA256 2659ddb846f60d13789674e926a71bbb4a8b9d3ca98c6b034a95eaa073531405 SHA512 df143b6e89b0a4c6e8ddbba24ddcab3603f04e7df1fab7d389241a112c6cd3297e4837dfc0d225289997b99867a5466a5b8697c68ef2bdc5817261fbc103d505 WHIRLPOOL fe1a1375e75204bdf92c9690f1885211dc456c2cc466f4d7e47c865fc0e1c77ce07d27b58ff2e53c4c28214d055878c7d805f0b79043748e1448c6b8ac398c82
DIST gtk-gnutella-1.1.4.tar.bz2 19546318 SHA256 6ae259ff9d5f20a2d10dba66ed6cbe5b56552307a6e8bc36df053b70aff4c956 SHA512 e09fde0e1f8a701e099f91768e032d022f6e9d41cdb4cc7833f1e7ba0e2795bc102c6b835960eb69e577ffc1426c42f6e1682ebadb8c5a643a796f88ff204ac6 WHIRLPOOL a9e63865896444c2ba22e9cf4302f5da5f6bdcec257cc87c618c3c3514cbf924e0eb6df7909b21ad5798650a577adf38cb37806810fd3f6a7f67be5f7a7cc8f1
diff --git a/net-p2p/gtk-gnutella/gtk-gnutella-1.1.1.ebuild b/net-p2p/gtk-gnutella/gtk-gnutella-1.1.1.ebuild
deleted file mode 100644
index 62a6075dc610..000000000000
--- a/net-p2p/gtk-gnutella/gtk-gnutella-1.1.1.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit eutils
-
-IUSE="nls dbus ssl +gtk"
-
-DESCRIPTION="A GTK+ Gnutella client"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-HOMEPAGE="http://gtk-gnutella.sourceforge.net/"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="amd64 ppc x86 ~x86-fbsd"
-
-RDEPEND="
- dev-libs/glib:2
- sys-libs/zlib
- gtk? ( >=x11-libs/gtk+-2.2.1:2 )
- dbus? ( >=sys-apps/dbus-0.35.2 )
- ssl? ( >=net-libs/gnutls-2.2.5 )
- nls? ( >=sys-devel/gettext-0.11.5 )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_prepare() {
- strip-linguas -i po
-
- echo "# Gentoo-selected LINGUAS" > po/LINGUAS
- for ling in ${LINGUAS}; do
- echo $ling >> po/LINGUAS
- done
-}
-
-src_configure() {
- # There is no option to turn off optimization through the build.sh
- # script.
- sed -i -e "s/Configure -Oder/Configure -Oder -Doptimize=none/" build.sh || die
-
- # The build script does not support the equivalent --enable
- # options so we must construct the configuration by hand.
-
- local myconf
-
- if ! use nls; then
- myconf="${myconf} --disable-nls"
- fi
-
- if ! use dbus; then
- myconf="${myconf} --disable-dbus"
- fi
-
- if ! use ssl; then
- myconf="${myconf} --disable-gnutls"
- fi
-
- if use gtk; then
- myconf="${myconf} --gtk2"
- else
- myconf="${myconf} --topless"
- fi
-
- ./build.sh \
- --configure-only \
- --prefix="/usr" \
- --cc=$(tc-getCC) \
- ${myconf}
-}
-
-src_compile() {
- # Build system is not parallel-safe, bug 500760
- emake -j1
-}
-
-src_install() {
- dodir /usr/bin
- emake INSTALL_PREFIX="${D}" install || die "Install failed"
- dodoc AUTHORS ChangeLog README TODO
-
- # Touch the symbols file into the future to avoid warnings from
- # gtk-gnutella later on, since we will most likely strip the binary.
- touch --date="next minute" "${D}/usr/lib/gtk-gnutella/gtk-gnutella.nm" || die
-}