summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-im/coturn/coturn-4.5.2-r1.ebuild17
-rw-r--r--net-im/coturn/coturn-9999.ebuild31
-rw-r--r--net-im/coturn/files/coturn-4.5.2-respect-TMPDIR.patch24
3 files changed, 59 insertions, 13 deletions
diff --git a/net-im/coturn/coturn-4.5.2-r1.ebuild b/net-im/coturn/coturn-4.5.2-r1.ebuild
index 37dde1c42c28..d3a3c8813604 100644
--- a/net-im/coturn/coturn-4.5.2-r1.ebuild
+++ b/net-im/coturn/coturn-4.5.2-r1.ebuild
@@ -2,14 +2,14 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit systemd tmpfiles
+
+inherit toolchain-funcs systemd tmpfiles
DESCRIPTION="coturn TURN server project"
HOMEPAGE="https://github.com/coturn/coturn"
if [ ${PV} = 9999 ]; then
EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
inherit git-r3
- DEPEND="dev-vcs/git"
# S="${WORKDIR}/${PN}-master"
else
KEYWORDS="~amd64 ~x86"
@@ -22,13 +22,18 @@ IUSE="mongodb mysql postgres redis sqlite"
RDEPEND="acct-group/turnserver
acct-user/turnserver
>dev-libs/libevent-2.1.8:=
+ dev-libs/openssl:=
mongodb? ( dev-libs/mongo-c-driver )
mysql? ( dev-db/mysql-connector-c:= )
postgres? ( dev-db/postgresql:* )
redis? ( dev-libs/hiredis:= )
sqlite? ( dev-db/sqlite )"
-
DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.5.2-respect-TMPDIR.patch
+)
src_configure() {
if [ -n "${AR}" ]; then
@@ -56,7 +61,13 @@ src_configure() {
if ! use sqlite; then
export TURN_NO_SQLITE=yes
fi
+
+ tc-export CC
+
+ export ARCHIVERCMD="$(tc-getAR) -r"
+ export PKGCONFIG="$(tc-getPKG_CONFIG)"
export DOCSDIR="/usr/share/doc/${PN}-${PV}"
+
econf $(use_with sqlite)
}
diff --git a/net-im/coturn/coturn-9999.ebuild b/net-im/coturn/coturn-9999.ebuild
index 4f65686782b4..d3a3c8813604 100644
--- a/net-im/coturn/coturn-9999.ebuild
+++ b/net-im/coturn/coturn-9999.ebuild
@@ -2,14 +2,14 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit systemd tmpfiles
+
+inherit toolchain-funcs systemd tmpfiles
DESCRIPTION="coturn TURN server project"
HOMEPAGE="https://github.com/coturn/coturn"
if [ ${PV} = 9999 ]; then
EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
inherit git-r3
- DEPEND="dev-vcs/git"
# S="${WORKDIR}/${PN}-master"
else
KEYWORDS="~amd64 ~x86"
@@ -20,15 +20,20 @@ LICENSE="BSD"
SLOT="0"
IUSE="mongodb mysql postgres redis sqlite"
RDEPEND="acct-group/turnserver
- acct-user/turnserver
- >dev-libs/libevent-2.1.8:=
- mongodb? ( dev-libs/mongo-c-driver )
- mysql? ( dev-db/mysql-connector-c:= )
- postgres? ( dev-db/postgresql:* )
- redis? ( dev-libs/hiredis:= )
- sqlite? ( dev-db/sqlite )"
-
+ acct-user/turnserver
+ >dev-libs/libevent-2.1.8:=
+ dev-libs/openssl:=
+ mongodb? ( dev-libs/mongo-c-driver )
+ mysql? ( dev-db/mysql-connector-c:= )
+ postgres? ( dev-db/postgresql:* )
+ redis? ( dev-libs/hiredis:= )
+ sqlite? ( dev-db/sqlite )"
DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.5.2-respect-TMPDIR.patch
+)
src_configure() {
if [ -n "${AR}" ]; then
@@ -56,7 +61,13 @@ src_configure() {
if ! use sqlite; then
export TURN_NO_SQLITE=yes
fi
+
+ tc-export CC
+
+ export ARCHIVERCMD="$(tc-getAR) -r"
+ export PKGCONFIG="$(tc-getPKG_CONFIG)"
export DOCSDIR="/usr/share/doc/${PN}-${PV}"
+
econf $(use_with sqlite)
}
diff --git a/net-im/coturn/files/coturn-4.5.2-respect-TMPDIR.patch b/net-im/coturn/files/coturn-4.5.2-respect-TMPDIR.patch
new file mode 100644
index 000000000000..036705afc1f2
--- /dev/null
+++ b/net-im/coturn/files/coturn-4.5.2-respect-TMPDIR.patch
@@ -0,0 +1,24 @@
+diff --git a/configure b/configure
+index caf11f5..003da8d 100755
+--- a/configure
++++ b/configure
+@@ -513,12 +513,13 @@ fi
+ # Temporary DIR location:
+ #########################
+
+-TMPDIR="."
+-
+-if [ -d /var/tmp ] ; then
+- TMPDIR="/var/tmp"
+-elif [ -d /tmp ] ; then
+- TMPDIR=/tmp
++TMPDIR=${TMPDIR:-.}
++if test x"${TMPDIR}" = "." ; then
++ if [ -d /var/tmp ] ; then
++ TMPDIR="/var/tmp"
++ elif [ -d /tmp ] ; then
++ TMPDIR=/tmp
++ fi
+ fi
+
+ ${ECHO_CMD} Use TMP dir ${TMPDIR}