summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-apps/wordpress/Manifest1
-rw-r--r--www-apps/wordpress/wordpress-5.4.2.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/www-apps/wordpress/Manifest b/www-apps/wordpress/Manifest
index 38955bf108ce..9c836d75778b 100644
--- a/www-apps/wordpress/Manifest
+++ b/www-apps/wordpress/Manifest
@@ -1 +1,2 @@
DIST wordpress-5.4.1.tar.gz 12234700 BLAKE2B 0df1f1b1da22c5ad429ef59861dbcb80b5bd6c8720bc96b450d2b6599b903dda813e16f28fc2ee2afe1654b4047556a06bb409f6d0a3be3671b37e54fac52cf3 SHA512 5ed4f3bd593febdf2aec4c582c2ed850d3bf52122273b4306c1fba87939a675228df84092a709052f13e0096b2545cd6f078ab89b232ee4b4dce467d834de0cd
+DIST wordpress-5.4.2.tar.gz 12238031 BLAKE2B 47e80985392540d5cf46c40b3a4e7ef75ca8ee95996b13442e288ee68510d001ec92cb11c7621dfb1148a7a1409fed2418b2c6758555d63e457b19ae6cf43368 SHA512 d1f4366f6e8ec591ce91ed76ea6949feeaf112881c3d742860c79955283b31c1712a04394eda8308d6d5756ff6d20ef4cf2e18559a59469ef195cf2cb437c219
diff --git a/www-apps/wordpress/wordpress-5.4.2.ebuild b/www-apps/wordpress/wordpress-5.4.2.ebuild
new file mode 100644
index 000000000000..6fc0786bf3b1
--- /dev/null
+++ b/www-apps/wordpress/wordpress-5.4.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit webapp
+
+DESCRIPTION="Wordpress PHP and MySQL based content management system (CMS)"
+HOMEPAGE="https://wordpress.org/"
+SRC_URI="https://wordpress.org/${P/_rc/-RC}.tar.gz"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="virtual/httpd-php
+ || ( dev-lang/php[mysql] dev-lang/php[mysqli] )"
+
+S=${WORKDIR}/${PN}
+
+need_httpd_cgi
+
+IUSE="+akismet examples +themes vhosts"
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc readme.html
+ rm readme.html license.txt || die
+
+ if use !akismet ; then
+ rm -R wp-content/plugins/akismet/ || die
+ fi
+ if use !examples ; then
+ rm wp-content/plugins/hello.php || die
+ fi
+ if use !themes ; then
+ rm -R wp-content/themes/*/ || die
+ fi
+
+ [[ -f wp-config.php ]] || cp wp-config-sample.php wp-config.php
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/index.php
+ webapp_serverowned "${MY_HTDOCSDIR}"/wp-admin/menu.php
+ webapp_serverowned "${MY_HTDOCSDIR}"
+ # allows plugins update if allowed within WP
+ webapp_serverowned "${MY_HTDOCSDIR}"/wp-admin/includes/file.php
+
+ webapp_configfile "${MY_HTDOCSDIR}"/wp-config.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_postupgrade_txt en "${FILESDIR}"/postupgrade-en.txt
+
+ webapp_src_install
+}