summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-misc/projecteur/files/projecteur-0.9.2-gcc12.patch21
-rw-r--r--x11-misc/projecteur/projecteur-0.9.2.ebuild7
2 files changed, 26 insertions, 2 deletions
diff --git a/x11-misc/projecteur/files/projecteur-0.9.2-gcc12.patch b/x11-misc/projecteur/files/projecteur-0.9.2-gcc12.patch
new file mode 100644
index 000000000000..7c7ff0f4105b
--- /dev/null
+++ b/x11-misc/projecteur/files/projecteur-0.9.2-gcc12.patch
@@ -0,0 +1,21 @@
+From 2e989dabcf853da5ab82ab67e3eca8619cb6669a Mon Sep 17 00:00:00 2001
+From: Jahn F <jahnf@users.noreply.github.com>
+Date: Tue, 3 May 2022 09:02:05 +0200
+Subject: [PATCH] Add missing <array> include
+
+---
+ src/device.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/device.h b/src/device.h
+index 1c51585..1ce24fe 100644
+--- a/src/device.h
++++ b/src/device.h
+@@ -7,6 +7,7 @@
+
+ #include "devicescan.h"
+
++#include <array>
+ #include <memory>
+ #include <vector>
+
diff --git a/x11-misc/projecteur/projecteur-0.9.2.ebuild b/x11-misc/projecteur/projecteur-0.9.2.ebuild
index a98d6fdab612..34852f249fa4 100644
--- a/x11-misc/projecteur/projecteur-0.9.2.ebuild
+++ b/x11-misc/projecteur/projecteur-0.9.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -33,7 +33,10 @@ DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
-PATCHES=( "${FILESDIR}/${PN}-0.9.1-dont-compress-manpage.patch" )
+PATCHES=(
+ "${FILESDIR}/${PN}-0.9.1-dont-compress-manpage.patch"
+ "${FILESDIR}/${PN}-0.9.2-gcc12.patch"
+)
src_prepare() {
cmake_src_prepare