summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-gfx/imv/imv-9999.ebuild69
1 files changed, 61 insertions, 8 deletions
diff --git a/media-gfx/imv/imv-9999.ebuild b/media-gfx/imv/imv-9999.ebuild
index 275366fe87f1..927a92ad3595 100644
--- a/media-gfx/imv/imv-9999.ebuild
+++ b/media-gfx/imv/imv-9999.ebuild
@@ -1,30 +1,83 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-
-inherit xdg-utils git-r3
+EAPI=7
+inherit git-r3 toolchain-funcs xdg-utils
DESCRIPTION="Minimal image viewer designed for tiling window manager users"
HOMEPAGE="https://github.com/eXeC64/imv"
-EGIT_REPO_URI="https://github.com/eXeC64/imv.git"
+EGIT_REPO_URI="https://github.com/eXeC64/imv"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS=""
-IUSE="test"
+IUSE="X +freeimage jpeg png svg test tiff wayland"
RESTRICT="!test? ( test )"
+REQUIRED_USE="
+ || ( X wayland )
+"
RDEPEND="
!sys-apps/renameutils
media-libs/fontconfig
media-libs/libsdl2
media-libs/sdl2-ttf
- media-libs/freeimage
+ X? (
+ x11-libs/pango
+ x11-libs/libX11
+ )
+ freeimage? ( media-libs/freeimage )
+ jpeg? ( media-libs/libjpeg-turbo )
+ png? ( media-libs/libpng )
+ svg? ( gnome-base/librsvg )
+ tiff? ( media-libs/tiff )
+ wayland? ( dev-libs/wayland )
+"
+BDEPEND="
+ app-text/asciidoc
+ test? ( dev-util/cmocka )
"
+DEPEND="
+ ${RDEPEND}
+"
+
+src_prepare() {
+ default
+ sed -i -e 's|pkg-config|$(PKG_CONFIG)|g' Makefile || die
+}
-DEPEND="${RDEPEND}
- test? ( dev-util/cmocka )"
+src_configure() {
+ tc-export PKG_CONFIG
+ local WINDOWS
+ if use X; then
+ if ! use wayland; then
+ WINDOWS=x11
+ else
+ WINDOWS=all
+ fi
+ else
+ if use wayland; then
+ WINDOWS=wayland
+ fi
+ fi
+
+ BACKENDS=(
+ BACKEND_FREEIMAGE=$(usex freeimage)
+ BACKEND_JPEG=$(usex jpeg)
+ BACKEND_LIBPNG=$(usex png)
+ BACKEND_LIBRSVG=$(usex svg)
+ BACKEND_LIBTIFF=$(usex tiff)
+ WINDOWS=${WINDOWS}
+ )
+}
+
+src_compile() {
+ emake ${BACKENDS[@]}
+}
+
+src_install() {
+ emake ${BACKENDS[@]} DESTDIR="${D}" install
+}
pkg_postinst() {
xdg_desktop_database_update