summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-arcade/burgerspace/burgerspace-1.9.2-r1.ebuild (renamed from games-arcade/burgerspace/burgerspace-1.9.2.ebuild)21
1 files changed, 13 insertions, 8 deletions
diff --git a/games-arcade/burgerspace/burgerspace-1.9.2.ebuild b/games-arcade/burgerspace/burgerspace-1.9.2-r1.ebuild
index 2dea3767701f..11de206aa181 100644
--- a/games-arcade/burgerspace/burgerspace-1.9.2.ebuild
+++ b/games-arcade/burgerspace/burgerspace-1.9.2-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit autotools games
+EAPI=7
+
+inherit autotools
DESCRIPTION="Clone of the 1982 BurgerTime video game by Data East"
HOMEPAGE="https://perso.b2b2c.ca/~sarrazip/dev/burgerspace.html"
@@ -12,36 +13,40 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="network"
-RESTRICT="test" # doesn't really test anything
+RESTRICT="test" # doesn't really test anything
RDEPEND=">=dev-games/flatzebra-0.1.6"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
src_prepare() {
+ default
+
sed -i \
-e "/^pkgsounddir/ s:sounds.*:\$(PACKAGE)/sounds:" \
-e "/^desktopentrydir/ s:=.*:=/usr/share/applications:" \
-e "/^pixmapdir/ s:=.*:=/usr/share/pixmaps:" \
src/Makefile.am \
|| die
+
sed -i \
-e "/Categories/s:Application;::" \
-e "/Icon/s:\..*::" \
-e "/Terminal/s:0:false:" \
src/burgerspace.desktop.in \
|| die
+
eautoreconf
}
src_configure() {
- egamesconf \
+ econf \
$(use_with network)
}
src_install() {
emake -C src DESTDIR="${D}" install
+
doman doc/${PN}.6
dodoc AUTHORS NEWS README THANKS
- prepgamesdirs
}