summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/activemodel/Manifest1
-rw-r--r--dev-ruby/activemodel/activemodel-6.0.3.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-ruby/activemodel/Manifest b/dev-ruby/activemodel/Manifest
index cade3ca76a82..2671a927c041 100644
--- a/dev-ruby/activemodel/Manifest
+++ b/dev-ruby/activemodel/Manifest
@@ -1,2 +1,3 @@
DIST rails-5.2.4.2.tgz 8823143 BLAKE2B 273bee6ccc2354bcfd8d24b320fe69c24f643c196eba053c727d30b13d4178069068c430a0a4112ae28c3e4b5a5dde0b66a7c46c7c28054f2b7a678427f478af SHA512 21561407a0b606dbd2fb6ad12ef910c0bdf3d5162db7e55f4f41f698280ba73664b0b5594930d4cebcb42a66e2e5e22de3523789818eb424443e8c5b2316b8fc
DIST rails-6.0.2.2.tgz 18556125 BLAKE2B f4ed5cc6cbbfa84fb687aba5a6c8f2f6ab68febb41147c40ed8dbc6253c128adbac6503e65e89fe672f50270716d197d8c05b4e1e286aafd76581fc167e6c5da SHA512 c1aab2d6c72948c75a047aec9d9f651f0c1bae78bb17e2fa0cb393113ee1e59980dc093e6f3fd3b2f3839c9b3bb4afcd0b0badfd9574b35b932275a9d9800689
+DIST rails-6.0.3.tgz 18565682 BLAKE2B fe8601aec070535f487801eec16d944809be824e4833b7a906b47b4099dd5e72515ac3e492e4301dd651657fc2c4547ecbdd2c12265e04aad2758e9e284ad385 SHA512 f4572b4ebba9a79a6910c554f06e71efab5ccc0090e1a620e80b9d3b479cdd21d5a041437d90313e045e47ccc6e44eb21d4e56cc9fe1fb791cf5593427d0501b
diff --git a/dev-ruby/activemodel/activemodel-6.0.3.ebuild b/dev-ruby/activemodel/activemodel-6.0.3.ebuild
new file mode 100644
index 000000000000..84c440523f59
--- /dev/null
+++ b/dev-ruby/activemodel/activemodel-6.0.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activemodel.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Toolkit for building modeling frameworks like Active Record and Active Resource"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~sparc ~x86"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}:*
+"
+
+ruby_add_bdepend "
+ test? (
+ ~dev-ruby/railties-${PV}
+ dev-ruby/test-unit:2
+ dev-ruby/mocha
+ >=dev-ruby/bcrypt-ruby-3.1.7
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ sed -i -e '/load_paths/d' test/cases/helper.rb || die "Unable to remove load paths"
+}