summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-plugins/wmgrabimage/wmgrabimage-0.72-r1.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/x11-plugins/wmgrabimage/wmgrabimage-0.72-r1.ebuild b/x11-plugins/wmgrabimage/wmgrabimage-0.72-r1.ebuild
deleted file mode 100644
index 4ad78dfcd83b..000000000000
--- a/x11-plugins/wmgrabimage/wmgrabimage-0.72-r1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=0
-
-inherit eutils
-
-MY_PN=${PN/grabi/GrabI}
-
-DESCRIPTION="wmGrabImage grabs an image from the WWW and displays it"
-HOMEPAGE="https://www.dockapps.net/wmgrabimage"
-SRC_URI="https://www.dockapps.net/download/${MY_PN}-${PV}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ppc x86"
-IUSE=""
-
-RDEPEND=">=net-misc/wget-1.9-r2
- >=media-gfx/imagemagick-5.5.7.15
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXpm"
-DEPEND="${RDEPEND}
- x11-base/xorg-proto"
-
-S=${WORKDIR}/${MY_PN}-${PV}/${MY_PN}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-noman.patch
- sed -i -e 's/-geom /-geometry /' GrabImage || die "sed failed."
- sed -i -e 's/install -s -m /install -m /' Makefile || die "sed failed."
-}
-
-src_compile() {
- emake clean || die "emake clean failed."
- emake CFLAGS="${CFLAGS} -Wall" SYSTEM="${LDFLAGS}" || die "emake failed."
-}
-
-src_install() {
- dodir /usr/bin
- emake DESTDIR="${D}/usr" install || die "einstall failed."
-
- doman wmGrabImage.1
-
- dodoc ../{BUGS,CHANGES,HINTS,TODO}
-
- domenu "${FILESDIR}"/${PN}.desktop
-}