summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-php/pecl-redis/Manifest4
-rw-r--r--dev-php/pecl-redis/pecl-redis-5.1.1.ebuild52
-rw-r--r--dev-php/pecl-redis/pecl-redis-5.2.1.ebuild52
-rw-r--r--dev-php/pecl-redis/pecl-redis-5.2.2.ebuild52
-rw-r--r--dev-php/pecl-redis/pecl-redis-5.3.1.ebuild61
5 files changed, 0 insertions, 221 deletions
diff --git a/dev-php/pecl-redis/Manifest b/dev-php/pecl-redis/Manifest
index 076440f978be..1153a3511698 100644
--- a/dev-php/pecl-redis/Manifest
+++ b/dev-php/pecl-redis/Manifest
@@ -1,5 +1 @@
-DIST redis-5.1.1.tgz 245205 BLAKE2B b7177be5282b081562a446b1b37c7b46ba0ef382e55f27989d5586346a10f842d050ee46e881e480ea6b768e1259458df565d02193eda13a95704cd5455c1ca2 SHA512 eb6aa538d2ae4115634fd5841e3ccccf788cad13b99e0485fb2af43def85e93328012e5cef66d1be4bdd494be6f68de329a066e41b710e434f94f3ed3401bfee
-DIST redis-5.2.1.tgz 251570 BLAKE2B 297d6130469735a53f6dfb6ffea8c7c813363099eb76f25619f0cbb05cd06f5ecad9c0f30c370e33985523cf26488cf133aa0a48a99075bc6d5796309e3d914d SHA512 de90bf65cce0cb8c5ea28415e4f7bfff23c8bb3dc96ddca3158f94be2e4bd051e13ec3f34429b0e8ceb436096520e3998f544f377d5ef7d4d1df4edba7f66bc2
-DIST redis-5.2.2.tgz 251629 BLAKE2B e6ca740412dd1ba4ee960e1c71b3f75ebb1a1e2605bc93159395c657ab61eda4c8222b6e890a447c06cd1ef016e061861ffc5d8a6fd6e7e324353a148b54c593 SHA512 0020c572bcd24cdb479046727fba2d30ca87c9a7111c51e5fe3be0b85459e3e7dfc8892b690650de0a7dc80c1a8921f9de45590f6e60257fbf0534729c6e6f4f
-DIST redis-5.3.1.tgz 264485 BLAKE2B 51f68841d51329cbbbd2012e539351b3220dc1361ae5a3782b6c3e9620ed14b9a0b9097a0d6ba6e2fa60e8a794fd2ea57fff871d2fceb7bcdb4a2ab4a6d8789f SHA512 dca62e0e87d22c25818f0eb84ec0a4ae8ab4c1a2de295b7d56d10548c95448637e1b1ca86c55adf0f801fe22bf3c05fad4ff58f3823e5d74c506d041b64f1d4a
DIST redis-5.3.2.tgz 266814 BLAKE2B 2be79d850e5958bcaf4fddcbdef0a402e62a522f260ae94c0fdc931a988e9b266c7a4e049b89b507a29a8e9085590e4077e336b85974d70a7cb9b3d6c806949d SHA512 95ce960b78cf94ecd212ec88914935167af37e4176d4b111dfc8c6f1a0846a34beba7f9f516cd7a5e1c9dda23f46cce44c99aaa5b42724c0c2a188b0698af414
diff --git a/dev-php/pecl-redis/pecl-redis-5.1.1.ebuild b/dev-php/pecl-redis/pecl-redis-5.1.1.ebuild
deleted file mode 100644
index f765a4d536ff..000000000000
--- a/dev-php/pecl-redis/pecl-redis-5.1.1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PHP_EXT_NAME="redis"
-USE_PHP="php7-1 php7-2 php7-3 php7-4"
-PHP_EXT_NEEDED_USE="json?,session?"
-DOCS=( arrays.markdown cluster.markdown README.markdown CREDITS )
-MY_P="${PN/pecl-/}-${PV/_rc/RC}"
-PHP_EXT_PECL_FILENAME="${MY_P}.tgz"
-PHP_EXT_S="${WORKDIR}/${MY_P}"
-
-inherit php-ext-pecl-r3
-
-DESCRIPTION="PHP extension for interfacing with Redis"
-LICENSE="PHP-3.01"
-SLOT="0"
-KEYWORDS="amd64 ~arm"
-IUSE="igbinary +json +session"
-
-DEPEND="
- igbinary? ( >=dev-php/igbinary-3.0.1-r1[php_targets_php7-1?,php_targets_php7-2?,php_targets_php7-3?,php_targets_php7-4?] )
-"
-RDEPEND="${DEPEND} !dev-php/pecl-redis:7"
-
-# The test suite requires network access.
-RESTRICT=test
-
-S="${WORKDIR}/${MY_P}"
-
-src_configure() {
- local PHP_EXT_ECONF_ARGS=(
- --enable-redis
- $(use_enable igbinary redis-igbinary)
- $(use_enable json redis-json)
- $(use_enable session redis-session)
- )
- php-ext-source-r3_src_configure
-}
-
-src_test() {
- local slot
- for slot in $(php_get_slots); do
- php_init_slot_env "${slot}"
- # Run tests for Redis class
- ${PHPCLI} -d extension=modules/redis.so \
- tests/TestRedis.php \
- --class Redis \
- --host ${PECL_REDIS_HOST} || die 'test suite failed'
- done
-}
diff --git a/dev-php/pecl-redis/pecl-redis-5.2.1.ebuild b/dev-php/pecl-redis/pecl-redis-5.2.1.ebuild
deleted file mode 100644
index ec5cd6b371d3..000000000000
--- a/dev-php/pecl-redis/pecl-redis-5.2.1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PHP_EXT_NAME="redis"
-USE_PHP="php7-2 php7-3 php7-4"
-PHP_EXT_NEEDED_USE="json?,session?"
-DOCS=( arrays.markdown cluster.markdown README.markdown CREDITS )
-MY_P="${PN/pecl-/}-${PV/_rc/RC}"
-PHP_EXT_PECL_FILENAME="${MY_P}.tgz"
-PHP_EXT_S="${WORKDIR}/${MY_P}"
-
-inherit php-ext-pecl-r3
-
-DESCRIPTION="PHP extension for interfacing with Redis"
-LICENSE="PHP-3.01"
-SLOT="0"
-KEYWORDS="~amd64 ~arm"
-IUSE="igbinary +json +session"
-
-DEPEND="
- igbinary? ( >=dev-php/igbinary-3.0.1-r1[php_targets_php7-2?,php_targets_php7-3?,php_targets_php7-4?] )
-"
-RDEPEND="${DEPEND} !dev-php/pecl-redis:7"
-
-# The test suite requires network access.
-RESTRICT=test
-
-S="${WORKDIR}/${MY_P}"
-
-src_configure() {
- local PHP_EXT_ECONF_ARGS=(
- --enable-redis
- $(use_enable igbinary redis-igbinary)
- $(use_enable json redis-json)
- $(use_enable session redis-session)
- )
- php-ext-source-r3_src_configure
-}
-
-src_test() {
- local slot
- for slot in $(php_get_slots); do
- php_init_slot_env "${slot}"
- # Run tests for Redis class
- ${PHPCLI} -d extension=modules/redis.so \
- tests/TestRedis.php \
- --class Redis \
- --host ${PECL_REDIS_HOST} || die 'test suite failed'
- done
-}
diff --git a/dev-php/pecl-redis/pecl-redis-5.2.2.ebuild b/dev-php/pecl-redis/pecl-redis-5.2.2.ebuild
deleted file mode 100644
index ec5cd6b371d3..000000000000
--- a/dev-php/pecl-redis/pecl-redis-5.2.2.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PHP_EXT_NAME="redis"
-USE_PHP="php7-2 php7-3 php7-4"
-PHP_EXT_NEEDED_USE="json?,session?"
-DOCS=( arrays.markdown cluster.markdown README.markdown CREDITS )
-MY_P="${PN/pecl-/}-${PV/_rc/RC}"
-PHP_EXT_PECL_FILENAME="${MY_P}.tgz"
-PHP_EXT_S="${WORKDIR}/${MY_P}"
-
-inherit php-ext-pecl-r3
-
-DESCRIPTION="PHP extension for interfacing with Redis"
-LICENSE="PHP-3.01"
-SLOT="0"
-KEYWORDS="~amd64 ~arm"
-IUSE="igbinary +json +session"
-
-DEPEND="
- igbinary? ( >=dev-php/igbinary-3.0.1-r1[php_targets_php7-2?,php_targets_php7-3?,php_targets_php7-4?] )
-"
-RDEPEND="${DEPEND} !dev-php/pecl-redis:7"
-
-# The test suite requires network access.
-RESTRICT=test
-
-S="${WORKDIR}/${MY_P}"
-
-src_configure() {
- local PHP_EXT_ECONF_ARGS=(
- --enable-redis
- $(use_enable igbinary redis-igbinary)
- $(use_enable json redis-json)
- $(use_enable session redis-session)
- )
- php-ext-source-r3_src_configure
-}
-
-src_test() {
- local slot
- for slot in $(php_get_slots); do
- php_init_slot_env "${slot}"
- # Run tests for Redis class
- ${PHPCLI} -d extension=modules/redis.so \
- tests/TestRedis.php \
- --class Redis \
- --host ${PECL_REDIS_HOST} || die 'test suite failed'
- done
-}
diff --git a/dev-php/pecl-redis/pecl-redis-5.3.1.ebuild b/dev-php/pecl-redis/pecl-redis-5.3.1.ebuild
deleted file mode 100644
index 9f7ec9e88930..000000000000
--- a/dev-php/pecl-redis/pecl-redis-5.3.1.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PHP_EXT_NAME="redis"
-USE_PHP="php7-2 php7-3 php7-4"
-PHP_EXT_NEEDED_USE="json?,session?"
-DOCS=( arrays.markdown cluster.markdown README.markdown CREDITS )
-MY_P="${PN/pecl-/}-${PV/_rc/RC}"
-PHP_EXT_PECL_FILENAME="${MY_P}.tgz"
-PHP_EXT_S="${WORKDIR}/${MY_P}"
-
-inherit php-ext-pecl-r3
-
-DESCRIPTION="PHP extension for interfacing with Redis"
-LICENSE="PHP-3.01"
-SLOT="0"
-KEYWORDS="~amd64 ~arm"
-IUSE="igbinary +json lz4 +session zstd"
-
-DEPEND="
- igbinary? ( >=dev-php/igbinary-3.0.1-r1[php_targets_php7-2?,php_targets_php7-3?,php_targets_php7-4?] )
- lz4? ( app-arch/lz4:= )
- zstd? ( app-arch/zstd:= )
-"
-RDEPEND="${DEPEND}
- !dev-php/pecl-redis:7"
-
-# The test suite requires network access.
-RESTRICT=test
-
-S="${WORKDIR}/${MY_P}"
-
-src_configure() {
- local PHP_EXT_ECONF_ARGS=(
- --enable-redis
- --disable-redis-lzf
- --disable-redis-msgpack
- $(use_enable igbinary redis-igbinary)
- $(use_enable json redis-json)
- $(use_enable lz4 redis-lz4)
- $(use_with lz4 liblz4)
- $(use_enable session redis-session)
- $(use_enable zstd redis-zstd)
- $(use_with zstd libzstd)
- )
- php-ext-source-r3_src_configure
-}
-
-src_test() {
- local slot
- for slot in $(php_get_slots); do
- php_init_slot_env "${slot}"
- # Run tests for Redis class
- ${PHPCLI} -d extension=modules/redis.so \
- tests/TestRedis.php \
- --class Redis \
- --host ${PECL_REDIS_HOST} || die 'test suite failed'
- done
-}