summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pytest/Manifest1
-rw-r--r--dev-python/pytest/pytest-3.2.2.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/pytest/Manifest b/dev-python/pytest/Manifest
index d6eff506c1c8..3b64c1dbbdcc 100644
--- a/dev-python/pytest/Manifest
+++ b/dev-python/pytest/Manifest
@@ -3,3 +3,4 @@ DIST pytest-3.0.3.tar.gz 731934 SHA256 f213500a356800a483e8a146ff971ae14a8df3f2c
DIST pytest-3.0.6.tar.gz 748748 SHA256 643434a9f1a188271da35e20064cb8b6c5440976c5bb541dc7b5b0e3cf75d940 SHA512 0e983f1f52c18327537d20be30425f4c74037d1fbf6b4aedf2646cf21d450fa9b2b20625f26f5db759b4fe1fd28c6640cb1df88e667efaeea6642e7f02f01e06 WHIRLPOOL 708e5041135883ba31d9712880672f64bf05c0bf40a544061cb42fed4d2aec111bfdf82b63f10e8a87c2b76870e3ea364b396258f0674d2199e43fe93cf2922e
DIST pytest-3.0.7.tar.gz 743866 SHA256 b70696ebd1a5e6b627e7e3ac1365a4bc60aaf3495e843c1e70448966c5224cab SHA512 f458929614fca5bc9542b9adfe2fa5d2c5b97ec13e331d3a9caf256d2d005b3dad9c11d01b2eb62332648f90608ba297a1edc2c20b7630ec4f69114299720a2a WHIRLPOOL 2febc111fed67573296f8c4a758ea36c2a2e81bd425442beace139f7e1bd3eaab7aa2fdcf8e0280871b0692e19d70efe18d780e4dd7336c9dd5d6fb0db2df6c5
DIST pytest-3.1.2.tar.gz 766406 SHA256 795ec29fbba70b22a593691ce8bcd4bdde2dc96e8099731f73c7d8bb3ce879bf SHA512 6b8bf6280481295585169798351105749301a2b088fa89a48c463578a25edcb1fe7ea4100668bc3013a0a6dfd0ceab31c683e9280ece4f79575ca37909502d5c WHIRLPOOL 5c685f928080a5d6d1a979a0dbda1bc851eff855c76bb471ebf131047506c934e68a2e4733c4b265d291558ec1084d0276e77e469bd3d5ec0d91daa97c5eb989
+DIST pytest-3.2.2.tar.gz 786396 SHA256 f46e49e0340a532764991c498244a60e3a37d7424a532b3ff1a6a7653f1a403a SHA512 6df3a50e7d1efeaf7a283920b16d1daf800798f422bc851b0aacd2bbd5cb0a88c95f9057fae49943b9dfe6527ed552cdf8d983b944ab91d0af252ee4f6eb82db WHIRLPOOL 6d41e74696ed879d78f8a50dabb7775fa7631bfd5a6a1dd9df89269d6d3174683776982451f83b32c197cd801796e671e7431b542376a7d343b00e9fc21616b3
diff --git a/dev-python/pytest/pytest-3.2.2.ebuild b/dev-python/pytest/pytest-3.2.2.ebuild
new file mode 100644
index 000000000000..c949a1553ce7
--- /dev/null
+++ b/dev-python/pytest/pytest-3.2.2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple powerful testing with Python"
+HOMEPAGE="http://pytest.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+# When bumping, please check setup.py for the proper py version
+PY_VER="1.4.33"
+COMMON_DEPEND="
+ >=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/hypothesis-3.5.2[${PYTHON_USEDEP}]
+ >dev-python/pytest-xdist-1.13[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${COMMON_DEPEND}
+ !dev-python/logilab-common
+"
+
+python_prepare_all() {
+ chmod o-w *egg*/* || die
+ # Disable versioning of py.test script to avoid collision with
+ # versioning performed by the eclass.
+ sed -e "s/return points/return {'py.test': target}/" -i setup.py || die "sed failed"
+ grep -qF "py>=${PY_VER}" setup.py || die "Incorrect dev-python/py dependency"
+
+ # Something in the ebuild environment causes this to hang/error.
+ # https://bugs.gentoo.org/598442
+ rm testing/test_pdb.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # test_nose.py not written to suit py3.2 in pypy3
+ if [[ "${EPYTHON}" == pypy3 ]]; then
+ "${PYTHON}" "${BUILD_DIR}"/lib/pytest.py --lsof -rfsxX \
+ --ignore=testing/BUILD_nose.py \
+ || die "tests failed with ${EPYTHON}"
+ else
+ "${PYTHON}" "${BUILD_DIR}"/lib/pytest.py --lsof -rfsxX testing || die "tests failed with ${EPYTHON}"
+ fi
+}
+
+python_compile_all(){
+ use doc && emake -C doc/en html
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( doc/en/_build/html/. )
+ distutils-r1_python_install_all
+}