summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/unrardll/Manifest1
-rw-r--r--dev-python/unrardll/metadata.xml16
-rw-r--r--dev-python/unrardll/unrardll-0.1.7.ebuild33
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/unrardll/Manifest b/dev-python/unrardll/Manifest
new file mode 100644
index 000000000000..692799ecadae
--- /dev/null
+++ b/dev-python/unrardll/Manifest
@@ -0,0 +1 @@
+DIST unrardll-0.1.7.tar.gz 10780032 BLAKE2B 92f852ed9cbc02d4c48093dbd5a7f64f4bc279a7b3a3018247a832a61c263b3be19ec5ea94ffdc78c85bd2737647cc3eb231ae9d0953da1de5f23002e7e6ffdc SHA512 23da519c37e52e5cc032d119d1b723c0f4b4ec2c8a08b8ec24a193395d5530780c65a1c20f69aa58f6976ea5e7481c11b92a472cfbce8c477af14673be2189fc
diff --git a/dev-python/unrardll/metadata.xml b/dev-python/unrardll/metadata.xml
new file mode 100644
index 000000000000..34d0dccf4daa
--- /dev/null
+++ b/dev-python/unrardll/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>eschwartz93@gmail.com</email>
+ <name>Eli Schwartz</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">kovidgoyal/unrardll</remote-id>
+ <remote-id type="pypi">unrardll</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/unrardll/unrardll-0.1.7.ebuild b/dev-python/unrardll/unrardll-0.1.7.ebuild
new file mode 100644
index 000000000000..2c4ab30ac2b9
--- /dev/null
+++ b/dev-python/unrardll/unrardll-0.1.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python wrapper for the UnRAR DLL"
+HOMEPAGE="
+ https://github.com/kovidgoyal/unrardll
+ https://pypi.org/project/unrardll/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# The version constraint is needed to resolve https://bugs.gentoo.org/916036
+# and guarantee the headers are findable.
+DEPEND=">=app-arch/unrar-6.2.12-r1:="
+RDEPEND="${DEPEND}"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ default
+ # https://github.com/kovidgoyal/unrardll/pull/5
+ mv test/basic.py test/test_basic.py || die
+}